summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/libc-client
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-devtools/libc-client
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-devtools/libc-client')
-rw-r--r--meta-oe/recipes-devtools/libc-client/files/quote_cctype.patch12
-rw-r--r--meta-oe/recipes-devtools/libc-client/libc-client_2007e.bb35
2 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/libc-client/files/quote_cctype.patch b/meta-oe/recipes-devtools/libc-client/files/quote_cctype.patch
new file mode 100644
index 000000000..f729ee207
--- /dev/null
+++ b/meta-oe/recipes-devtools/libc-client/files/quote_cctype.patch
@@ -0,0 +1,12 @@
1diff -urN imap-2007.orig/Makefile imap-2007/Makefile
2--- imap-2007.orig/Makefile 2007-12-20 23:11:10.000000000 +0100
3+++ imap-2007/Makefile 2008-03-19 14:08:47.000000000 +0100
4@@ -690,7 +690,7 @@
5 @$(SH) -c '(test $(BUILDTYPE) = rebuild -o $(BUILDTYPE) = `$(CAT) OSTYPE`) || (echo Already built for `$(CAT) OSTYPE` -- you must do \"make clean\" first && exit 1)'
6 @echo Rebuilding c-client for `$(CAT) OSTYPE`...
7 @$(TOUCH) SPECIALS
8- $(CD) c-client;$(MAKE) all CC=`$(CAT) CCTYPE` \
9+ $(CD) c-client;$(MAKE) all CC="`$(CAT) CCTYPE`" \
10 CFLAGS="`$(CAT) CFLAGS`" `$(CAT) SPECIALS`
11
12 rebuildclean:
diff --git a/meta-oe/recipes-devtools/libc-client/libc-client_2007e.bb b/meta-oe/recipes-devtools/libc-client/libc-client_2007e.bb
new file mode 100644
index 000000000..150ff9028
--- /dev/null
+++ b/meta-oe/recipes-devtools/libc-client/libc-client_2007e.bb
@@ -0,0 +1,35 @@
1SUMMARY = "UW c-client library for mail protocols"
2SECTION = "devel"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a6a4ddbb7cd2999f6827ee143f6fcd97"
6
7DEPENDS = "openssl libpam"
8
9PR = "r1"
10
11SRC_URI = "ftp://ftp.cac.washington.edu/imap/imap-${PV}.tar.gz \
12 file://quote_cctype.patch"
13
14SRC_URI[md5sum] = "7903800dc2604000016de070e0c55840"
15SRC_URI[sha256sum] = "4b1137b87249782496ec3eeacaf83bbf09312a7d2ae3aead262179041b55565f"
16
17S = "${WORKDIR}/imap-${PV}"
18
19EXTRA_OEMAKE = "CC='${CC}'"
20
21HEADERS = "src/c-client/*.h src/osdep/unix/*.h c-client/auths.c c-client/linkage.c c-client/linkage.h c-client/osdep.h"
22
23do_compile() {
24 echo "SSLINCLUDE=${STAGING_INCDIR} SSLLIB=${STAGING_LIBDIR}" > ${S}/SPECIALS
25 oe_runmake lnp
26}
27
28do_install() {
29 install -d ${D}${includedir}/c-client
30 install ${HEADERS} ${D}${includedir}/c-client
31 install -d ${D}${libdir}
32 install c-client/c-client.a ${D}${libdir}/libc-client.a
33}
34
35ALLOW_EMPTY_${PN} = "1"