summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/kconfig-frontends/kconfig-frontends_4.11.0.1.bb
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2017-06-16 16:15:44 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-19 19:30:41 +0200
commitc2670c4b5c020bfff5900b8cc1c90e220a5263e1 (patch)
treedc2321ffb5abf7904d84b43e07b24af89f34839f /meta-oe/recipes-devtools/kconfig-frontends/kconfig-frontends_4.11.0.1.bb
parentec5bffa7d21ad2ca9576188dcbe0a85b5b6f5158 (diff)
downloadmeta-openembedded-c2670c4b5c020bfff5900b8cc1c90e220a5263e1.tar.gz
kconfig-frontends: Update to 4.11.0.1
No longer needed patches have been removed, and one patch has been backported instead of using the submitted patch. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/kconfig-frontends/kconfig-frontends_4.11.0.1.bb')
-rw-r--r--meta-oe/recipes-devtools/kconfig-frontends/kconfig-frontends_4.11.0.1.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/kconfig-frontends/kconfig-frontends_4.11.0.1.bb b/meta-oe/recipes-devtools/kconfig-frontends/kconfig-frontends_4.11.0.1.bb
new file mode 100644
index 000000000..df08b8b11
--- /dev/null
+++ b/meta-oe/recipes-devtools/kconfig-frontends/kconfig-frontends_4.11.0.1.bb
@@ -0,0 +1,41 @@
1# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Linux kernel style configuration framework for other projects"
5DESCRIPTION = "The kconfig-frontends project aims at centralising \
6the effort of keeping an up-to-date, out-of-tree, packaging of the \
7kconfig infrastructure, ready for use by third-party projects. \
8The kconfig-frontends package provides the kconfig parser, as well as all \
9the frontends"
10HOMEPAGE = "http://ymorin.is-a-geek.org/projects/kconfig-frontends"
11LICENSE = "GPL-2.0"
12LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
13SECTION = "devel"
14DEPENDS += "ncurses flex bison gperf-native"
15RDEPENDS_${PN} += "python3 bash"
16SRC_URI = "git://ymorin.is-a-geek.org/kconfig-frontends;branch=4.11.x \
17 file://0001-Makefile-ensure-frontends-exits-before-writing-into-.patch \
18 file://0001-Switch-utils-kconfig-diff-to-use-Python-3.patch"
19
20SRCREV = "f22fce3a308be1c7790ebefc6bbedb33c5f7c86a"
21
22S = "${WORKDIR}/git"
23
24inherit autotools pkgconfig
25do_configure_prepend () {
26 mkdir -p ${S}/scripts/.autostuff/m4
27}
28
29do_install_append() {
30 ln -s kconfig-conf ${D}${bindir}/conf
31 ln -s kconfig-mconf ${D}${bindir}/mconf
32}
33
34EXTRA_OECONF += "--disable-gconf --disable-qconf"
35
36# Some packages have the version preceeding the .so instead properly
37# versioned .so.<version>, so we need to reorder and repackage.
38SOLIBS = "-${@d.getVar('PV')[:-2]}.so"
39FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so"
40
41BBCLASSEXTEND = "native"