summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/jq/jq_1.7.1.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-12-26 15:01:07 +0800
committerKhem Raj <raj.khem@gmail.com>2023-12-29 09:04:17 -0800
commitbef4681e41882684022a4d95036aab8f2632ed15 (patch)
tree367850152ad8d916deadf375d029c79c5d9db1e2 /meta-oe/recipes-devtools/jq/jq_1.7.1.bb
parent85360acc4d93e135a647bf4819b9ba524df3cdf0 (diff)
downloadmeta-openembedded-bef4681e41882684022a4d95036aab8f2632ed15.tar.gz
jq: upgrade 1.7 -> 1.7.1
Changelog: ========== - CVE-2023-50246: Fix heap buffer overflow in jvp\_literal\_number\_literal - CVE-2023-50268: fix stack-buffer-overflow if comparing nan with payload Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/jq/jq_1.7.1.bb')
-rw-r--r--meta-oe/recipes-devtools/jq/jq_1.7.1.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/jq/jq_1.7.1.bb b/meta-oe/recipes-devtools/jq/jq_1.7.1.bb
new file mode 100644
index 000000000..6b1233551
--- /dev/null
+++ b/meta-oe/recipes-devtools/jq/jq_1.7.1.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Lightweight and flexible command-line JSON processor"
2DESCRIPTION = "jq is like sed for JSON data, you can use it to slice and \
3 filter and map and transform structured data with the same \
4 ease that sed, awk, grep and friends let you play with text."
5HOMEPAGE = "https://jqlang.github.io/jq/"
6BUGTRACKER = "https://github.com/jqlang/jq/issues"
7SECTION = "utils"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://COPYING;md5=488f4e0b04c0456337fb70d1ac1758ba"
10
11GITHUB_BASE_URI = "https://github.com/jqlang/${BPN}/releases/"
12SRC_URI = "${GITHUB_BASE_URI}/download/${BPN}-${PV}/${BPN}-${PV}.tar.gz \
13 file://run-ptest \
14 "
15SRC_URI[sha256sum] = "478c9ca129fd2e3443fe27314b455e211e0d8c60bc8ff7df703873deeee580c2"
16
17inherit autotools github-releases ptest
18
19UPSTREAM_CHECK_REGEX = "releases/tag/${BPN}-(?P<pver>\d+(\.\d+)+)"
20
21PACKAGECONFIG ?= "oniguruma"
22
23PACKAGECONFIG[docs] = "--enable-docs,--disable-docs,ruby-native"
24PACKAGECONFIG[maintainer-mode] = "--enable-maintainer-mode,--disable-maintainer-mode,flex-native bison-native"
25PACKAGECONFIG[oniguruma] = "--with-oniguruma,--without-oniguruma,onig"
26# enable if you want ptest running under valgrind
27PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind"
28
29do_configure:append() {
30 sed -i -e "/^ac_cs_config=/ s:${WORKDIR}::g" ${B}/config.status
31}
32
33do_install_ptest() {
34 cp -rf ${S}/tests ${D}${PTEST_PATH}
35 cp -rf ${B}/.libs ${D}${PTEST_PATH}
36 # libjq.so.* is packaged in the main jq component, so remove it from ptest
37 rm -f ${D}${PTEST_PATH}/.libs/libjq.so.*
38 ln -sf ${bindir}/jq ${D}${PTEST_PATH}
39 if [ "${@bb.utils.contains('PACKAGECONFIG', 'valgrind', 'true', 'false', d)}" = "false" ]; then
40 sed -i 's:#export NO_VALGRIND=1:export NO_VALGRIND=1:g' ${D}${PTEST_PATH}/run-ptest
41 fi
42 # handle multilib
43 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
44}
45
46BBCLASSEXTEND = "native"