diff options
author | Mingli Yu <mingli.yu@windriver.com> | 2021-08-11 13:31:48 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-08-11 10:23:54 -0700 |
commit | 369fd1efe918a27f6ac0dee8e5b2a305817f399f (patch) | |
tree | bef59c93395066c49a37903ffb84284c68de47b8 /meta-oe/recipes-devtools/jemalloc | |
parent | 02aeda00ab3769abc0bd651f7d1c4998f436ac6e (diff) | |
download | meta-openembedded-369fd1efe918a27f6ac0dee8e5b2a305817f399f.tar.gz |
jemalloc: fix the race during do_install
Fixes:
| TOPDIR/tmp-glibc/hosttools/install: cannot stat 'doc/jemalloc.3': No such file or directory
| make: *** [Makefile:513: install_doc_man] Error 1
Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/jemalloc')
-rw-r--r-- | meta-oe/recipes-devtools/jemalloc/files/0001-Makefile.in-make-sure-doc-generated-before-install.patch | 42 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb | 4 |
2 files changed, 45 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/jemalloc/files/0001-Makefile.in-make-sure-doc-generated-before-install.patch b/meta-oe/recipes-devtools/jemalloc/files/0001-Makefile.in-make-sure-doc-generated-before-install.patch new file mode 100644 index 0000000000..0a1fe6d76e --- /dev/null +++ b/meta-oe/recipes-devtools/jemalloc/files/0001-Makefile.in-make-sure-doc-generated-before-install.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | From 1efb45330f5dbe475a092cda6982e6d7e135485a Mon Sep 17 00:00:00 2001 | ||
2 | From: Mingli Yu <mingli.yu@windriver.com> | ||
3 | Date: Tue, 10 Aug 2021 13:02:18 +0000 | ||
4 | Subject: [PATCH] Makefile.in: make sure doc generated before install | ||
5 | |||
6 | There is a race between the doc generation and the doc installation, | ||
7 | so make the install depend on the build for doc to fix the error occurs | ||
8 | sometimes as below: | ||
9 | | TOPDIR/tmp-glibc/hosttools/install: cannot stat 'doc/jemalloc.3': No such file or directory | ||
10 | | make: *** [Makefile:513: install_doc_man] Error 1 | ||
11 | |||
12 | Upstream-Status: Submitted [https://github.com/jemalloc/jemalloc/pull/2108] | ||
13 | |||
14 | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> | ||
15 | --- | ||
16 | Makefile.in | 4 ++-- | ||
17 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
18 | |||
19 | diff --git a/Makefile.in b/Makefile.in | ||
20 | index 7128b007..ab94f0c8 100644 | ||
21 | --- a/Makefile.in | ||
22 | +++ b/Makefile.in | ||
23 | @@ -501,14 +501,14 @@ install_lib: install_lib_static | ||
24 | endif | ||
25 | install_lib: install_lib_pc | ||
26 | |||
27 | -install_doc_html: | ||
28 | +install_doc_html: build_doc_html | ||
29 | $(INSTALL) -d $(DATADIR)/doc/jemalloc$(install_suffix) | ||
30 | @for d in $(DOCS_HTML); do \ | ||
31 | echo "$(INSTALL) -m 644 $$d $(DATADIR)/doc/jemalloc$(install_suffix)"; \ | ||
32 | $(INSTALL) -m 644 $$d $(DATADIR)/doc/jemalloc$(install_suffix); \ | ||
33 | done | ||
34 | |||
35 | -install_doc_man: | ||
36 | +install_doc_man: build_doc_man | ||
37 | $(INSTALL) -d $(MANDIR)/man3 | ||
38 | @for d in $(DOCS_MAN3); do \ | ||
39 | echo "$(INSTALL) -m 644 $$d $(MANDIR)/man3"; \ | ||
40 | -- | ||
41 | 2.29.2 | ||
42 | |||
diff --git a/meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb b/meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb index 39637663f6..b191f729a3 100644 --- a/meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb +++ b/meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb | |||
@@ -13,7 +13,9 @@ SECTION = "libs" | |||
13 | 13 | ||
14 | LIC_FILES_CHKSUM = "file://README;md5=6900e4a158982e4c4715bf16aa54fa10" | 14 | LIC_FILES_CHKSUM = "file://README;md5=6900e4a158982e4c4715bf16aa54fa10" |
15 | 15 | ||
16 | SRC_URI = "git://github.com/jemalloc/jemalloc.git" | 16 | SRC_URI = "git://github.com/jemalloc/jemalloc.git \ |
17 | file://0001-Makefile.in-make-sure-doc-generated-before-install.patch \ | ||
18 | " | ||
17 | 19 | ||
18 | SRCREV = "ea6b3e973b477b8061e0076bb257dbd7f3faa756" | 20 | SRCREV = "ea6b3e973b477b8061e0076bb257dbd7f3faa756" |
19 | 21 | ||