summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/grpc
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-05-29 00:46:02 -0700
committerKhem Raj <raj.khem@gmail.com>2021-05-31 07:48:02 -0700
commit949d9616cbf218934a2e3efb3da5ef0a544a338a (patch)
treed5664ad80363d86169047ea3683362f39b4cef4c /meta-oe/recipes-devtools/grpc
parente8262bab723b98ef094f680d49c8c0bcc136e0e9 (diff)
downloadmeta-openembedded-949d9616cbf218934a2e3efb3da5ef0a544a338a.tar.gz
grpc: Upgrade to 1.38.0
Fix build with musl by checking for iovec redefinition Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/grpc')
-rw-r--r--meta-oe/recipes-devtools/grpc/grpc/0001-gsec-Fix-build-on-musl.patch37
-rw-r--r--meta-oe/recipes-devtools/grpc/grpc_1.38.0.bb (renamed from meta-oe/recipes-devtools/grpc/grpc_1.37.1.bb)4
2 files changed, 39 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/grpc/grpc/0001-gsec-Fix-build-on-musl.patch b/meta-oe/recipes-devtools/grpc/grpc/0001-gsec-Fix-build-on-musl.patch
new file mode 100644
index 000000000..faa18bb7f
--- /dev/null
+++ b/meta-oe/recipes-devtools/grpc/grpc/0001-gsec-Fix-build-on-musl.patch
@@ -0,0 +1,37 @@
1From 9af185be6068d279736c0d2b2162a4e768444d3d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 29 May 2021 00:41:32 -0700
4Subject: [PATCH] gsec: Fix build on musl
5
6musl defines iovec struct in alltypes.h file which is included by many
7system include files, therefore check for appropriate define from musl
8before defining it again
9
10Upstream-Status: Pending
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 src/core/tsi/alts/crypt/gsec.h | 3 +++
14 1 file changed, 3 insertions(+)
15
16diff --git a/src/core/tsi/alts/crypt/gsec.h b/src/core/tsi/alts/crypt/gsec.h
17index 4d65caa944..3c367b2895 100644
18--- a/src/core/tsi/alts/crypt/gsec.h
19+++ b/src/core/tsi/alts/crypt/gsec.h
20@@ -26,11 +26,14 @@
21 #include <stdlib.h>
22
23 #include <grpc/grpc.h>
24+#include <sys/uio.h>
25
26+#if !defined(__DEFINED_struct_iovec)
27 struct iovec {
28 void* iov_base;
29 size_t iov_len;
30 };
31+#endif
32
33 /**
34 * A gsec interface for AEAD encryption schemes. The API is thread-compatible.
35--
362.31.1
37
diff --git a/meta-oe/recipes-devtools/grpc/grpc_1.37.1.bb b/meta-oe/recipes-devtools/grpc/grpc_1.38.0.bb
index a7aabd13f..2095d81d4 100644
--- a/meta-oe/recipes-devtools/grpc/grpc_1.37.1.bb
+++ b/meta-oe/recipes-devtools/grpc/grpc_1.38.0.bb
@@ -16,8 +16,8 @@ RDEPENDS_${PN}-compiler = "${PN}"
16RDEPENDS_${PN}-dev += "${PN}-compiler" 16RDEPENDS_${PN}-dev += "${PN}-compiler"
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19SRCREV_grpc = "8664c8334c05d322fbbdfb9e3b24601a23e9363c" 19SRCREV_grpc = "54dc182082db941aa67c7c3f93ad858c99a16d7d"
20BRANCH = "v1.37.x" 20BRANCH = "v1.38.x"
21SRC_URI = "git://github.com/grpc/grpc.git;protocol=https;name=grpc;branch=${BRANCH} \ 21SRC_URI = "git://github.com/grpc/grpc.git;protocol=https;name=grpc;branch=${BRANCH} \
22 " 22 "
23# Fixes build with older compilers 4.8 especially on ubuntu 14.04 23# Fixes build with older compilers 4.8 especially on ubuntu 14.04