summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/cloud9
diff options
context:
space:
mode:
authorJason Kridner <jdk@ti.com>2011-10-19 18:08:38 -0400
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-21 14:57:30 +0200
commit36423031ae2cc2157232f3bec8f5c9fa53ef215d (patch)
tree2c111897f54947caf4dfda329a1f95dcc6f8121d /meta-oe/recipes-devtools/cloud9
parent949ec2d7319205a3a0366d18291a92541dfa038c (diff)
downloadmeta-openembedded-36423031ae2cc2157232f3bec8f5c9fa53ef215d.tar.gz
Cloud9: incremental submodule and build fixes
Signed-off-by: Jason Kridner <jdk@ti.com>
Diffstat (limited to 'meta-oe/recipes-devtools/cloud9')
-rw-r--r--meta-oe/recipes-devtools/cloud9/cloud9/0001-remove-x86-specific-compiler-flags.patch25
-rw-r--r--meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb89
2 files changed, 79 insertions, 35 deletions
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9/0001-remove-x86-specific-compiler-flags.patch b/meta-oe/recipes-devtools/cloud9/cloud9/0001-remove-x86-specific-compiler-flags.patch
new file mode 100644
index 000000000..099507dfb
--- /dev/null
+++ b/meta-oe/recipes-devtools/cloud9/cloud9/0001-remove-x86-specific-compiler-flags.patch
@@ -0,0 +1,25 @@
1From 2e36a24997feb30ea8325eca5575e2e968909a5f Mon Sep 17 00:00:00 2001
2From: Jason Kridner <jdk@ti.com>
3Date: Thu, 20 Oct 2011 14:45:34 -0400
4Subject: [PATCH] remove x86-specific compiler flags
5
6---
7 wscript | 2 --
8 1 files changed, 0 insertions(+), 2 deletions(-)
9
10diff --git a/../o3/wscript b/../o3/wscript
11index 6e21bee..607e1c3 100644
12--- a/../o3/wscript
13+++ b/../o3/wscript
14@@ -9,8 +9,6 @@ def configure(conf):
15 conf.check_tool('compiler_cxx')
16 conf.check_tool('node_addon')
17 conf.add_os_flags('LDFLAGS','LINKFLAGS')
18- conf.env.append_value('CCFLAGS', ['-O3', '-msse2', '-ffast-math'])
19- conf.env.append_value('CXXFLAGS', ['-O3', '-msse2', '-ffast-math'])
20
21 def build(bld):
22 obj = bld.new_task_gen('cxx', 'shlib', 'node_addon')
23--
241.7.4.1
25
diff --git a/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb
index 05e5bebbe..b06e59260 100644
--- a/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb
+++ b/meta-oe/recipes-devtools/cloud9/cloud9_0.5.1.bb
@@ -3,79 +3,98 @@ HOMEPAGE = "http://c9.io"
3LICENSE = "GPLv3" 3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=4784c3bcff601fd8f9515f52a11e7018" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=4784c3bcff601fd8f9515f52a11e7018"
5 5
6PR = "r4" 6DEPENDS = "nodejs-native"
7
8PR = "r5"
7 9
8SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \ 10SRC_URI = "git://github.com/ajaxorg/cloud9.git;name=cloud9ide \
9 git://github.com/ajaxorg/connect.git;destsuffix=git/support/connect;name=connect \ 11 git://github.com/ajaxorg/o3;destsuffix=o3;name=o3 \
12 git://github.com/ajaxorg/ace.git;destsuffix=git/support/ace;name=ace \
13 git://github.com/ajaxorg/ace.wiki.git;destsuffix=git/support/ace/doc/wiki;name=acewiki \
14 git://github.com/ajaxorg/cockpit.git;destsuffix=git/support/ace/support/cockpit;name=cockpit \
15 git://github.com/ajaxorg/dryice.git;destsuffix=git/support/ace/support/dryice;name=dryice \
16 git://github.com/ajaxorg/pilot.git;destsuffix=git/support/ace/support/pilot;name=pilot \
17 git://github.com/ajaxorg/apf.git;destsuffix=git/support/apf;name=apf \
10 git://github.com/ajaxorg/async.js.git;destsuffix=git/support/asyncjs;name=asyncjs \ 18 git://github.com/ajaxorg/async.js.git;destsuffix=git/support/asyncjs;name=asyncjs \
19 git://github.com/ajaxorg/connect.git;destsuffix=git/support/connect;name=connect \
20 git://github.com/jashkenas/coffee-script.git;destsuffix=git/support/connect/support/coffee-script;name=coffee-script \
21 git://github.com/visionmedia/expresso.git;destsuffix=git/support/connect/support/expresso;name=expresso \
22 git://github.com/visionmedia/node-jscoverage.git;destsuffix=git/support/connect/support/expresso/deps/jscoverage;name=jscoverage \
23 git://github.com/cloudhead/less.js.git;destsuffix=git/support/connect/support/less;name=less \
24 git://github.com/visionmedia/sass.js.git;destsuffix=git/support/connect/support/sass;name=sass \
11 git://github.com/ajaxorg/jsDAV.git;destsuffix=git/support/jsdav;name=jsdav \ 25 git://github.com/ajaxorg/jsDAV.git;destsuffix=git/support/jsdav;name=jsdav \
26 git://github.com/fjakobs/async.js.git;destsuffix=git/support/jsdav/support/async.js;name=async-js \
27 git://github.com/felixge/node-formidable.git;destsuffix=git/support/jsdav/support/formidable;name=formidable \
28 git://github.com/ajaxorg/jsftp.git;destsuffix=git/support/jsdav/support/jsftp;name=jsftp \
29 git://github.com/Gozala/streamer.git;destsuffix=git/support/jsdav/support/jsftp/support/streamer;name=streamer \
30 git://github.com/ajaxorg/node-sftp.git;destsuffix=git/support/jsdav/support/node-sftp;name=sftp \
12 git://github.com/ajaxorg/lib-v8debug.git;destsuffix=git/support/lib-v8debug;name=lib-v8debug \ 31 git://github.com/ajaxorg/lib-v8debug.git;destsuffix=git/support/lib-v8debug;name=lib-v8debug \
13 git://github.com/ajaxorg/ace.git;destsuffix=git/support/ace;name=ace \
14 git://github.com/ajaxorg/apf.git;destsuffix=git/support/apf;name=apf \
15 git://github.com/ajaxorg/node-builds-v4.git;destsuffix=git/support/node-builds-v4;name=node-builds-v4 \
16 git://github.com/ajaxorg/gnu-builds.git;destsuffix=git/support/gnu-builds;name=gnu-builds \
17 git://github.com/ajaxorg/socket.io.git;destsuffix=git/support/socket.io;name=socketio \ 32 git://github.com/ajaxorg/socket.io.git;destsuffix=git/support/socket.io;name=socketio \
18 git://github.com/ajaxorg/socket.io-client.git;destsuffix=git/support/socket.io-client;name=socketio-client \ 33 git://github.com/ajaxorg/socket.io-client.git;destsuffix=git/support/socket.io-client;name=socketio-client \
19 git://github.com/ajaxorg/UglifyJS.git;destsuffix=git/support/uglify-js;name=uglifyjs \ 34 git://github.com/ajaxorg/UglifyJS.git;destsuffix=git/support/uglify-js;name=uglify-js \
35 file://0001-remove-x86-specific-compiler-flags.patch \
20 file://cloud9.service \ 36 file://cloud9.service \
21 " 37 "
22 38
23SRCREV_cloud9ide = "593948c9aaded845cb8f3ced49ef41428e351264" 39SRCREV_cloud9ide = "f2bb59777c0c1fa9c82e8307094e3595e2c9db0b"
24SRCREV_connect = "3d1d77a113fa2f18020f562832dca3d4c2d717a2" 40SRCREV_o3 = "806422e9fd12251d4a3bb408fd86773867d7e09a"
41SRCREV_ace = "9ec72ff319c06c4a1f93dae3157021eefbac338d"
42SRCREV_acewiki = "cc5ccde4565f7b21c81345f47e941e011e94b810"
43SRCREV_cockpit = "33f02ab3af5d755c98b3c58309ac2c62fc6de736"
44SRCREV_dryice = "375d9a339646d70846ad40eddaad406198dd9d40"
45SRCREV_pilot = "48ddaa841476ddf9210ccbb2b310952db8212084"
46SRCREV_apf = "6bdac74916fe85a6f63eb8561667628b5ede659c"
25SRCREV_asyncjs = "d36ead408e2959b1e99572114ef3a1b6a48c1072" 47SRCREV_asyncjs = "d36ead408e2959b1e99572114ef3a1b6a48c1072"
48SRCREV_connect = "6bec95b51f2286b942bc7f340d62d816bcdc13d4"
49SRCREV_coffee-script = "a53c104db16d3ac9d13cf9f16834edec250b9749"
50SRCREV_expresso = "7f10ab7fa655299b4e2f519065b0495e6ac34ef2"
51SRCREV_jscoverage = "0d4608a6b4275b020ba665389aa75897d5d4a584"
52SRCREV_less = "a2807288008587b95c6c2f8ba5cac16f1bcab98f"
53SRCREV_sass = "4dfd4c699e7a8baf226215ab044854c4507f4420"
26SRCREV_jsdav = "f1d1f691fdb521701c1c06d158d213575e4e4e5e" 54SRCREV_jsdav = "f1d1f691fdb521701c1c06d158d213575e4e4e5e"
55SRCREV_async-js = "92fb710a70efd3cdc2376ebfba71a7fb3a4f1651"
56SRCREV_formidable = "0cba820cabc23250d47754e57d9f61cc73d12f2a"
57SRCREV_jsftp = "2343ab78e61dfe35312d4adabbc6ee36e0afd122"
58SRCREV_streamer = "1a7f75d4065819171ac91a09974199b932dbe17d"
59SRCREV_sftp = "a0539345134970d7535a19cb2608e3d1bc119d71"
27SRCREV_lib-v8debug = "29b20d01e6854da2173e1665ea141dab6b5a8104" 60SRCREV_lib-v8debug = "29b20d01e6854da2173e1665ea141dab6b5a8104"
28SRCREV_ace = "d85acd115e88e4461a04fafc6a93a801aeb057ec"
29SRCREV_apf = "a7e0daa29573f319f22be5a6cfa275243502604b"
30SRCREV_node-builds-v4 = "2e3ac47b7b8d506147feb08372cc36b988b6195a"
31SRCREV_gnu-builds = "9ff133d95f9a41d749fe16220d81517dad9a2db3"
32SRCREV_socketio = "8f82b1e4e1076a3092fed77e0dc9379425f59b9d" 61SRCREV_socketio = "8f82b1e4e1076a3092fed77e0dc9379425f59b9d"
33SRCREV_socketio-client = "7b5335d1ed88564928a5d00d8a750ff9f9c627a5" 62SRCREV_socketio-client = "7b5335d1ed88564928a5d00d8a750ff9f9c627a5"
34SRCREV_uglifyjs = "941c845c4a01e4e47a158458fe846eb36d0828ad" 63SRCREV_uglify-js = "941c845c4a01e4e47a158458fe846eb36d0828ad"
35 64
36SRCREV_FORMAT = "cloud9ide" 65SRCREV_FORMAT = "cloud9ide"
37 66
38S = "${WORKDIR}/git" 67S = "${WORKDIR}/git"
39 68
40# Most of cloud9 is in git submodules that still need to be fetched. 69do_configure () {
41do_configure_prepend () { 70 cd ${WORKDIR}/o3
42 git submodule update --init --recursive 71 node-waf configure
43} 72}
44 73
45# There's nothing left to be compiled at this time.
46# node-o3-xml is the only compiled code module in here.
47# The repository has binaries for:
48# Linux ARM armv7
49# Linux x86 32/64-bit
50# Sun Solaris 32-bit
51# Mac x86 32/64-bit
52# Windows x86 32-bit
53do_compile () { 74do_compile () {
54: 75 cd ${WORKDIR}/o3
76 node tools/gluegen.js
77 node-waf
55} 78}
56 79
57do_install () { 80do_install () {
58 install -m 0755 -d ${D}/usr/share/cloud9 ${D}${bindir} ${D}/var/lib/cloud9 81 install -m 0755 -d ${D}/usr/share/cloud9 ${D}${bindir} ${D}/var/lib/cloud9
59 rsync -r --exclude=".*" ${S}/* ${D}/usr/share/cloud9 82 rsync -r --exclude=".*" ${S}/* ${D}/usr/share/cloud9
60 83
61 for i in cygwin darwin linux32 linux64 sunos ; do
62 rm -f ${D}/usr/share/cloud9/support/node-builds-v4/*$i*
63 rm -f ${D}/usr/share/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/*$i*
64 rm -f ${D}//usr/share/cloud9/support/gnu-builds/*$i*
65 done
66
67 touch ${D}${bindir}/cloud9 84 touch ${D}${bindir}/cloud9
68 echo "#!/bin/sh" > ${D}${bindir}/cloud9 85 echo "#!/bin/sh" > ${D}${bindir}/cloud9
69 echo "node /usr/share/cloud9/bin/cloud9.js -l 0.0.0.0 -w /var/lib/cloud9 -p 3000" >> ${D}${bindir}/cloud9 86 echo "node /usr/share/cloud9/bin/cloud9.js -l 0.0.0.0 -w /var/lib/cloud9 -p 3000" >> ${D}${bindir}/cloud9
70 chmod 0755 ${D}${bindir}/cloud9 87 chmod 0755 ${D}${bindir}/cloud9
71 88
72 install -d ${D}${base_libdir}/systemd/system 89 install -m 0755 -d ${D}/usr/share/cloud9/support/jsdav/support/node-o3-xml/lib
90 install -m 0644 ${WORKDIR}/o3/modules/o3.js ${D}/usr/share/cloud9/support/jsdav/support/node-o3-xml/lib/o3-xml.js
91 install -m 0755 ${WORKDIR}/o3/build/default/o3.node ${D}/usr/share/cloud9/support/jsdav/support/node-o3-xml/lib/o3.node
92
93 install -m 0755 -d ${D}${base_libdir}/systemd/system
73 install -m 0644 ${WORKDIR}/*.service ${D}${base_libdir}/systemd/system/ 94 install -m 0644 ${WORKDIR}/*.service ${D}${base_libdir}/systemd/system/
74} 95}
75 96
76 97
77FILES_${PN}-dbg += "/usr/share/cloud9/support/jsdav/support/node-o3-xml-v4/lib/o3-xml/.debug"
78
79FILES_${PN} += "${base_libdir}/systemd/system" 98FILES_${PN} += "${base_libdir}/systemd/system"
80RDEPENDS_${PN} = "nodejs gzip" 99RDEPENDS_${PN} = "nodejs gzip"
81 100