diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-03-13 15:31:20 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-03-14 00:00:16 -0800 |
commit | 874bdec053fc4467bede5701c74f9389fbdabd3a (patch) | |
tree | d9e302b5524c69ff916e3049a7b60d78be0412b1 /meta-oe/recipes-devtools/breakpad | |
parent | eecfefa5cab7dfc71392706c06735060233bad26 (diff) | |
download | meta-openembedded-874bdec053fc4467bede5701c74f9389fbdabd3a.tar.gz |
breakpad: Upgrade to latest
License-Update: added APSL 2.0 and BSD-3-Clause and libunwind license
Forward patches as needed and drop patches applied upstream
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/breakpad')
8 files changed, 49 insertions, 164 deletions
diff --git a/meta-oe/recipes-devtools/breakpad/breakpad/0001-Turn-off-sign-compare-for-musl-libc.patch b/meta-oe/recipes-devtools/breakpad/breakpad/0001-Turn-off-sign-compare-for-musl-libc.patch index 33bae1a373..6b8d011d8b 100644 --- a/meta-oe/recipes-devtools/breakpad/breakpad/0001-Turn-off-sign-compare-for-musl-libc.patch +++ b/meta-oe/recipes-devtools/breakpad/breakpad/0001-Turn-off-sign-compare-for-musl-libc.patch | |||
@@ -13,11 +13,9 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
13 | src/client/linux/crash_generation/crash_generation_server.cc | 10 ++++++++++ | 13 | src/client/linux/crash_generation/crash_generation_server.cc | 10 ++++++++++ |
14 | 1 file changed, 10 insertions(+) | 14 | 1 file changed, 10 insertions(+) |
15 | 15 | ||
16 | diff --git a/src/client/linux/crash_generation/crash_generation_server.cc b/src/client/linux/crash_generation/crash_generation_server.cc | ||
17 | index 2596afde..2faeb9e5 100644 | ||
18 | --- a/src/client/linux/crash_generation/crash_generation_server.cc | 16 | --- a/src/client/linux/crash_generation/crash_generation_server.cc |
19 | +++ b/src/client/linux/crash_generation/crash_generation_server.cc | 17 | +++ b/src/client/linux/crash_generation/crash_generation_server.cc |
20 | @@ -230,8 +230,18 @@ CrashGenerationServer::ClientEvent(short revents) | 18 | @@ -230,8 +230,18 @@ CrashGenerationServer::ClientEvent(short |
21 | // Walk the control payload and extract the file descriptor and validated pid. | 19 | // Walk the control payload and extract the file descriptor and validated pid. |
22 | pid_t crashing_pid = -1; | 20 | pid_t crashing_pid = -1; |
23 | int signal_fd = -1; | 21 | int signal_fd = -1; |
@@ -28,7 +26,7 @@ index 2596afde..2faeb9e5 100644 | |||
28 | + #pragma clang diagnostic push | 26 | + #pragma clang diagnostic push |
29 | + #pragma clang diagnostic ignored "-Wsign-compare" | 27 | + #pragma clang diagnostic ignored "-Wsign-compare" |
30 | +#endif | 28 | +#endif |
31 | for (struct cmsghdr *hdr = CMSG_FIRSTHDR(&msg); hdr; | 29 | for (struct cmsghdr* hdr = CMSG_FIRSTHDR(&msg); hdr; |
32 | hdr = CMSG_NXTHDR(&msg, hdr)) { | 30 | hdr = CMSG_NXTHDR(&msg, hdr)) { |
33 | +#ifndef __GLIBC__ | 31 | +#ifndef __GLIBC__ |
34 | + #pragma clang diagnostic pop | 32 | + #pragma clang diagnostic pop |
@@ -36,6 +34,3 @@ index 2596afde..2faeb9e5 100644 | |||
36 | if (hdr->cmsg_level != SOL_SOCKET) | 34 | if (hdr->cmsg_level != SOL_SOCKET) |
37 | continue; | 35 | continue; |
38 | if (hdr->cmsg_type == SCM_RIGHTS) { | 36 | if (hdr->cmsg_type == SCM_RIGHTS) { |
39 | -- | ||
40 | 2.14.1 | ||
41 | |||
diff --git a/meta-oe/recipes-devtools/breakpad/breakpad/0001-include-sys-reg.h-to-get-__WORDSIZE-on-musl-libc.patch b/meta-oe/recipes-devtools/breakpad/breakpad/0001-include-sys-reg.h-to-get-__WORDSIZE-on-musl-libc.patch index 4583d601a8..3dc55cf1fc 100644 --- a/meta-oe/recipes-devtools/breakpad/breakpad/0001-include-sys-reg.h-to-get-__WORDSIZE-on-musl-libc.patch +++ b/meta-oe/recipes-devtools/breakpad/breakpad/0001-include-sys-reg.h-to-get-__WORDSIZE-on-musl-libc.patch | |||
@@ -7,22 +7,20 @@ Subject: [PATCH 1/3] include <sys/reg.h> to get __WORDSIZE on musl libc | |||
7 | src/common/linux/elf_core_dump.h | 1 + | 7 | src/common/linux/elf_core_dump.h | 1 + |
8 | 1 file changed, 1 insertion(+) | 8 | 1 file changed, 1 insertion(+) |
9 | 9 | ||
10 | Index: git/src/common/linux/elf_core_dump.h | 10 | --- a/src/common/linux/elf_core_dump.h |
11 | =================================================================== | 11 | +++ b/src/common/linux/elf_core_dump.h |
12 | --- git.orig/src/common/linux/elf_core_dump.h | 12 | @@ -33,10 +33,14 @@ |
13 | +++ git/src/common/linux/elf_core_dump.h | ||
14 | @@ -33,10 +33,13 @@ | ||
15 | #ifndef COMMON_LINUX_ELF_CORE_DUMP_H_ | 13 | #ifndef COMMON_LINUX_ELF_CORE_DUMP_H_ |
16 | #define COMMON_LINUX_ELF_CORE_DUMP_H_ | 14 | #define COMMON_LINUX_ELF_CORE_DUMP_H_ |
17 | 15 | ||
18 | +#include <config.h> | 16 | +#include <config.h> |
19 | #include <elf.h> | 17 | #include <elf.h> |
18 | #include <limits.h> | ||
20 | #include <link.h> | 19 | #include <link.h> |
21 | #include <stddef.h> | 20 | #include <stddef.h> |
22 | - | ||
23 | +#ifdef HAVE_SYS_REG_H | 21 | +#ifdef HAVE_SYS_REG_H |
24 | +#include <sys/reg.h> | 22 | +#include <sys/reg.h> |
25 | +#endif | 23 | +#endif |
24 | |||
26 | #include "common/memory_range.h" | 25 | #include "common/memory_range.h" |
27 | 26 | ||
28 | namespace google_breakpad { | ||
diff --git a/meta-oe/recipes-devtools/breakpad/breakpad/0002-Use-_fpstate-instead-of-_libc_fpstate-on-linux.patch b/meta-oe/recipes-devtools/breakpad/breakpad/0002-Use-_fpstate-instead-of-_libc_fpstate-on-linux.patch deleted file mode 100644 index 6c097cd22e..0000000000 --- a/meta-oe/recipes-devtools/breakpad/breakpad/0002-Use-_fpstate-instead-of-_libc_fpstate-on-linux.patch +++ /dev/null | |||
@@ -1,60 +0,0 @@ | |||
1 | From 0ba1b3e35e7c743b670bedc3e90001dfb868df10 Mon Sep 17 00:00:00 2001 | ||
2 | From: Felix Janda <felix.janda@posteo.de> | ||
3 | Date: Sun, 1 Feb 2015 13:45:51 +0100 | ||
4 | Subject: [PATCH 2/6] Use _fpstate instead of _libc_fpstate on linux | ||
5 | |||
6 | glibc defines both. musl libc only the former. | ||
7 | --- | ||
8 | src/client/linux/dump_writer_common/ucontext_reader.cc | 4 ++-- | ||
9 | src/client/linux/dump_writer_common/ucontext_reader.h | 2 +- | ||
10 | src/client/linux/minidump_writer/minidump_writer.h | 2 +- | ||
11 | 3 files changed, 4 insertions(+), 4 deletions(-) | ||
12 | |||
13 | Index: git/src/client/linux/dump_writer_common/ucontext_reader.cc | ||
14 | =================================================================== | ||
15 | --- git.orig/src/client/linux/dump_writer_common/ucontext_reader.cc | ||
16 | +++ git/src/client/linux/dump_writer_common/ucontext_reader.cc | ||
17 | @@ -49,7 +49,7 @@ uintptr_t UContextReader::GetInstruction | ||
18 | } | ||
19 | |||
20 | void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext_t *uc, | ||
21 | - const struct _libc_fpstate* fp) { | ||
22 | + const struct _fpstate* fp) { | ||
23 | const greg_t* regs = uc->uc_mcontext.gregs; | ||
24 | |||
25 | out->context_flags = MD_CONTEXT_X86_FULL | | ||
26 | @@ -97,7 +97,7 @@ uintptr_t UContextReader::GetInstruction | ||
27 | } | ||
28 | |||
29 | void UContextReader::FillCPUContext(RawContextCPU *out, const ucontext_t *uc, | ||
30 | - const struct _libc_fpstate* fpregs) { | ||
31 | + const struct _fpstate* fpregs) { | ||
32 | const greg_t* regs = uc->uc_mcontext.gregs; | ||
33 | |||
34 | out->context_flags = MD_CONTEXT_AMD64_FULL; | ||
35 | Index: git/src/client/linux/dump_writer_common/ucontext_reader.h | ||
36 | =================================================================== | ||
37 | --- git.orig/src/client/linux/dump_writer_common/ucontext_reader.h | ||
38 | +++ git/src/client/linux/dump_writer_common/ucontext_reader.h | ||
39 | @@ -50,7 +50,7 @@ struct UContextReader { | ||
40 | // info: the collection of register structures. | ||
41 | #if defined(__i386__) || defined(__x86_64) | ||
42 | static void FillCPUContext(RawContextCPU *out, const ucontext_t *uc, | ||
43 | - const struct _libc_fpstate* fp); | ||
44 | + const struct _fpstate* fp); | ||
45 | #elif defined(__aarch64__) | ||
46 | static void FillCPUContext(RawContextCPU *out, const ucontext_t *uc, | ||
47 | const struct fpsimd_context* fpregs); | ||
48 | Index: git/src/client/linux/minidump_writer/minidump_writer.h | ||
49 | =================================================================== | ||
50 | --- git.orig/src/client/linux/minidump_writer/minidump_writer.h | ||
51 | +++ git/src/client/linux/minidump_writer/minidump_writer.h | ||
52 | @@ -48,7 +48,7 @@ class ExceptionHandler; | ||
53 | #if defined(__aarch64__) | ||
54 | typedef struct fpsimd_context fpstate_t; | ||
55 | #elif !defined(__ARM_EABI__) && !defined(__mips__) | ||
56 | -typedef struct _libc_fpstate fpstate_t; | ||
57 | +typedef struct _fpstate fpstate_t; | ||
58 | #endif | ||
59 | |||
60 | // These entries store a list of memory regions that the client wants included | ||
diff --git a/meta-oe/recipes-devtools/breakpad/breakpad/0002-sys-signal.h-is-a-nonportable-alias-for-signal.h.patch b/meta-oe/recipes-devtools/breakpad/breakpad/0002-sys-signal.h-is-a-nonportable-alias-for-signal.h.patch deleted file mode 100644 index cfd9a9b34e..0000000000 --- a/meta-oe/recipes-devtools/breakpad/breakpad/0002-sys-signal.h-is-a-nonportable-alias-for-signal.h.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From 15582e19c2545d5ffe8ff07f957d0ed602aeca74 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 14 Sep 2017 23:15:09 -0700 | ||
4 | Subject: [PATCH 2/5] <sys/signal.h> is a nonportable alias for <signal.h> | ||
5 | |||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
7 | --- | ||
8 | src/client/linux/handler/exception_handler.cc | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/src/client/linux/handler/exception_handler.cc b/src/client/linux/handler/exception_handler.cc | ||
12 | index 05936d28..cca023fd 100644 | ||
13 | --- a/src/client/linux/handler/exception_handler.cc | ||
14 | +++ b/src/client/linux/handler/exception_handler.cc | ||
15 | @@ -78,7 +78,7 @@ | ||
16 | #include <sys/wait.h> | ||
17 | #include <unistd.h> | ||
18 | |||
19 | -#include <sys/signal.h> | ||
20 | +#include <signal.h> | ||
21 | #include <sys/ucontext.h> | ||
22 | #include <sys/user.h> | ||
23 | #include <ucontext.h> | ||
24 | -- | ||
25 | 2.14.1 | ||
26 | |||
diff --git a/meta-oe/recipes-devtools/breakpad/breakpad/0003-Dont-include-stab.h.patch b/meta-oe/recipes-devtools/breakpad/breakpad/0003-Dont-include-stab.h.patch index 2593ea93ea..76b2088b01 100644 --- a/meta-oe/recipes-devtools/breakpad/breakpad/0003-Dont-include-stab.h.patch +++ b/meta-oe/recipes-devtools/breakpad/breakpad/0003-Dont-include-stab.h.patch | |||
@@ -10,10 +10,8 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
10 | src/common/stabs_reader_unittest.cc | 1 - | 10 | src/common/stabs_reader_unittest.cc | 1 - |
11 | 3 files changed, 11 insertions(+), 3 deletions(-) | 11 | 3 files changed, 11 insertions(+), 3 deletions(-) |
12 | 12 | ||
13 | Index: git/src/common/stabs_reader.cc | 13 | --- a/src/common/stabs_reader.cc |
14 | =================================================================== | 14 | +++ b/src/common/stabs_reader.cc |
15 | --- git.orig/src/common/stabs_reader.cc | ||
16 | +++ git/src/common/stabs_reader.cc | ||
17 | @@ -34,7 +34,9 @@ | 15 | @@ -34,7 +34,9 @@ |
18 | #include "common/stabs_reader.h" | 16 | #include "common/stabs_reader.h" |
19 | 17 | ||
@@ -24,10 +22,8 @@ Index: git/src/common/stabs_reader.cc | |||
24 | #include <string.h> | 22 | #include <string.h> |
25 | 23 | ||
26 | #include <string> | 24 | #include <string> |
27 | Index: git/src/common/stabs_reader.h | 25 | --- a/src/common/stabs_reader.h |
28 | =================================================================== | 26 | +++ b/src/common/stabs_reader.h |
29 | --- git.orig/src/common/stabs_reader.h | ||
30 | +++ git/src/common/stabs_reader.h | ||
31 | @@ -58,6 +58,30 @@ | 27 | @@ -58,6 +58,30 @@ |
32 | #elif defined(HAVE_A_OUT_H) | 28 | #elif defined(HAVE_A_OUT_H) |
33 | #include <a.out.h> | 29 | #include <a.out.h> |
@@ -59,10 +55,8 @@ Index: git/src/common/stabs_reader.h | |||
59 | 55 | ||
60 | #include <string> | 56 | #include <string> |
61 | #include <vector> | 57 | #include <vector> |
62 | Index: git/src/common/stabs_reader_unittest.cc | 58 | --- a/src/common/stabs_reader_unittest.cc |
63 | =================================================================== | 59 | +++ b/src/common/stabs_reader_unittest.cc |
64 | --- git.orig/src/common/stabs_reader_unittest.cc | ||
65 | +++ git/src/common/stabs_reader_unittest.cc | ||
66 | @@ -33,7 +33,9 @@ | 60 | @@ -33,7 +33,9 @@ |
67 | 61 | ||
68 | #include <assert.h> | 62 | #include <assert.h> |
@@ -73,16 +67,14 @@ Index: git/src/common/stabs_reader_unittest.cc | |||
73 | #include <stdarg.h> | 67 | #include <stdarg.h> |
74 | #include <stdlib.h> | 68 | #include <stdlib.h> |
75 | #include <string.h> | 69 | #include <string.h> |
76 | Index: git/configure.ac | 70 | --- a/configure.ac |
77 | =================================================================== | 71 | +++ b/configure.ac |
78 | --- git.orig/configure.ac | ||
79 | +++ git/configure.ac | ||
80 | @@ -72,7 +72,7 @@ AC_ARG_ENABLE(m32, | 72 | @@ -72,7 +72,7 @@ AC_ARG_ENABLE(m32, |
81 | AC_HEADER_STDC | 73 | AC_HEADER_STDC |
82 | AC_SYS_LARGEFILE | 74 | AC_SYS_LARGEFILE |
83 | AX_PTHREAD | 75 | AX_PTHREAD |
84 | -AC_CHECK_HEADERS([a.out.h sys/random.h]) | 76 | -AC_CHECK_HEADERS([a.out.h sys/mman.h sys/random.h]) |
85 | +AC_CHECK_HEADERS([a.out.h stab.h sys/random.h]) | 77 | +AC_CHECK_HEADERS([a.out.h stab.h sys/mman.h sys/random.h]) |
86 | AC_CHECK_FUNCS([arc4random getrandom]) | 78 | AC_CHECK_FUNCS([arc4random getcontext getrandom memfd_create]) |
87 | 79 | AM_CONDITIONAL([HAVE_GETCONTEXT], [test "x$ac_cv_func_getcontext" = xyes]) | |
88 | AX_CXX_COMPILE_STDCXX(11, noext, mandatory) | 80 | AM_CONDITIONAL([HAVE_MEMFD_CREATE], [test "x$ac_cv_func_memfd_create" = xyes]) |
diff --git a/meta-oe/recipes-devtools/breakpad/breakpad/0004-elf_reader.cc-include-sys-reg.h-to-get-__WORDSIZE-on.patch b/meta-oe/recipes-devtools/breakpad/breakpad/0004-elf_reader.cc-include-sys-reg.h-to-get-__WORDSIZE-on.patch index 525a1555bd..5892cfa7d6 100644 --- a/meta-oe/recipes-devtools/breakpad/breakpad/0004-elf_reader.cc-include-sys-reg.h-to-get-__WORDSIZE-on.patch +++ b/meta-oe/recipes-devtools/breakpad/breakpad/0004-elf_reader.cc-include-sys-reg.h-to-get-__WORDSIZE-on.patch | |||
@@ -9,35 +9,33 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
9 | src/common/dwarf/elf_reader.cc | 1 + | 9 | src/common/dwarf/elf_reader.cc | 1 + |
10 | 1 file changed, 1 insertion(+) | 10 | 1 file changed, 1 insertion(+) |
11 | 11 | ||
12 | Index: git/src/common/dwarf/elf_reader.cc | 12 | --- a/src/common/dwarf/elf_reader.cc |
13 | =================================================================== | 13 | +++ b/src/common/dwarf/elf_reader.cc |
14 | --- git.orig/src/common/dwarf/elf_reader.cc | 14 | @@ -30,12 +30,16 @@ |
15 | +++ git/src/common/dwarf/elf_reader.cc | ||
16 | @@ -29,10 +29,13 @@ | ||
17 | #ifndef _GNU_SOURCE | ||
18 | #define _GNU_SOURCE // needed for pread() | 15 | #define _GNU_SOURCE // needed for pread() |
19 | #endif | 16 | #endif |
20 | - | 17 | |
21 | +#include <config.h> | 18 | +#include <config.h> |
22 | #include <sys/types.h> | 19 | #include <fcntl.h> |
23 | #include <sys/stat.h> | 20 | #include <limits.h> |
21 | #include <string.h> | ||
24 | #include <sys/mman.h> | 22 | #include <sys/mman.h> |
23 | #include <sys/stat.h> | ||
24 | #include <sys/types.h> | ||
25 | +#ifdef HAVE_SYS_REG_H | 25 | +#ifdef HAVE_SYS_REG_H |
26 | +#include <sys/reg.h> | 26 | +#include <sys/reg.h> |
27 | +#endif | 27 | +#endif |
28 | #include <unistd.h> | 28 | #include <unistd.h> |
29 | #include <fcntl.h> | 29 | |
30 | #include <string.h> | 30 | #include <algorithm> |
31 | Index: git/configure.ac | 31 | --- a/configure.ac |
32 | =================================================================== | 32 | +++ b/configure.ac |
33 | --- git.orig/configure.ac | ||
34 | +++ git/configure.ac | ||
35 | @@ -72,7 +72,7 @@ AC_ARG_ENABLE(m32, | 33 | @@ -72,7 +72,7 @@ AC_ARG_ENABLE(m32, |
36 | AC_HEADER_STDC | 34 | AC_HEADER_STDC |
37 | AC_SYS_LARGEFILE | 35 | AC_SYS_LARGEFILE |
38 | AX_PTHREAD | 36 | AX_PTHREAD |
39 | -AC_CHECK_HEADERS([a.out.h stab.h sys/random.h]) | 37 | -AC_CHECK_HEADERS([a.out.h stab.h sys/mman.h sys/random.h]) |
40 | +AC_CHECK_HEADERS([a.out.h stab.h sys/random.h sys/reg.h]) | 38 | +AC_CHECK_HEADERS([a.out.h stab.h sys/mman.h sys/random.h sys/reg.h]) |
41 | AC_CHECK_FUNCS([arc4random getrandom]) | 39 | AC_CHECK_FUNCS([arc4random getcontext getrandom memfd_create]) |
42 | 40 | AM_CONDITIONAL([HAVE_GETCONTEXT], [test "x$ac_cv_func_getcontext" = xyes]) | |
43 | AX_CXX_COMPILE_STDCXX(11, noext, mandatory) | 41 | AM_CONDITIONAL([HAVE_MEMFD_CREATE], [test "x$ac_cv_func_memfd_create" = xyes]) |
diff --git a/meta-oe/recipes-devtools/breakpad/breakpad/mips_asm_sgidefs.patch b/meta-oe/recipes-devtools/breakpad/breakpad/mips_asm_sgidefs.patch index 19bb560445..96f5f48cc8 100644 --- a/meta-oe/recipes-devtools/breakpad/breakpad/mips_asm_sgidefs.patch +++ b/meta-oe/recipes-devtools/breakpad/breakpad/mips_asm_sgidefs.patch | |||
@@ -1,12 +1,9 @@ | |||
1 | Index: lss/linux_syscall_support.h | 1 | --- a/linux_syscall_support.h |
2 | =================================================================== | 2 | +++ b/linux_syscall_support.h |
3 | --- lss.orig/linux_syscall_support.h | 3 | @@ -119,14 +119,7 @@ extern "C" { |
4 | +++ lss/linux_syscall_support.h | ||
5 | @@ -118,21 +118,13 @@ extern "C" { | ||
6 | #include <endian.h> | ||
7 | 4 | ||
8 | #ifdef __mips__ | 5 | #ifdef __mips__ |
9 | -/* Include definitions of the ABI currently in use. */ | 6 | /* Include definitions of the ABI currently in use. */ |
10 | -#ifdef __ANDROID__ | 7 | -#ifdef __ANDROID__ |
11 | -/* Android doesn't have sgidefs.h, but does have asm/sgidefs.h, | 8 | -/* Android doesn't have sgidefs.h, but does have asm/sgidefs.h, |
12 | - * which has the definitions we need. | 9 | - * which has the definitions we need. |
@@ -18,10 +15,3 @@ Index: lss/linux_syscall_support.h | |||
18 | #endif | 15 | #endif |
19 | #endif | 16 | #endif |
20 | 17 | ||
21 | /* The Android NDK's <sys/stat.h> #defines these macros as aliases | ||
22 | * to their non-64 counterparts. To avoid naming conflict, remove them. */ | ||
23 | -#ifdef __ANDROID__ | ||
24 | +#if defined(__ANDROID__) || (defined(__linux__) && !defined(__glibc__)) | ||
25 | /* These are restored by the corresponding #pragma pop_macro near | ||
26 | * the end of this file. */ | ||
27 | # pragma push_macro("stat64") | ||
diff --git a/meta-oe/recipes-devtools/breakpad/breakpad_git.bb b/meta-oe/recipes-devtools/breakpad/breakpad_git.bb index daf262ed66..0e510aaf6d 100644 --- a/meta-oe/recipes-devtools/breakpad/breakpad_git.bb +++ b/meta-oe/recipes-devtools/breakpad/breakpad_git.bb | |||
@@ -6,7 +6,7 @@ SUMMARY = "An open-source multi-platform crash reporting system" | |||
6 | DESCRIPTION = "Breakpad is a library and tool suite that allows you to distribute an application to users with compiler-provided debugging information removed, record crashes in compact \"minidump\" files, send them back to your server, and produce C and C++ stack traces from these minidumps. " | 6 | DESCRIPTION = "Breakpad is a library and tool suite that allows you to distribute an application to users with compiler-provided debugging information removed, record crashes in compact \"minidump\" files, send them back to your server, and produce C and C++ stack traces from these minidumps. " |
7 | HOMEPAGE = "https://code.google.com/p/google-breakpad/" | 7 | HOMEPAGE = "https://code.google.com/p/google-breakpad/" |
8 | LICENSE = "BSD-3-Clause" | 8 | LICENSE = "BSD-3-Clause" |
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=56c24a43c81c3af6fcf590851931489e" | 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8bb274ebd1901085fd71a8d8afe8831b" |
10 | SECTION = "libs" | 10 | SECTION = "libs" |
11 | 11 | ||
12 | inherit autotools | 12 | inherit autotools |
@@ -19,25 +19,23 @@ PV = "1.0" | |||
19 | 19 | ||
20 | SRCREV_FORMAT = "breakpad_gtest_protobuf_lss_gyp" | 20 | SRCREV_FORMAT = "breakpad_gtest_protobuf_lss_gyp" |
21 | 21 | ||
22 | SRCREV_breakpad = "0c0e24f709288a129d665ec27d6f089189318385" | 22 | SRCREV_breakpad = "8b22babdf894e5aa98b2dbbe103f7e3856a71944" |
23 | #v1.10.0 | 23 | #v1.10.0 |
24 | SRCREV_gtest = "5ec7f0c4a113e2f18ac2c6cc7df51ad6afc24081" | 24 | SRCREV_gtest = "4fe018038f87675c083d0cfb6a6b57c274fb1753" |
25 | SRCREV_protobuf = "cb6dd4ef5f82e41e06179dcd57d3b1d9246ad6ac" | 25 | SRCREV_protobuf = "cb6dd4ef5f82e41e06179dcd57d3b1d9246ad6ac" |
26 | SRCREV_lss = "8048ece6c16c91acfe0d36d1d3cc0890ab6e945c" | 26 | SRCREV_lss = "fd00dbbd0c06a309c657d89e9430143b179ff6db" |
27 | SRCREV_gyp = "324dd166b7c0b39d513026fa52d6280ac6d56770" | 27 | SRCREV_gyp = "324dd166b7c0b39d513026fa52d6280ac6d56770" |
28 | 28 | ||
29 | SRC_URI = "git://github.com/google/breakpad;name=breakpad \ | 29 | SRC_URI = "git://github.com/google/breakpad;name=breakpad;branch=main \ |
30 | git://github.com/google/googletest.git;destsuffix=git/src/testing/gtest;name=gtest \ | 30 | git://github.com/google/googletest.git;destsuffix=git/src/testing/gtest;name=gtest \ |
31 | git://github.com/google/protobuf.git;destsuffix=git/src/third_party/protobuf/protobuf;name=protobuf \ | 31 | git://github.com/protocolbuffers/protobuf.git;destsuffix=git/src/third_party/protobuf/protobuf;name=protobuf \ |
32 | git://chromium.googlesource.com/linux-syscall-support;protocol=https;destsuffix=git/src/third_party/lss;name=lss \ | 32 | git://chromium.googlesource.com/linux-syscall-support;protocol=https;branch=main;destsuffix=git/src/third_party/lss;name=lss \ |
33 | git://chromium.googlesource.com/external/gyp;protocol=https;destsuffix=git/src/tools/gyp;name=gyp \ | 33 | git://chromium.googlesource.com/external/gyp;protocol=https;destsuffix=git/src/tools/gyp;name=gyp \ |
34 | file://0001-include-sys-reg.h-to-get-__WORDSIZE-on-musl-libc.patch \ | 34 | file://0001-include-sys-reg.h-to-get-__WORDSIZE-on-musl-libc.patch \ |
35 | file://0003-Fix-conflict-between-musl-libc-dirent.h-and-lss.patch \ | 35 | file://0003-Fix-conflict-between-musl-libc-dirent.h-and-lss.patch \ |
36 | file://0001-Turn-off-sign-compare-for-musl-libc.patch \ | 36 | file://0001-Turn-off-sign-compare-for-musl-libc.patch \ |
37 | file://0002-sys-signal.h-is-a-nonportable-alias-for-signal.h.patch \ | ||
38 | file://0003-Dont-include-stab.h.patch \ | 37 | file://0003-Dont-include-stab.h.patch \ |
39 | file://0004-elf_reader.cc-include-sys-reg.h-to-get-__WORDSIZE-on.patch \ | 38 | file://0004-elf_reader.cc-include-sys-reg.h-to-get-__WORDSIZE-on.patch \ |
40 | file://0002-Use-_fpstate-instead-of-_libc_fpstate-on-linux.patch \ | ||
41 | file://mcontext.patch \ | 39 | file://mcontext.patch \ |
42 | file://0001-disable-calls-to-getcontext-with-musl.patch \ | 40 | file://0001-disable-calls-to-getcontext-with-musl.patch \ |
43 | file://0001-lss-Match-syscalls-to-match-musl.patch;patchdir=src/third_party/lss \ | 41 | file://0001-lss-Match-syscalls-to-match-musl.patch;patchdir=src/third_party/lss \ |