summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
diff options
context:
space:
mode:
authorClément Péron <peron.clem@gmail.com>2021-01-26 10:24:05 +0100
committerKhem Raj <raj.khem@gmail.com>2021-01-27 10:21:14 -0800
commitce9fa374e134040f60d199448340c04c89d2ec85 (patch)
treec68e2154f66b0b6075f6cc3b37e8634fe11baf21 /meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
parent486d0fa33ec6dc41f198445180135ccccb897ce1 (diff)
downloadmeta-openembedded-ce9fa374e134040f60d199448340c04c89d2ec85.tar.gz
abseil-cpp: bump to LTS 2020_09_23 Patch Release 3
Most patches have been upstreamed and accepted. We can drop the -fPIC patch and pass BUILD_SHARED_LIBS instead. Signed-off-by: Clément Péron <peron.clem@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb')
-rw-r--r--meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb24
1 files changed, 13 insertions, 11 deletions
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
index 8efa31e95..cc7bf01d7 100644
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
+++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
@@ -7,16 +7,12 @@ SECTION = "libs"
7LICENSE = "Apache-2.0" 7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=df52c6edb7adc22e533b2bacc3bd3915" 8LIC_FILES_CHKSUM = "file://LICENSE;md5=df52c6edb7adc22e533b2bacc3bd3915"
9 9
10PV = "20190808+git${SRCPV}" 10PV = "20200923+git${SRCPV}"
11SRCREV = "aa844899c937bde5d2b24f276b59997e5b668bde" 11SRCREV = "6f9d96a1f41439ac172ee2ef7ccd8edf0e5d068c"
12BRANCH = "lts_2019_08_08" 12BRANCH = "lts_2020_09_23"
13SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH} \ 13SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH} \
14 file://0001-Remove-maes-option-from-cross-compilation.patch \ 14 file://0001-absl-always-use-asm-sgidefs.h.patch \
15 file://0002-Add-forgotten-ABSL_HAVE_VDSO_SUPPORT-conditional.patch \ 15 file://0002-Remove-maes-option-from-cross-compilation.patch \
16 file://0003-Add-fPIC-option.patch \
17 file://0001-Add-RISCV-support-to-GetProgramCounter.patch \
18 file://0001-absl-always-use-asm-sgidefs.h.patch \
19 file://0001-Fix-build-on-riscv32.patch \
20 " 16 "
21 17
22S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
@@ -28,9 +24,16 @@ ASNEEDED_class-nativesdk = ""
28 24
29inherit cmake 25inherit cmake
30 26
27EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
28 -DBUILD_TESTING=OFF \
29 "
30
31BBCLASSEXTEND = "native nativesdk" 31BBCLASSEXTEND = "native nativesdk"
32ALLOW_EMPTY_${PN} = "1" 32ALLOW_EMPTY_${PN} = "1"
33 33
34FILES_${PN} = "${libdir}/libabsl_*.so ${libdir}/cmake"
35FILES_${PN}-dev = "${includedir}"
36
34python () { 37python () {
35 arch = d.getVar("TARGET_ARCH") 38 arch = d.getVar("TARGET_ARCH")
36 39
@@ -55,4 +58,3 @@ python () {
55 raise bb.parse.SkipRecipe("%s-%s Needs support for corei7 on x86_64" % (pkgn, pkgv)) 58 raise bb.parse.SkipRecipe("%s-%s Needs support for corei7 on x86_64" % (pkgn, pkgv))
56 59
57} 60}
58