diff options
author | Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> | 2021-12-11 15:52:54 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-12-13 08:09:25 -0800 |
commit | 01cd7fcae16edde709d24f905a222dcaea8fb0a1 (patch) | |
tree | d8b196113a685070d97321fbbaeec940afa44298 /meta-oe/recipes-dbs | |
parent | f0ee69cefd890edef50aba240e39f1dbf44af5f0 (diff) | |
download | meta-openembedded-01cd7fcae16edde709d24f905a222dcaea8fb0a1.tar.gz |
soci: update to 4.0.2
Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-dbs')
-rw-r--r-- | meta-oe/recipes-dbs/soci/soci/0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch | 42 | ||||
-rw-r--r-- | meta-oe/recipes-dbs/soci/soci_4.0.2.bb (renamed from meta-oe/recipes-dbs/soci/soci_3.2.3.bb) | 11 |
2 files changed, 45 insertions, 8 deletions
diff --git a/meta-oe/recipes-dbs/soci/soci/0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch b/meta-oe/recipes-dbs/soci/soci/0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch new file mode 100644 index 000000000..8e32ebb0b --- /dev/null +++ b/meta-oe/recipes-dbs/soci/soci/0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | From fae154eb209e068586e1adb589de5d273fcf4b4f Mon Sep 17 00:00:00 2001 | ||
2 | From: Denis Arnaud <denis.arnaud_fedora@m4x.org> | ||
3 | Date: Tue, 18 May 2021 00:05:03 +0200 | ||
4 | Subject: [PATCH] Fix build when SIGSTKSZ is no longer a constant | ||
5 | |||
6 | In the latest glibc versions SIGSTKSZ is not a constant any more, which | ||
7 | broke building the tests with it. | ||
8 | |||
9 | Work around this by hard-coding a typical value for it. | ||
10 | |||
11 | closes #886. | ||
12 | |||
13 | Upstream-Status: Backport. | ||
14 | --- | ||
15 | tests/catch.hpp | 4 ++-- | ||
16 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
17 | |||
18 | diff --git a/tests/catch.hpp b/tests/catch.hpp | ||
19 | index 014df2c5..85067813 100644 | ||
20 | --- a/tests/catch.hpp | ||
21 | +++ b/tests/catch.hpp | ||
22 | @@ -6489,7 +6489,7 @@ namespace Catch { | ||
23 | static bool isSet; | ||
24 | static struct sigaction oldSigActions [sizeof(signalDefs)/sizeof(SignalDefs)]; | ||
25 | static stack_t oldSigStack; | ||
26 | - static char altStackMem[SIGSTKSZ]; | ||
27 | + static char altStackMem[8192]; | ||
28 | |||
29 | static void handleSignal( int sig ) { | ||
30 | std::string name = "<unknown signal>"; | ||
31 | @@ -6540,7 +6540,7 @@ namespace Catch { | ||
32 | bool FatalConditionHandler::isSet = false; | ||
33 | struct sigaction FatalConditionHandler::oldSigActions[sizeof(signalDefs)/sizeof(SignalDefs)] = {}; | ||
34 | stack_t FatalConditionHandler::oldSigStack = {}; | ||
35 | - char FatalConditionHandler::altStackMem[SIGSTKSZ] = {}; | ||
36 | + char FatalConditionHandler::altStackMem[8192] = {}; | ||
37 | |||
38 | } // namespace Catch | ||
39 | |||
40 | -- | ||
41 | 2.25.1 | ||
42 | |||
diff --git a/meta-oe/recipes-dbs/soci/soci_3.2.3.bb b/meta-oe/recipes-dbs/soci/soci_4.0.2.bb index c218b7151..fb67e0c54 100644 --- a/meta-oe/recipes-dbs/soci/soci_3.2.3.bb +++ b/meta-oe/recipes-dbs/soci/soci_4.0.2.bb | |||
@@ -1,6 +1,3 @@ | |||
1 | # Copyright (C) 2015 Khem Raj <raj.khem@gmail.com> | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | DESCRIPTION = "The C++ Database Access Library" | 1 | DESCRIPTION = "The C++ Database Access Library" |
5 | HOMEPAGE = "http://soci.sourceforge.net" | 2 | HOMEPAGE = "http://soci.sourceforge.net" |
6 | LICENSE = "BSL-1.0" | 3 | LICENSE = "BSL-1.0" |
@@ -8,12 +5,9 @@ LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c" | |||
8 | SECTION = "libs" | 5 | SECTION = "libs" |
9 | DEPENDS = "boost" | 6 | DEPENDS = "boost" |
10 | 7 | ||
11 | |||
12 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BP}/${BP}.tar.gz \ | 8 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BP}/${BP}.tar.gz \ |
13 | file://soci_libdir.patch \ | 9 | file://0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch" |
14 | " | 10 | SRC_URI[sha256sum] = "34da2d2320539463da8a5131253246fa2671e0438ab5fd1e5119edb428f558a5" |
15 | SRC_URI[md5sum] = "acfbccf176cd20e06833a8037a2d3699" | ||
16 | SRC_URI[sha256sum] = "2c659db0f4f7b424bbcffe195c03c293a1dbf676189a27b077fb2aab4d53a610" | ||
17 | 11 | ||
18 | TESTCONFIG = '-DSOCI_TEST_EMPTY_CONNSTR="dummy" -DSOCI_TEST_SQLITE3_CONNSTR="test.db" \ | 12 | TESTCONFIG = '-DSOCI_TEST_EMPTY_CONNSTR="dummy" -DSOCI_TEST_SQLITE3_CONNSTR="test.db" \ |
19 | -DSOCI_TEST_POSTGRESQL_CONNSTR:STRING="dbname=soci_test" \ | 13 | -DSOCI_TEST_POSTGRESQL_CONNSTR:STRING="dbname=soci_test" \ |
@@ -29,6 +23,7 @@ PACKAGECONFIG[postgresql] = "-DSOCI_POSTGRESQL=ON,-DSOCI_POSTGRESQL=OFF,postgres | |||
29 | PACKAGECONFIG[odbc] = "-DSOCI_ODBC=ON,-DSOCI_ODBC=OFF,," | 23 | PACKAGECONFIG[odbc] = "-DSOCI_ODBC=ON,-DSOCI_ODBC=OFF,," |
30 | PACKAGECONFIG[empty] = "-DSOCI_EMPTY=ON,-DSOCI_EMPTY=OFF,," | 24 | PACKAGECONFIG[empty] = "-DSOCI_EMPTY=ON,-DSOCI_EMPTY=OFF,," |
31 | PACKAGECONFIG[oracle] = "-DWITH_ORACLE=ON --with-oracle-include=${OINCDIR} --with-oracle-lib=${OLIBDIR},-DWITH_ORACLE=OFF,," | 25 | PACKAGECONFIG[oracle] = "-DWITH_ORACLE=ON --with-oracle-include=${OINCDIR} --with-oracle-lib=${OLIBDIR},-DWITH_ORACLE=OFF,," |
26 | PACKAGECONFIG[firebird] = "-DWITH_FIREBIRD=ON,-DWITH_FIREBIRD=OFF,," | ||
32 | PACKAGECONFIG[ptest] = "${TESTCONFIG},,," | 27 | PACKAGECONFIG[ptest] = "${TESTCONFIG},,," |
33 | 28 | ||
34 | # enable your backend by default we enable 'empty' | 29 | # enable your backend by default we enable 'empty' |