diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-01-25 20:13:35 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-01-25 21:03:16 -0800 |
commit | aa22894fa352986a62c4530ad8facd8868b2e535 (patch) | |
tree | 364eb3cc00def0c5dbad5dacd56ddc207fbd2a52 /meta-oe/recipes-dbs/postgresql | |
parent | 61e1697e92854cda1fc50dcdfacd21b1c74801f8 (diff) | |
download | meta-openembedded-aa22894fa352986a62c4530ad8facd8868b2e535.tar.gz |
postgresql: Fix build on riscv
Remove duplicate code
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-dbs/postgresql')
-rw-r--r-- | meta-oe/recipes-dbs/postgresql/files/remove_duplicate.patch | 38 | ||||
-rw-r--r-- | meta-oe/recipes-dbs/postgresql/postgresql_14.1.bb | 1 |
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-dbs/postgresql/files/remove_duplicate.patch b/meta-oe/recipes-dbs/postgresql/files/remove_duplicate.patch new file mode 100644 index 000000000..92a3dcc71 --- /dev/null +++ b/meta-oe/recipes-dbs/postgresql/files/remove_duplicate.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | Remove duplicate code for riscv | ||
2 | |||
3 | Upstream-Status: Pending | ||
4 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
5 | |||
6 | --- a/src/include/storage/s_lock.h | ||
7 | +++ b/src/include/storage/s_lock.h | ||
8 | @@ -341,30 +341,6 @@ tas(volatile slock_t *lock) | ||
9 | #endif /* HAVE_GCC__SYNC_INT32_TAS */ | ||
10 | #endif /* __arm__ || __arm || __aarch64__ || __aarch64 || __riscv */ | ||
11 | |||
12 | - | ||
13 | -/* | ||
14 | - * RISC-V likewise uses __sync_lock_test_and_set(int *, int) if available. | ||
15 | - */ | ||
16 | -#if defined(__riscv) | ||
17 | -#ifdef HAVE_GCC__SYNC_INT32_TAS | ||
18 | -#define HAS_TEST_AND_SET | ||
19 | - | ||
20 | -#define TAS(lock) tas(lock) | ||
21 | - | ||
22 | -typedef int slock_t; | ||
23 | - | ||
24 | -static __inline__ int | ||
25 | -tas(volatile slock_t *lock) | ||
26 | -{ | ||
27 | - return __sync_lock_test_and_set(lock, 1); | ||
28 | -} | ||
29 | - | ||
30 | -#define S_UNLOCK(lock) __sync_lock_release(lock) | ||
31 | - | ||
32 | -#endif /* HAVE_GCC__SYNC_INT32_TAS */ | ||
33 | -#endif /* __riscv */ | ||
34 | - | ||
35 | - | ||
36 | /* S/390 and S/390x Linux (32- and 64-bit zSeries) */ | ||
37 | #if defined(__s390__) || defined(__s390x__) | ||
38 | #define HAS_TEST_AND_SET | ||
diff --git a/meta-oe/recipes-dbs/postgresql/postgresql_14.1.bb b/meta-oe/recipes-dbs/postgresql/postgresql_14.1.bb index 1112cc21d..680b50bb4 100644 --- a/meta-oe/recipes-dbs/postgresql/postgresql_14.1.bb +++ b/meta-oe/recipes-dbs/postgresql/postgresql_14.1.bb | |||
@@ -7,6 +7,7 @@ SRC_URI += "\ | |||
7 | file://0001-Add-support-for-RISC-V.patch \ | 7 | file://0001-Add-support-for-RISC-V.patch \ |
8 | file://0001-Improve-reproducibility.patch \ | 8 | file://0001-Improve-reproducibility.patch \ |
9 | file://0001-configure.ac-bypass-autoconf-2.69-version-check.patch \ | 9 | file://0001-configure.ac-bypass-autoconf-2.69-version-check.patch \ |
10 | file://remove_duplicate.patch \ | ||
10 | " | 11 | " |
11 | 12 | ||
12 | SRC_URI[sha256sum] = "4d3c101ea7ae38982f06bdc73758b53727fb6402ecd9382006fa5ecc7c2ca41f" | 13 | SRC_URI[sha256sum] = "4d3c101ea7ae38982f06bdc73758b53727fb6402ecd9382006fa5ecc7c2ca41f" |