summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs/postgresql/files/0001-Improve-reproducibility.patch
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-06-04 15:31:04 +0800
committerArmin Kuster <akuster808@gmail.com>2019-09-04 14:30:59 -0700
commit6452692b70d2b4b24253eb40a893c474b6696833 (patch)
tree607bac8c15daba8222a33c8a70d49ce23fdf8b6c /meta-oe/recipes-dbs/postgresql/files/0001-Improve-reproducibility.patch
parenta319e5ecdd2847f9a8f77a02a3c90c3edd06f12a (diff)
downloadmeta-openembedded-6452692b70d2b4b24253eb40a893c474b6696833.tar.gz
postgresql: improve reproducibility
- Make pg_config not record var-CC, var-CFLAGS, and configure which contains build paths - Split pgxs in which Makefile.global contains build path from package postgresql to postgresql-server-dev, it refers ubuntu Here is we got from Ubuntu 18.04 $ dpkg -c /var/cache/apt/archives/postgresql-server-dev-10_10.8-0ubuntu0.18.04.1_amd64.deb -rwxr-xr-x root/root 30792 2019-05-07 17:20 ./usr/lib/postgresql/10/bin/pg_config drwxr-xr-x root/root 0 2019-05-07 17:20 ./usr/lib/postgresql/10/lib/ drwxr-xr-x root/root 0 2019-05-07 17:20 ./usr/lib/postgresql/10/lib/pgxs/ drwxr-xr-x root/root 0 2019-05-07 17:20 ./usr/lib/postgresql/10/lib/pgxs/config/ drwxr-xr-x root/root 0 2019-05-07 17:20 ./usr/lib/postgresql/10/lib/pgxs/src/ -rw-r--r-- root/root 31309 2019-05-07 17:20 ./usr/lib/postgresql/10/lib/pgxs/src/Makefile.global Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-dbs/postgresql/files/0001-Improve-reproducibility.patch')
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/0001-Improve-reproducibility.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-oe/recipes-dbs/postgresql/files/0001-Improve-reproducibility.patch b/meta-oe/recipes-dbs/postgresql/files/0001-Improve-reproducibility.patch
new file mode 100644
index 000000000..32b7f4284
--- /dev/null
+++ b/meta-oe/recipes-dbs/postgresql/files/0001-Improve-reproducibility.patch
@@ -0,0 +1,39 @@
1From 3c13315447fa175da6c9ebe59a039e611cdb5bd1 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Tue, 4 Jun 2019 13:45:30 +0800
4Subject: [PATCH] Improve reproducibility,
5
6Remove build patch from binaries which pg_config do
7not record var-CC, var-CFLAGS, and configure
8
9$ /usr/bin/pg_config --cc
10not recorded
11
12$ /usr/bin/pg_config --configure
13not recorded
14
15Upstream-Status: Inappropriate [oe specific]
16
17Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
18---
19 src/common/Makefile | 4 ----
20 1 file changed, 4 deletions(-)
21
22diff --git a/src/common/Makefile b/src/common/Makefile
23index 1fc2c66..5e6c457 100644
24--- a/src/common/Makefile
25+++ b/src/common/Makefile
26@@ -27,10 +27,6 @@ include $(top_builddir)/src/Makefile.global
27 # don't include subdirectory-path-dependent -I and -L switches
28 STD_CPPFLAGS := $(filter-out -I$(top_srcdir)/src/include -I$(top_builddir)/src/include,$(CPPFLAGS))
29 STD_LDFLAGS := $(filter-out -L$(top_builddir)/src/common -L$(top_builddir)/src/port,$(LDFLAGS))
30-override CPPFLAGS += -DVAL_CONFIGURE="\"$(configure_args)\""
31-override CPPFLAGS += -DVAL_CC="\"$(CC)\""
32-override CPPFLAGS += -DVAL_CPPFLAGS="\"$(STD_CPPFLAGS)\""
33-override CPPFLAGS += -DVAL_CFLAGS="\"$(CFLAGS)\""
34 override CPPFLAGS += -DVAL_CFLAGS_SL="\"$(CFLAGS_SL)\""
35 override CPPFLAGS += -DVAL_LDFLAGS="\"$(STD_LDFLAGS)\""
36 override CPPFLAGS += -DVAL_LDFLAGS_EX="\"$(LDFLAGS_EX)\""
37--
382.7.4
39