summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-crypto
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2021-12-15 20:15:50 +0100
committerKhem Raj <raj.khem@gmail.com>2021-12-15 19:11:18 -0800
commite95b6af4c8c752331d66cb4470a45b23ae3d8759 (patch)
tree351b372959a164c6f10e0bb7298ad4c3164f7067 /meta-oe/recipes-crypto
parent195c723b87b3b526d530c191f5fa0268d3f2f723 (diff)
downloadmeta-openembedded-e95b6af4c8c752331d66cb4470a45b23ae3d8759.tar.gz
libkcapi: update to 1.3.1
Dropped upstreamed patch. License-Update: copyright years updated. Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-crypto')
-rw-r--r--meta-oe/recipes-crypto/libkcapi/libkcapi/0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch36
-rw-r--r--meta-oe/recipes-crypto/libkcapi/libkcapi_1.3.1.bb (renamed from meta-oe/recipes-crypto/libkcapi/libkcapi_1.2.1.bb)8
2 files changed, 3 insertions, 41 deletions
diff --git a/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch b/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch
deleted file mode 100644
index 9d9f63e34..000000000
--- a/meta-oe/recipes-crypto/libkcapi/libkcapi/0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch
+++ /dev/null
@@ -1,36 +0,0 @@
1From 771dd6aa45dd0bbbb7d7c7a7b116e1b5666fbd7a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 15 Nov 2020 18:05:48 -0800
4Subject: [PATCH] Disable use of __NR_io_getevents when not defined
5
6Architectures like riscv32 do not define this syscall, therefore return
7ENOSYS on such architectures
8
9Upstream-Status: Submitted [https://github.com/smuellerDD/libkcapi/pull/100]
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 lib/internal.h | 12 ++++++++++++
13 1 file changed, 12 insertions(+)
14
15--- a/lib/internal.h
16+++ b/lib/internal.h
17@@ -325,10 +325,17 @@ static inline int io_submit(aio_context_
18 return syscall(__NR_io_submit, ctx, n, iocb);
19 }
20
21-static inline int io_getevents(aio_context_t ctx, long min, long max,
22- struct io_event *events, struct timespec *timeout)
23+static inline int io_getevents(__attribute__((unused)) aio_context_t ctx,
24+ __attribute__((unused)) long min,
25+ __attribute__((unused)) long max,
26+ __attribute__((unused)) struct io_event *events,
27+ __attribute__((unused)) struct timespec *timeout)
28 {
29+#ifdef __NR_io_getevents
30 return syscall(__NR_io_getevents, ctx, min, max, events, timeout);
31+#else
32+ return -ENOSYS;
33+#endif
34 }
35
36 /************************************************************
diff --git a/meta-oe/recipes-crypto/libkcapi/libkcapi_1.2.1.bb b/meta-oe/recipes-crypto/libkcapi/libkcapi_1.3.1.bb
index cc71903a8..f10d68470 100644
--- a/meta-oe/recipes-crypto/libkcapi/libkcapi_1.2.1.bb
+++ b/meta-oe/recipes-crypto/libkcapi/libkcapi_1.3.1.bb
@@ -1,13 +1,11 @@
1SUMMARY = "Linux Kernel Crypto API User Space Interface Library" 1SUMMARY = "Linux Kernel Crypto API User Space Interface Library"
2HOMEPAGE = "http://www.chronox.de/libkcapi.html" 2HOMEPAGE = "http://www.chronox.de/libkcapi.html"
3LICENSE = "BSD-3-Clause | GPL-2.0" 3LICENSE = "BSD-3-Clause | GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=c78be93ed8d1637f2a3f4a83ff9d5f54" 4LIC_FILES_CHKSUM = "file://COPYING;md5=80c467906eb826339c7f09e61808ed23"
5 5
6S = "${WORKDIR}/git" 6S = "${WORKDIR}/git"
7SRCREV = "d41284525ec8960e9a828979cfe269012b7df8db" 7SRCREV = "2936ecd060c299157ac880650ba2c9fd94d27bb1"
8SRC_URI = "git://github.com/smuellerDD/libkcapi.git;branch=master;protocol=https \ 8SRC_URI = "git://github.com/smuellerDD/libkcapi.git;branch=master;protocol=https"
9 file://0001-Disable-use-of-__NR_io_getevents-when-not-defined.patch \
10 "
11 9
12inherit autotools 10inherit autotools
13 11