summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-crypto
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@gmail.com>2022-05-30 13:08:05 +0000
committerKhem Raj <raj.khem@gmail.com>2022-05-31 08:26:23 -0700
commitc8541a348232e99eb54bf49661966192fbf8a0c0 (patch)
tree5ff09231cb09c8322b33cf18040f39057a72fcef /meta-oe/recipes-crypto
parentb76919201b55fc7b5a4869725ef1ad9f3adcba21 (diff)
downloadmeta-openembedded-c8541a348232e99eb54bf49661966192fbf8a0c0.tar.gz
libtomcrypt: add recipe
LibTomCrypt is a fairly comprehensive, modular and portable cryptographic toolkit that provides developers with a vast array of well known published block ciphers, one-way hash functions, chaining modes, pseudo-random number generators, public key cryptography and a plethora of other routines. Signed-off-by: Samuli Piippo <samuli.piippo@qt.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-crypto')
-rw-r--r--meta-oe/recipes-crypto/libtomcrypt/libtomcrypt_1.18.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-crypto/libtomcrypt/libtomcrypt_1.18.2.bb b/meta-oe/recipes-crypto/libtomcrypt/libtomcrypt_1.18.2.bb
new file mode 100644
index 000000000..357fd0ab8
--- /dev/null
+++ b/meta-oe/recipes-crypto/libtomcrypt/libtomcrypt_1.18.2.bb
@@ -0,0 +1,21 @@
1SUMMARY = "LibTomCrypt is a public domain open source cryptographic toolkit"
2HOMEPAGE = "https://www.libtom.net/LibTomCrypt"
3SECTION = "libs"
4LICENSE = "Unlicense"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=71baacc459522324ef3e2b9e052e8180"
6
7DEPENDS += "libtool-cross"
8
9SRC_URI = "git://github.com/libtom/libtomcrypt.git;protocol=https;branch=master"
10
11SRCREV = "7e7eb695d581782f04b24dc444cbfde86af59853"
12
13S = "${WORKDIR}/git"
14
15do_compile() {
16 oe_runmake -f makefile.shared
17}
18
19do_install() {
20 oe_runmake -f makefile.shared 'PREFIX=${prefix}' 'DESTDIR=${D}' install
21}