summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-07-26 11:58:13 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-13 13:19:40 +0200
commitfb10f1b4d797482375272c92931b7e3d13683a9e (patch)
treee5bb825c66ba659a47dc5b3a21e42ad8e4da4589 /meta-oe/recipes-core
parent523fa42dd4904068dd8d9edced02155bd48d3278 (diff)
downloadmeta-openembedded-fb10f1b4d797482375272c92931b7e3d13683a9e.tar.gz
dbus-daemon-proxy: Fix return value from master_filter_cb()
Use github for SRC_URI Reorder the linker flags so that we can remove disabling --as-needed Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/dbus/dbus-daemon-proxy/0001-dbus-daemon-proxy-Return-DBUS_HANDLER_RESULT_NOT_YET.patch30
-rw-r--r--meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb8
2 files changed, 34 insertions, 4 deletions
diff --git a/meta-oe/recipes-core/dbus/dbus-daemon-proxy/0001-dbus-daemon-proxy-Return-DBUS_HANDLER_RESULT_NOT_YET.patch b/meta-oe/recipes-core/dbus/dbus-daemon-proxy/0001-dbus-daemon-proxy-Return-DBUS_HANDLER_RESULT_NOT_YET.patch
new file mode 100644
index 000000000..2c4ca057f
--- /dev/null
+++ b/meta-oe/recipes-core/dbus/dbus-daemon-proxy/0001-dbus-daemon-proxy-Return-DBUS_HANDLER_RESULT_NOT_YET.patch
@@ -0,0 +1,30 @@
1From 8e6d1f590b1cb437dc67c51298ef1722a7266d35 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 25 Jul 2017 18:37:58 -0700
4Subject: [PATCH] dbus-daemon-proxy: Return DBUS_HANDLER_RESULT_NOT_YET_HANDLED
5 from master_filter_cb() if DBusConnection is null
6
7So it can be passed on to other handlers since this could
8not be handled here
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 dbus-daemon-proxy.c | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/dbus-daemon-proxy.c b/dbus-daemon-proxy.c
16index 009e4fd..f3f0d80 100644
17--- a/dbus-daemon-proxy.c
18+++ b/dbus-daemon-proxy.c
19@@ -115,7 +115,7 @@ master_filter_cb (DBusConnection *conn,
20 guint32 serial;
21
22 if (!dbus_conn)
23- return;
24+ DBUS_HANDLER_RESULT_NOT_YET_HANDLED;
25
26 if (verbose)
27 g_print ("New message from server: type='%d' path='%s' iface='%s'"
28--
292.13.3
30
diff --git a/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb b/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb
index 4571b447f..42cd032c2 100644
--- a/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb
+++ b/meta-oe/recipes-core/dbus/dbus-daemon-proxy_git.bb
@@ -6,15 +6,15 @@ SRCREV = "1226a0a1374628ff191f6d8a56000be5e53e7608"
6PV = "0.0.0+gitr${SRCPV}" 6PV = "0.0.0+gitr${SRCPV}"
7PR = "r1.59" 7PR = "r1.59"
8 8
9ASNEEDED_pn-dbus-daemon-proxy = "" 9SRC_URI = "git://github.com/alban/dbus-daemon-proxy \
10 10 file://0001-dbus-daemon-proxy-Return-DBUS_HANDLER_RESULT_NOT_YET.patch \
11SRC_URI = "git://git.collabora.co.uk/git/user/alban/dbus-daemon-proxy" 11 "
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
13 13
14inherit pkgconfig 14inherit pkgconfig
15 15
16do_compile() { 16do_compile() {
17 ${CC} ${LDFLAGS} `pkg-config --cflags --libs dbus-glib-1` -o dbus-daemon-proxy dbus-daemon-proxy.c 17 ${CC} ${CFLAGS} -o dbus-daemon-proxy dbus-daemon-proxy.c `pkg-config --cflags --libs dbus-glib-1` ${LDFLAGS}
18} 18}
19 19
20do_install() { 20do_install() {