summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2016-11-25 15:28:52 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-02 09:16:17 +0100
commitefd3696e70a6603f1a45faa4a172433514f0a487 (patch)
treeb72751ba93b050391db05a8e1be7506836b6d515 /meta-oe/recipes-core
parent761639b9d7681c81dd69eaf3a37c32791d6e97fd (diff)
downloadmeta-openembedded-efd3696e70a6603f1a45faa4a172433514f0a487.tar.gz
remove True option to getVar calls
getVar() now defaults to expanding by default, thus remove the True option from getVar() calls with a regex search and replace. Search made with the following regex: getVar ?\(( ?[^,()]*), True\) Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/fakeroot/fakeroot-native_1.18.4.bb2
-rw-r--r--meta-oe/recipes-core/llvm/llvm.inc2
-rw-r--r--meta-oe/recipes-core/proxy-libintl/proxy-libintl_20100902.bb2
-rw-r--r--meta-oe/recipes-core/toybox/toybox_0.7.1.bb4
4 files changed, 5 insertions, 5 deletions
diff --git a/meta-oe/recipes-core/fakeroot/fakeroot-native_1.18.4.bb b/meta-oe/recipes-core/fakeroot/fakeroot-native_1.18.4.bb
index a27a60b48..9d50ea44a 100644
--- a/meta-oe/recipes-core/fakeroot/fakeroot-native_1.18.4.bb
+++ b/meta-oe/recipes-core/fakeroot/fakeroot-native_1.18.4.bb
@@ -8,7 +8,7 @@ EXTRA_OECONF = "--program-prefix="
8 8
9# Compatability for the rare systems not using or having SYSV 9# Compatability for the rare systems not using or having SYSV
10python () { 10python () {
11 if d.getVar('HOST_NONSYSV', True) and d.getVar('HOST_NONSYSV', True) != '0': 11 if d.getVar('HOST_NONSYSV') and d.getVar('HOST_NONSYSV') != '0':
12 d.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ') 12 d.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ')
13} 13}
14 14
diff --git a/meta-oe/recipes-core/llvm/llvm.inc b/meta-oe/recipes-core/llvm/llvm.inc
index fa971f38c..f27261fa9 100644
--- a/meta-oe/recipes-core/llvm/llvm.inc
+++ b/meta-oe/recipes-core/llvm/llvm.inc
@@ -153,7 +153,7 @@ python llvm_populate_packages() {
153 split_packages = do_split_packages(d, libdir, '^lib(.*)\.so$', 'libllvm${LLVM_RELEASE}-%s', 'Split package for %s', allow_dirs=True, allow_links=True, recursive=True) 153 split_packages = do_split_packages(d, libdir, '^lib(.*)\.so$', 'libllvm${LLVM_RELEASE}-%s', 'Split package for %s', allow_dirs=True, allow_links=True, recursive=True)
154 split_staticdev_packages = do_split_packages(d, libllvm_libdir, '^lib(.*)\.a$', 'libllvm${LLVM_RELEASE}-%s-staticdev', 'Split staticdev package for %s', allow_dirs=True) 154 split_staticdev_packages = do_split_packages(d, libllvm_libdir, '^lib(.*)\.a$', 'libllvm${LLVM_RELEASE}-%s-staticdev', 'Split staticdev package for %s', allow_dirs=True)
155 if split_packages: 155 if split_packages:
156 pn = d.getVar('PN', True) 156 pn = d.getVar('PN')
157 d.appendVar('RDEPENDS_' + pn, ' '+' '.join(split_packages)) 157 d.appendVar('RDEPENDS_' + pn, ' '+' '.join(split_packages))
158 d.appendVar('RDEPENDS_' + pn + '-dbg', ' '+' '.join(split_dbg_packages)) 158 d.appendVar('RDEPENDS_' + pn + '-dbg', ' '+' '.join(split_dbg_packages))
159 d.appendVar('RDEPENDS_' + pn + '-staticdev', ' '+' '.join(split_staticdev_packages)) 159 d.appendVar('RDEPENDS_' + pn + '-staticdev', ' '+' '.join(split_staticdev_packages))
diff --git a/meta-oe/recipes-core/proxy-libintl/proxy-libintl_20100902.bb b/meta-oe/recipes-core/proxy-libintl/proxy-libintl_20100902.bb
index a46a91c8b..f11ae7e4d 100644
--- a/meta-oe/recipes-core/proxy-libintl/proxy-libintl_20100902.bb
+++ b/meta-oe/recipes-core/proxy-libintl/proxy-libintl_20100902.bb
@@ -18,7 +18,7 @@ PACKAGES = "${PN} ${PN}-dev"
18FILES_${PN}-dev = "${includedir}/libintl.h ${libdir}/libintl.a" 18FILES_${PN}-dev = "${includedir}/libintl.h ${libdir}/libintl.a"
19INSANE_SKIP_${PN}-dev = "staticdev" 19INSANE_SKIP_${PN}-dev = "staticdev"
20ALLOW_EMPTY_${PN} = "1" 20ALLOW_EMPTY_${PN} = "1"
21CFLAGS_append = " -fPIC -Wall -I ../../include ${@['-DSTUB_ONLY', ''][d.getVar('USE_NLS', 1) != 'no']}" 21CFLAGS_append = " -fPIC -Wall -I ../../include ${@['-DSTUB_ONLY', ''][d.getVar('USE_NLS') != 'no']}"
22TARGET_CC_ARCH += "${LDFLAGS}" 22TARGET_CC_ARCH += "${LDFLAGS}"
23 23
24do_compile() { 24do_compile() {
diff --git a/meta-oe/recipes-core/toybox/toybox_0.7.1.bb b/meta-oe/recipes-core/toybox/toybox_0.7.1.bb
index defca7016..032b13855 100644
--- a/meta-oe/recipes-core/toybox/toybox_0.7.1.bb
+++ b/meta-oe/recipes-core/toybox/toybox_0.7.1.bb
@@ -59,8 +59,8 @@ python do_package_prepend () {
59 # Read links from /etc/toybox.links and create appropriate 59 # Read links from /etc/toybox.links and create appropriate
60 # update-alternatives variables 60 # update-alternatives variables
61 61
62 dvar = d.getVar('D', True) 62 dvar = d.getVar('D')
63 pn = d.getVar('PN', True) 63 pn = d.getVar('PN')
64 target = "/bin/toybox" 64 target = "/bin/toybox"
65 65
66 f = open('%s/etc/toybox.links' % (dvar), 'r') 66 f = open('%s/etc/toybox.links' % (dvar), 'r')