summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorMaxin John <maxin.john@intel.com>2018-04-06 11:33:27 +0300
committerArmin Kuster <akuster808@gmail.com>2018-04-13 12:43:37 -0700
commitee25e2f3fdb9c4a6d14179891eb55ac8fa725da4 (patch)
tree6e8d24c65b1cda5f08365f8b04756ffc4353241b /meta-oe/recipes-core
parent9a0e1ce815d5d21cae49f83667aae82462d9edf4 (diff)
downloadmeta-openembedded-ee25e2f3fdb9c4a6d14179891eb55ac8fa725da4.tar.gz
ell: upgrade to version 0.4
1. Upgrade to version 0.4 and rename from _git to exact version _0.4 2. Fix build issues with musl libc Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/ell/ell/0001-ell-fix-build-with-musl-libc.patch39
-rw-r--r--meta-oe/recipes-core/ell/ell_0.4.bb (renamed from meta-oe/recipes-core/ell/ell_git.bb)6
2 files changed, 43 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/ell/ell/0001-ell-fix-build-with-musl-libc.patch b/meta-oe/recipes-core/ell/ell/0001-ell-fix-build-with-musl-libc.patch
new file mode 100644
index 000000000..a172a93ca
--- /dev/null
+++ b/meta-oe/recipes-core/ell/ell/0001-ell-fix-build-with-musl-libc.patch
@@ -0,0 +1,39 @@
1From 4f8c68757b05d12392cd1a8aed174cb8e56f80e3 Mon Sep 17 00:00:00 2001
2From: "Maxin B. John" <maxin.john@intel.com>
3Date: Thu, 5 Apr 2018 17:19:44 +0300
4Subject: [PATCH] ell: fix build with musl libc
5
6musl libc doesn't implement TEMP_FAILURE_RETRY. Use the
7TEMP_FAILURE_RETRY from glibc to fix build.
8
9Upstream-Status: Submitted [https://lists.01.org/pipermail/ell/2018-April/001209.html]
10
11Signed-off-by: Maxin B. John <maxin.john@intel.com>
12---
13 ell/dbus.h | 10 ++++++++++
14 1 file changed, 10 insertions(+)
15
16diff --git a/ell/dbus.h b/ell/dbus.h
17index a7c08d2..3ff5e0f 100644
18--- a/ell/dbus.h
19+++ b/ell/dbus.h
20@@ -28,6 +28,16 @@
21 #include <stddef.h>
22 #include <stdarg.h>
23
24+/* taken from glibc unistd.h for musl support */
25+#ifndef TEMP_FAILURE_RETRY
26+#define TEMP_FAILURE_RETRY(expression) \
27+ (__extension__ \
28+ ({ long int __result; \
29+ do __result = (long int) (expression); \
30+ while (__result == -1L && errno == EINTR); \
31+ __result; }))
32+#endif
33+
34 #ifdef __cplusplus
35 extern "C" {
36 #endif
37--
382.4.0
39
diff --git a/meta-oe/recipes-core/ell/ell_git.bb b/meta-oe/recipes-core/ell/ell_0.4.bb
index 4354974ba..1524bd6b9 100644
--- a/meta-oe/recipes-core/ell/ell_git.bb
+++ b/meta-oe/recipes-core/ell/ell_0.4.bb
@@ -7,8 +7,10 @@ SECTION = "libs"
7inherit autotools pkgconfig 7inherit autotools pkgconfig
8 8
9S = "${WORKDIR}/git" 9S = "${WORKDIR}/git"
10SRCREV = "8192131685be0f27d6f51b14b78ef93fa7f3c692" 10SRCREV = "b4aea06fabb2af1af01f861f8f394c75950b6d47"
11SRC_URI = "git://git.kernel.org/pub/scm/libs/ell/ell.git" 11SRC_URI = "git://git.kernel.org/pub/scm/libs/ell/ell.git \
12 file://0001-ell-fix-build-with-musl-libc.patch \
13 "
12 14
13do_configure_prepend () { 15do_configure_prepend () {
14 mkdir ${S}/build-aux 16 mkdir ${S}/build-aux