summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorThilo Cestonaro <thilo.cestonaro@ts.fujitsu.com>2016-11-18 14:18:45 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-23 15:29:55 +0100
commite9053535db4b6f4c9a757a584b1a59555cff4dbb (patch)
tree57bd1b686fe25ce1a86287658d5c44ecd6ed33d5 /meta-oe/recipes-core
parent4cd27df21d21650c8cf5468be36f33d49e4587cf (diff)
downloadmeta-openembedded-e9053535db4b6f4c9a757a584b1a59555cff4dbb.tar.gz
libdbus-c++: added recipe for it
Signed-off-by: Thilo Cestonaro <thilo.cestonaro@ts.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/dbus/libdbus-c++-0.9.0/fix-missing-unistd.h-include.patch40
-rw-r--r--meta-oe/recipes-core/dbus/libdbus-c++-0.9.0/remove-CXX_FOR_BUILD-stuff.patch33
-rw-r--r--meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb24
3 files changed, 97 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/dbus/libdbus-c++-0.9.0/fix-missing-unistd.h-include.patch b/meta-oe/recipes-core/dbus/libdbus-c++-0.9.0/fix-missing-unistd.h-include.patch
new file mode 100644
index 000000000..903a7209f
--- /dev/null
+++ b/meta-oe/recipes-core/dbus/libdbus-c++-0.9.0/fix-missing-unistd.h-include.patch
@@ -0,0 +1,40 @@
1
2sniped from ChromiumOS
3
4https://bugs.gentoo.org/424707
5
6From 154f7861d19a2bd5c79c488f9989610971db451b Mon Sep 17 00:00:00 2001
7From: Han Shen <shenhan@google.com>
8Date: Thu, 31 May 2012 16:49:35 -0700
9Subject: [PATCH] Fixed dbus-c++ gcc 4.7 building problem.
10
11Just add "unistd.h" inclusion to eventloop-integration.h.
12
13BUG=None
14TEST=Manually built using gcc 4.7.
15
16Change-Id: I87bd1f90db6a4c974a5ed8134044e8be2034aff2
17Reviewed-on: https://gerrit.chromium.org/gerrit/24260
18Tested-by: Han Shen <shenhan@google.com>
19Reviewed-by: Yunlian Jiang <yunlian@chromium.org>
20Commit-Ready: Han Shen <shenhan@chromium.org>
21Upstream-Status: Inappropriate [ not author, no upstream ]
22Signed-off-by: Thilo Cestonaro <thilo.cestonaro@ts.fujitsu.com>
23---
24 include/dbus-c++/eventloop-integration.h | 1 +
25 1 file changed, 1 insertion(+)
26
27diff --git a/include/dbus-c++/eventloop-integration.h b/include/dbus-c++/eventloop-integration.h
28index 5108340..1b56ab5 100644
29--- a/include/dbus-c++/eventloop-integration.h
30+++ b/include/dbus-c++/eventloop-integration.h
31@@ -27,6 +27,7 @@
32
33 #include <cstring>
34 #include <errno.h>
35+#include <unistd.h>
36 #include "api.h"
37 #include "dispatcher.h"
38 #include "util.h"
39--
401.7.9.7
diff --git a/meta-oe/recipes-core/dbus/libdbus-c++-0.9.0/remove-CXX_FOR_BUILD-stuff.patch b/meta-oe/recipes-core/dbus/libdbus-c++-0.9.0/remove-CXX_FOR_BUILD-stuff.patch
new file mode 100644
index 000000000..fa29d3cde
--- /dev/null
+++ b/meta-oe/recipes-core/dbus/libdbus-c++-0.9.0/remove-CXX_FOR_BUILD-stuff.patch
@@ -0,0 +1,33 @@
1From: Thilo Cestonaro <thilo.cestonaro@ts.fujitsu.com>
2Date: Fri, 18 Nov 2016 10:23:07 +0100
3Subject: Build libdbus-c++ tools for target platform rather than enforced for
4host platform.
5
6Upstream-Status: Inappropriate [no upstream]
7Signed-off-by: Thilo Cestonaro <thilo.cestonaro@ts.fujitsu.com>
8---
9
10diff -Naur libdbus-c++-0.9.0.ori/configure.ac libdbus-c++-0.9.0/configure.ac
11--- libdbus-c++-0.9.0.ori/configure.ac 2016-11-15 14:25:36.085882774 +0100
12+++ libdbus-c++-0.9.0/configure.ac 2016-11-15 14:27:08.814568717 +0100
13@@ -64,9 +64,6 @@
14 AC_PROG_CC
15 AC_PROG_CXX
16
17-CXX_FOR_BUILD=${CXX_FOR_BUILD-${CXX}}
18-AC_SUBST(CXX_FOR_BUILD)
19-
20 AM_PROG_LIBTOOL
21
22 PKG_PROG_PKG_CONFIG
23diff -Naur libdbus-c++-0.9.0.ori/tools/Makefile.am libdbus-c++-0.9.0/tools/Makefile.am
24--- libdbus-c++-0.9.0.ori/tools/Makefile.am 2016-11-15 14:25:36.089882803 +0100
25+++ libdbus-c++-0.9.0/tools/Makefile.am 2016-11-15 14:26:19.454203583 +0100
26@@ -1,7 +1,5 @@
27 # hacky, but ...
28
29-CXX = $(CXX_FOR_BUILD)
30-
31 AM_CPPFLAGS = \
32 $(dbus_CFLAGS) \
33 $(xml_CFLAGS) \
diff --git a/meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb b/meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb
new file mode 100644
index 000000000..7edaffca6
--- /dev/null
+++ b/meta-oe/recipes-core/dbus/libdbus-c++_0.9.0.bb
@@ -0,0 +1,24 @@
1SUMMARY = "DBus-C++ Library"
2DESCRIPTION = "DBus-c++ attempts to provide a C++ API for D-BUS. The library has a glib and an Ecore mainloop integration. It also offers an optional own main loop."
3HOMEPAGE = "http://dbus-cplusplus.sourceforge.net"
4SECTION = "base"
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
7DEPENDS = "dbus glib-2.0 libpcre"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/project/dbus-cplusplus/dbus-c++/${PV}/${BPN}-${PV}.tar.gz \
10 file://fix-missing-unistd.h-include.patch \
11 file://remove-CXX_FOR_BUILD-stuff.patch"
12SRC_URI[md5sum] = "e752116f523fa88ef041e63d3dee4de2"
13SRC_URI[sha256sum] = "bc11ac297b3cb010be904c72789695543ee3fdf3d75cdc8225fd371385af4e61"
14
15EXTRA_OECONF = "--disable-ecore --disable-examples --disable-tests"
16
17inherit autotools pkgconfig
18
19PACKAGES += "${PN}-tools"
20
21FILES_${PN} = "${libdir}"
22FILES_${PN}-tools = "${bindir}"
23
24BBCLASSEXTEND = "native"