summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2017-12-17 19:21:40 +0100
committerArmin Kuster <akuster808@gmail.com>2017-12-30 12:32:08 -0800
commite4be8f4e9e449475644179a8c7b0d4c6c4e5cb16 (patch)
treeb8ee0181ed46c6ae830dd0b0a6028e70918460e4 /meta-oe/recipes-core
parent9c6309582611519c92ec11cbda5769e0f0f0c315 (diff)
downloadmeta-openembedded-e4be8f4e9e449475644179a8c7b0d4c6c4e5cb16.tar.gz
plymouth: fix path to systemd-tty-ask-password-agent
In pre recipe specific sysroot times AC_PATH_PROG detected host's systemd-tty-ask-password-agent. In my case that path was wrong and systemd-ask-password-plymouth.service failed silently. Now with recipe specific sysroot and no link in PATH to buildhost, SYSTEMD_ASK_PASSWORD_AGENT remains empty and that causes: | systemd[1]: /lib/systemd/system/systemd-ask-password-plymouth.service:12: Executable path is not absolute, ignoring: --watch --plymouth | systemd[1]: systemd-ask-password-plymouth.service: Service lacks both ExecStart= and ExecStop= setting. Refusing. For both environments this patch fixes log-off from X-session to display-manager. Before this patch screen went dark and it seemed that X-server was restarted. Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/plymouth/files/0001-Make-full-path-to-systemd-tty-ask-password-agent-con.patch34
-rw-r--r--meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb7
2 files changed, 39 insertions, 2 deletions
diff --git a/meta-oe/recipes-core/plymouth/files/0001-Make-full-path-to-systemd-tty-ask-password-agent-con.patch b/meta-oe/recipes-core/plymouth/files/0001-Make-full-path-to-systemd-tty-ask-password-agent-con.patch
new file mode 100644
index 000000000..6a86c76d1
--- /dev/null
+++ b/meta-oe/recipes-core/plymouth/files/0001-Make-full-path-to-systemd-tty-ask-password-agent-con.patch
@@ -0,0 +1,34 @@
1From 746c690f57b52e6fe21cc2a11b5bb71d25af3128 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
3Date: Wed, 13 Dec 2017 16:15:57 +0100
4Subject: [PATCH] Make full path to systemd-tty-ask-password-agent configurable
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstream-Status: Inappropriate [embedded specific]
10
11Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
12---
13 configure.ac | 5 ++++-
14 1 file changed, 4 insertions(+), 1 deletion(-)
15
16diff --git a/configure.ac b/configure.ac
17index aad673e..6b37179 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -48,7 +48,10 @@ PLYMOUTH_LIBS="-lm -lrt -ldl"
21 AC_SUBST(PLYMOUTH_CFLAGS)
22 AC_SUBST(PLYMOUTH_LIBS)
23
24-AC_PATH_PROG([SYSTEMD_ASK_PASSWORD_AGENT], [systemd-tty-ask-password-agent])
25+AC_ARG_WITH(systemd-tty-ask-password-agent, AS_HELP_STRING([--with-systemd-tty-ask-password-agent],[path of systemd-tty-ask-password-agent]),SYSTEMD_ASK_PASSWORD_AGENT=${withval},SYSTEMD_ASK_PASSWORD_AGENT=/bin/systemd-tty-ask-password-agent)
26+AC_SUBST(SYSTEMD_ASK_PASSWORD_AGENT)
27+
28+# checked: UDEVADM is not used
29 AC_PATH_PROG([UDEVADM], [udevadm])
30
31 AC_ARG_ENABLE(pango, AS_HELP_STRING([--enable-pango],[enable building with pango, disabled there is no encryption prompts]),enable_pango=$enableval,enable_pango=yes)
32--
332.9.5
34
diff --git a/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb b/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
index 6163cff7c..600c4e292 100644
--- a/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
+++ b/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
@@ -16,13 +16,16 @@ DEPENDS = "libcap libpng cairo dbus udev"
16PROVIDES = "virtual/psplash" 16PROVIDES = "virtual/psplash"
17RPROVIDES_${PN} = "virtual-psplash virtual-psplash-support" 17RPROVIDES_${PN} = "virtual-psplash virtual-psplash-support"
18 18
19SRC_URI = "http://www.freedesktop.org/software/plymouth/releases/${BPN}-${PV}.tar.bz2" 19SRC_URI = " \
20 http://www.freedesktop.org/software/plymouth/releases/${BPN}-${PV}.tar.bz2 \
21 file://0001-Make-full-path-to-systemd-tty-ask-password-agent-con.patch \
22"
20SRC_URI[md5sum] = "ff420994deb7ea203df678df92e7ab7d" 23SRC_URI[md5sum] = "ff420994deb7ea203df678df92e7ab7d"
21SRC_URI[sha256sum] = "2f0ce82042cf9c7eadd2517a1f74c8a85fa8699781d9f294a06eade29fbed57f" 24SRC_URI[sha256sum] = "2f0ce82042cf9c7eadd2517a1f74c8a85fa8699781d9f294a06eade29fbed57f"
22 25
23EXTRA_OECONF += " --enable-shared --disable-static --disable-gtk --disable-documentation \ 26EXTRA_OECONF += " --enable-shared --disable-static --disable-gtk --disable-documentation \
24 --with-logo=${LOGO} \ 27 --with-logo=${LOGO} \
25 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-system-root-install', '', d)} \ 28 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-system-root-install --with-systemd-tty-ask-password-agent=${base_bindir}/systemd-tty-ask-password-agent', '', d)} \
26" 29"
27 30
28PACKAGECONFIG ??= "pango initrd" 31PACKAGECONFIG ??= "pango initrd"