summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-11-29 23:37:30 -0800
committerKhem Raj <raj.khem@gmail.com>2023-12-01 08:48:58 -0800
commitb1d55efe056c5f66dd77ef2e6bf67203300db6dc (patch)
tree78c73d79a4218faebba5df781bd82ab0e5accb3b /meta-oe/recipes-core
parent5d7cb6ec416da05209bf2cc329f0da889a2de41d (diff)
downloadmeta-openembedded-b1d55efe056c5f66dd77ef2e6bf67203300db6dc.tar.gz
sdbus-c++: Install ptests into PTEST_PATH
add rdep on basu and dbus when not using systemd Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rwxr-xr-xmeta-oe/recipes-core/sdbus-c++/sdbus-c++-1.4.0/run-ptest4
-rw-r--r--meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.4.0.bb9
2 files changed, 6 insertions, 7 deletions
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.4.0/run-ptest b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.4.0/run-ptest
index f6ade0c7e..2dc6e1eca 100755
--- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.4.0/run-ptest
+++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.4.0/run-ptest
@@ -4,12 +4,12 @@ set -o pipefail
4 4
5SCRIPTPATH="$( cd "$(dirname "$0")" ; pwd -P )" 5SCRIPTPATH="$( cd "$(dirname "$0")" ; pwd -P )"
6 6
7${SCRIPTPATH}/../tests/sdbus-c++-unit-tests 2>&1 | \ 7${SCRIPTPATH}/sdbus-c++-unit-tests 2>&1 | \
8sed -r 's/^\[\s+OK\s+\] (.*) \([0-9]+\sms\)$/OK: \1 /' | \ 8sed -r 's/^\[\s+OK\s+\] (.*) \([0-9]+\sms\)$/OK: \1 /' | \
9sed -r 's/^\[\s+FAILED\s+\] (.*) \([0-9]+\sms\)$/FAILED: \1 /' | \ 9sed -r 's/^\[\s+FAILED\s+\] (.*) \([0-9]+\sms\)$/FAILED: \1 /' | \
10awk '{if ($1 == "OK:" || $1 == "FAILED:") {print $0}}' 10awk '{if ($1 == "OK:" || $1 == "FAILED:") {print $0}}'
11 11
12${SCRIPTPATH}/../tests/sdbus-c++-integration-tests 2>&1 | \ 12${SCRIPTPATH}/sdbus-c++-integration-tests 2>&1 | \
13sed -r 's/^\[\s+OK\s+\] (.*) \([0-9]+\sms\)$/OK: \1 /' | \ 13sed -r 's/^\[\s+OK\s+\] (.*) \([0-9]+\sms\)$/OK: \1 /' | \
14sed -r 's/^\[\s+FAILED\s+\] (.*) \([0-9]+\sms\)$/FAILED: \1 /' | \ 14sed -r 's/^\[\s+FAILED\s+\] (.*) \([0-9]+\sms\)$/FAILED: \1 /' | \
15awk '{if ($1 == "OK:" || $1 == "FAILED:") {print $0}}' 15awk '{if ($1 == "OK:" || $1 == "FAILED:") {print $0}}'
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.4.0.bb b/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.4.0.bb
index 869bfa951..ca91b351e 100644
--- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.4.0.bb
+++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.4.0.bb
@@ -10,9 +10,9 @@ inherit cmake pkgconfig systemd ptest
10 10
11PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'with-external-libsystemd', 'with-builtin-libsystemd', d)} \ 11PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'with-external-libsystemd', 'with-builtin-libsystemd', d)} \
12 ${@bb.utils.contains('PTEST_ENABLED', '1', 'with-tests', '', d)}" 12 ${@bb.utils.contains('PTEST_ENABLED', '1', 'with-tests', '', d)}"
13PACKAGECONFIG[with-builtin-libsystemd] = ",,sdbus-c++-libsystemd,libcap" 13PACKAGECONFIG[with-builtin-libsystemd] = ",,sdbus-c++-libsystemd,libcap,basu"
14PACKAGECONFIG[with-external-libsystemd] = ",,systemd,libsystemd" 14PACKAGECONFIG[with-external-libsystemd] = ",,systemd,libsystemd"
15PACKAGECONFIG[with-tests] = "-DBUILD_TESTS=ON -DTESTS_INSTALL_PATH=${libdir}/${BPN}/tests,-DBUILD_TESTS=OFF,googletest gmock" 15PACKAGECONFIG[with-tests] = "-DBUILD_TESTS=ON -DTESTS_INSTALL_PATH=${PTEST_PATH},-DBUILD_TESTS=OFF,googletest gmock"
16 16
17DEPENDS += "expat" 17DEPENDS += "expat"
18 18
@@ -39,14 +39,13 @@ do_install:append() {
39 fi 39 fi
40} 40}
41 41
42PTEST_PATH = "${libdir}/${BPN}/ptest"
43do_install_ptest() { 42do_install_ptest() {
44 install -d ${D}${PTEST_PATH} 43 DESTDIR='${D}' cmake_runcmake_build --target tests/install
45 cp -r ${B}/tests/sdbus-c++-unit-tests ${D}${PTEST_PATH}
46} 44}
47 45
48FILES:${PN}-ptest =+ "${sysconfdir}/dbus-1/system.d/" 46FILES:${PN}-ptest =+ "${sysconfdir}/dbus-1/system.d/"
49FILES:${PN}-dev += "${bindir}/sdbus-c++-xml2cpp" 47FILES:${PN}-dev += "${bindir}/sdbus-c++-xml2cpp"
50 48
49RDEPENDS:${PN}-ptest += "dbus"
51# It adds -isystem which is spurious, no idea where it gets it from 50# It adds -isystem which is spurious, no idea where it gets it from
52CCACHE_DISABLE = "1" 51CCACHE_DISABLE = "1"