summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorAlistair Francis <alistair.francis@wdc.com>2018-07-23 16:11:04 -0700
committerKhem Raj <raj.khem@gmail.com>2018-07-26 20:10:07 -0700
commit95a8804cad0caed852a5bcf58475a99f1907f06f (patch)
treea39b2e5839b9caf8bfcb4448ef066baa529e2de8 /meta-oe/recipes-core
parentb1a3f656a550c43c8e9797531fc3402542b21f6b (diff)
downloadmeta-openembedded-95a8804cad0caed852a5bcf58475a99f1907f06f.tar.gz
ndctl: Add the NDCTL package
Add the NDCTL package (the libnvdimm utility library). This is based on the work from the meta-luv layer with a version bump. Signed-off-by: Alistair Francis <alistair.francis@wdc.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/ndctl/ndctl_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/ndctl/ndctl_git.bb b/meta-oe/recipes-core/ndctl/ndctl_git.bb
new file mode 100644
index 000000000..36f94ecfd
--- /dev/null
+++ b/meta-oe/recipes-core/ndctl/ndctl_git.bb
@@ -0,0 +1,29 @@
1SUMMARY = "libnvdimm utility library"
2DESCRIPTION = "Utility library for managing the libnvdimm \
3(non-volatile memory device) sub-system in the Linux kernel. \
4The LIBNVDIMM subsystem provides support for three types of \
5NVDIMMs, namely,PMEM, BLK, and NVDIMM devices that can \
6simultaneously support both PMEM and BLK mode access."
7HOMEPAGE = "https://git.kernel.org/cgit/linux/kernel/git/nvdimm/nvdimm.git/tree/Documentation/nvdimm/nvdimm.txt?h=libnvdimm-for-next"
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=e66651809cac5da60c8b80e9e4e79e08"
10
11inherit autotools-brokensep pkgconfig module-base
12
13SRCREV = "0d6aeeabec9d271e08c12e4cf679b59946e20156"
14SRC_URI = "git://github.com/pmem/ndctl.git"
15
16DEPENDS = "virtual/kernel kmod udev json-c"
17
18PV = "v61+git${SRCPV}"
19S = "${WORKDIR}/git"
20
21EXTRA_OECONF += "--enable-test --enable-destructive --disable-docs"
22
23do_configure_prepend() {
24 ${S}/autogen.sh
25}
26
27COMPATIBLE_HOST='(x86_64).*'
28
29FILES_${PN} += "/usr/share/bash-completion/completions/ndctl"