summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-01-23 22:24:12 -0800
committerKhem Raj <raj.khem@gmail.com>2024-01-27 09:48:31 -0800
commit793098cf03488560e72a2da7291c0ca3a4665f1a (patch)
tree3a2af1097a28974068864fe7f527b26b1bcb72ce /meta-oe/recipes-core
parent51392e0d1438be2923f72f7adb911d91619bb6cf (diff)
downloadmeta-openembedded-793098cf03488560e72a2da7291c0ca3a4665f1a.tar.gz
ndctl: Update to v78
Drop patches, they are not needed anymore Package /usr/lib/systemd/system/cxl-monitor.service Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/ndctl/ndctl/0001-build-set-HAVE_STATEMENT_EXPR-var.patch60
-rw-r--r--meta-oe/recipes-core/ndctl/ndctl/0001-meson-Use-pkg-config-to-detect-iniparser.patch41
-rw-r--r--meta-oe/recipes-core/ndctl/ndctl/0001-util-Correct-path-to-iniparser.h.patch28
-rw-r--r--meta-oe/recipes-core/ndctl/ndctl_v78.bb (renamed from meta-oe/recipes-core/ndctl/ndctl_v73.bb)13
4 files changed, 5 insertions, 137 deletions
diff --git a/meta-oe/recipes-core/ndctl/ndctl/0001-build-set-HAVE_STATEMENT_EXPR-var.patch b/meta-oe/recipes-core/ndctl/ndctl/0001-build-set-HAVE_STATEMENT_EXPR-var.patch
deleted file mode 100644
index 486d6c07b..000000000
--- a/meta-oe/recipes-core/ndctl/ndctl/0001-build-set-HAVE_STATEMENT_EXPR-var.patch
+++ /dev/null
@@ -1,60 +0,0 @@
1From b06d16ec2d4aefc4cf1675e9dd6314956bc32d69 Mon Sep 17 00:00:00 2001
2From: Naveen Saini <naveen.kumar.saini@intel.com>
3Date: Thu, 7 Apr 2022 14:36:58 +0800
4Subject: [PATCH] build: set HAVE_STATEMENT_EXPR var
5
6The v73 version tries to build and run a test program at compile
7time to check whether compiler supports sizeof and expression statements
8and sets HAVE_STATEMENT_EXPR accordingly. This requires EXEWRAPPER_ENABLED
9in meson.bbclass to be True and qemu-usermode to be working.
10
11In cases when EXEWRAPPER_ENABLED is False, build fails with error:
12
13| ../git/meson.build:213:0: ERROR: Can not run test applications in
14this cross environment.
15
16We don't really need to do this as these have been supported since gcc3 and can set the configs to 1.
17
18The autotools implementation also used to set it to 1 so this doesn't change anything:
19
20https://github.com/pmem/ndctl/blob/v72.1/configure.ac#L70
21
22Upstream-Status: Inappropriate
23
24Signed-off-by: Naveen Saini <naveen.kumar.saini@intel.com>
25---
26 meson.build | 18 ++----------------
27 1 file changed, 2 insertions(+), 16 deletions(-)
28
29diff --git a/meson.build b/meson.build
30index 42e11aa..e8d218b 100644
31--- a/meson.build
32+++ b/meson.build
33@@ -210,22 +210,8 @@ conf.set('ENABLE_DESTRUCTIVE', get_option('destructive').enabled())
34 conf.set('ENABLE_LOGGING', get_option('logging').enabled())
35 conf.set('ENABLE_DEBUG', get_option('dbg').enabled())
36
37-typeof = cc.run('''
38- int main() {
39- struct {
40- char a[16];
41- } x;
42- typeof(x) y;
43-
44- return sizeof(x) == sizeof(y);
45- }
46- '''
47-)
48-
49-if typeof.compiled() and typeof.returncode() == 1
50- conf.set('HAVE_TYPEOF', 1)
51- conf.set('HAVE_STATEMENT_EXPR', 1)
52-endif
53+conf.set('HAVE_TYPEOF', 1)
54+conf.set('HAVE_STATEMENT_EXPR', 1)
55
56 if target_machine.endian() == 'big'
57 conf.set('HAVE_BIG_ENDIAN', 1)
58--
592.17.1
60
diff --git a/meta-oe/recipes-core/ndctl/ndctl/0001-meson-Use-pkg-config-to-detect-iniparser.patch b/meta-oe/recipes-core/ndctl/ndctl/0001-meson-Use-pkg-config-to-detect-iniparser.patch
deleted file mode 100644
index ee172c3a6..000000000
--- a/meta-oe/recipes-core/ndctl/ndctl/0001-meson-Use-pkg-config-to-detect-iniparser.patch
+++ /dev/null
@@ -1,41 +0,0 @@
1From 44516eee75696c84849c0f7aa632e2456b101813 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 26 Mar 2022 00:57:03 -0700
4Subject: [PATCH] meson: Use pkg-config to detect iniparser
5
6Add iniparser dependency to util subdir
7
8Upstream-Status: Pending
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 meson.build | 2 +-
12 util/meson.build | 1 +
13 2 files changed, 2 insertions(+), 1 deletion(-)
14
15diff --git a/meson.build b/meson.build
16index 42e11aa..4209320 100644
17--- a/meson.build
18+++ b/meson.build
19@@ -160,7 +160,7 @@ cc = meson.get_compiler('c')
20
21 # keyutils and iniparser lack pkgconfig
22 keyutils = cc.find_library('keyutils', required : get_option('keyutils'))
23-iniparser = cc.find_library('iniparser', required : true)
24+iniparser = dependency('iniparser', required : true)
25
26 conf = configuration_data()
27 check_headers = [
28diff --git a/util/meson.build b/util/meson.build
29index 784b279..8e9ae9a 100644
30--- a/util/meson.build
31+++ b/util/meson.build
32@@ -12,5 +12,6 @@ util = static_library('util', [
33 'iomem.c',
34 ],
35 include_directories : root_inc,
36+ dependencies : iniparser,
37 )
38 util_dep = declare_dependency(link_with : util)
39--
402.35.1
41
diff --git a/meta-oe/recipes-core/ndctl/ndctl/0001-util-Correct-path-to-iniparser.h.patch b/meta-oe/recipes-core/ndctl/ndctl/0001-util-Correct-path-to-iniparser.h.patch
deleted file mode 100644
index fe2612ce9..000000000
--- a/meta-oe/recipes-core/ndctl/ndctl/0001-util-Correct-path-to-iniparser.h.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From c212d228c25cb583f52a6d31e9f0ec7bc1f9c506 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 26 Mar 2022 01:10:02 -0700
4Subject: [PATCH] util: Correct path to iniparser.h
5
6Upstream-Status: Pending
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10 util/parse-configs.c | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/util/parse-configs.c b/util/parse-configs.c
14index c834a07..1b7ffa6 100644
15--- a/util/parse-configs.c
16+++ b/util/parse-configs.c
17@@ -4,7 +4,7 @@
18 #include <dirent.h>
19 #include <errno.h>
20 #include <fcntl.h>
21-#include <iniparser.h>
22+#include <iniparser/iniparser.h>
23 #include <sys/stat.h>
24 #include <util/parse-configs.h>
25 #include <util/strbuf.h>
26--
272.35.1
28
diff --git a/meta-oe/recipes-core/ndctl/ndctl_v73.bb b/meta-oe/recipes-core/ndctl/ndctl_v78.bb
index da649d578..2974a7db7 100644
--- a/meta-oe/recipes-core/ndctl/ndctl_v73.bb
+++ b/meta-oe/recipes-core/ndctl/ndctl_v78.bb
@@ -10,19 +10,16 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=74a614eac8b2657a4b8e6607421a0883"
10 10
11inherit meson pkgconfig bash-completion systemd 11inherit meson pkgconfig bash-completion systemd
12 12
13SRCREV = "dd58d43458943d20ff063850670bf54a5242c9c5" 13SRCREV = "a871e6153b11fe63780b37cdcb1eb347b296095c"
14SRC_URI = "git://github.com/pmem/ndctl.git;branch=main;protocol=https \ 14SRC_URI = "git://github.com/pmem/ndctl.git;branch=main;protocol=https"
15 file://0001-util-Correct-path-to-iniparser.h.patch \
16 file://0001-meson-Use-pkg-config-to-detect-iniparser.patch \
17 file://0001-build-set-HAVE_STATEMENT_EXPR-var.patch"
18 15
19UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>v\d+(\.\d+)*)" 16UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>v\d+(\.\d+)*)"
20 17
21DEPENDS = "kmod udev json-c keyutils iniparser" 18DEPENDS = "kmod udev json-c keyutils iniparser libtraceevent libtracefs"
22 19
23S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
24 21
25EXTRA_OECONF += "-Ddestructive=enabled" 22EXTRA_OEMESON += "-Ddestructive=enabled -Diniparserdir=${STAGING_INCDIR}/iniparser"
26 23
27PACKAGECONFIG ??= "tests ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}" 24PACKAGECONFIG ??= "tests ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
28PACKAGECONFIG[systemd] = "-Dsystemd=enabled,-Dsystemd=disabled,systemd" 25PACKAGECONFIG[systemd] = "-Dsystemd=enabled,-Dsystemd=disabled,systemd"
@@ -33,4 +30,4 @@ SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',
33SYSTEMD_SERVICE:${PN} = "ndctl-monitor.service daxdev-reconfigure@.service" 30SYSTEMD_SERVICE:${PN} = "ndctl-monitor.service daxdev-reconfigure@.service"
34SYSTEMD_AUTO_ENABLE:${PN} = "disable" 31SYSTEMD_AUTO_ENABLE:${PN} = "disable"
35 32
36FILES:${PN} += "${datadir}/daxctl/daxctl.conf " 33FILES:${PN} += "${datadir}/daxctl/daxctl.conf ${nonarch_libdir}/systemd/system"