summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-10-21 13:55:53 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-24 16:23:42 +0200
commit48e381fcb09f2c91318e53f9256f4f702a046b9a (patch)
treeb41e55f37eda7c5f5fc3c86480e1aa44332c6c77 /meta-oe/recipes-core
parent7a364f8abc8090f662c7dccc21a7f389e54369f3 (diff)
downloadmeta-openembedded-48e381fcb09f2c91318e53f9256f4f702a046b9a.tar.gz
systemd: add lock group using useradd.bbclass
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/systemd/systemd_git.bb15
1 files changed, 5 insertions, 10 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd_git.bb b/meta-oe/recipes-core/systemd/systemd_git.bb
index c5503e840..4d314f85e 100644
--- a/meta-oe/recipes-core/systemd/systemd_git.bb
+++ b/meta-oe/recipes-core/systemd/systemd_git.bb
@@ -14,9 +14,9 @@ inherit gitpkgv
14PKGV = "v${GITPKGVTAG}" 14PKGV = "v${GITPKGVTAG}"
15 15
16PV = "git" 16PV = "git"
17PR = "r2" 17PR = "r3"
18 18
19inherit pkgconfig autotools vala perlnative 19inherit useradd pkgconfig autotools vala perlnative
20 20
21SRCREV = "64685e0cea62b4937f0804e47ce2cb7929f58223" 21SRCREV = "64685e0cea62b4937f0804e47ce2cb7929f58223"
22 22
@@ -59,6 +59,9 @@ do_install() {
59 59
60PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup ${PN}-initramfs" 60PACKAGES =+ "${PN}-gui ${PN}-vconsole-setup ${PN}-initramfs"
61 61
62USERADD_PACKAGES = "${PN}"
63GROUPADD_PARAM_${PN} = "-r lock"
64
62FILES_${PN}-initramfs = "/init" 65FILES_${PN}-initramfs = "/init"
63RDEPENDS_${PN}-initramfs = "${PN}" 66RDEPENDS_${PN}-initramfs = "${PN}"
64 67
@@ -113,12 +116,4 @@ update-alternatives --install ${base_sbindir}/halt halt ${base_bindir}/systemctl
113update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300 116update-alternatives --install ${base_sbindir}/reboot reboot ${base_bindir}/systemctl 300
114update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300 117update-alternatives --install ${base_sbindir}/shutdown shutdown ${base_bindir}/systemctl 300
115update-alternatives --install ${base_sbindir}/poweroff poweroff ${base_bindir}/systemctl 300 118update-alternatives --install ${base_sbindir}/poweroff poweroff ${base_bindir}/systemctl 300
116
117# can't do this offline, but we need the u-a bits above
118if [ "x$D" != "x" ]; then
119 echo "can't do addgroup offline" ; exit 1
120else
121 grep "^lock:" /etc/group > /dev/null || addgroup lock
122fi
123} 119}
124