summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-06 23:13:38 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-11 17:56:42 +0100
commit35eb06d8cc7e073724c8abbe944712cf9f8e7807 (patch)
tree8e1d97f069a3c63c10b3379b5ff44dea9b673725 /meta-oe/recipes-core
parentbfc4ad13077ef174ef881df4c1546ed64c2f6130 (diff)
downloadmeta-openembedded-35eb06d8cc7e073724c8abbe944712cf9f8e7807.tar.gz
libxml++: Update to 2.40.1
Fix ptests for S != B case Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/libxml/libxml++/libxml++_ptest.patch34
-rw-r--r--meta-oe/recipes-core/libxml/libxml++_2.40.1.bb (renamed from meta-oe/recipes-core/libxml/libxml++_2.38.1.bb)4
2 files changed, 19 insertions, 19 deletions
diff --git a/meta-oe/recipes-core/libxml/libxml++/libxml++_ptest.patch b/meta-oe/recipes-core/libxml/libxml++/libxml++_ptest.patch
index 82960f112..0d1a5186a 100644
--- a/meta-oe/recipes-core/libxml/libxml++/libxml++_ptest.patch
+++ b/meta-oe/recipes-core/libxml/libxml++/libxml++_ptest.patch
@@ -1,21 +1,21 @@
1diff --git a/Makefile.am b/Makefile.am 1Index: libxml++-2.40.1/Makefile.am
2index d4aadb1..0e36756 100644 2===================================================================
3--- a/Makefile.am 3--- libxml++-2.40.1.orig/Makefile.am
4+++ b/Makefile.am 4+++ libxml++-2.40.1/Makefile.am
5@@ -253,5 +253,8 @@ post-html: docs/index.html 5@@ -24,5 +24,8 @@ dist_noinst_SCRIPTS = autogen.sh
6 rsync $(rsync_args) -r docs/index.html $$USER,libxmlplusplus@web.sourceforge.net:$(web_path_project) 6
7 rsync $(rsync_args) -r examples $$USER,libxmlplusplus@web.sourceforge.net:$(web_path_project) 7 DISTCLEANFILES = MSVC_Net2010/libxml++/libxml++config.h
8 8
9+install-ptest: 9+install-ptest:
10+ make -C examples install-ptest 10+ make -C examples install-ptest
11+ 11+
12 # Optional: auto-generate the ChangeLog file from the git log on make dist 12 # Optional: auto-generate the ChangeLog file from the git log on make dist
13 include $(top_srcdir)/macros/dist-changelog.am 13 include $(top_srcdir)/build/dist-changelog.am
14diff --git a/examples/Makefile.am b/examples/Makefile.am 14Index: libxml++-2.40.1/examples/Makefile.am
15index d9541ca..c27e088 100644 15===================================================================
16--- a/examples/Makefile.am 16--- libxml++-2.40.1.orig/examples/Makefile.am
17+++ b/examples/Makefile.am 17+++ libxml++-2.40.1/examples/Makefile.am
18@@ -19,6 +19,8 @@ AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir) -I. $(LIBXMLXX_CFLAGS) 18@@ -19,6 +19,8 @@ AM_CPPFLAGS = -I$(top_builddir) -I$(top_
19 AM_CXXFLAGS = $(LIBXMLXX_WXXFLAGS) 19 AM_CXXFLAGS = $(LIBXMLXX_WXXFLAGS)
20 LDADD = $(top_builddir)/libxml++/libxml++-$(LIBXMLXX_API_VERSION).la $(LIBXMLXX_LIBS) 20 LDADD = $(top_builddir)/libxml++/libxml++-$(LIBXMLXX_API_VERSION).la $(LIBXMLXX_LIBS)
21 21
@@ -24,7 +24,7 @@ index d9541ca..c27e088 100644
24 check_PROGRAMS = \ 24 check_PROGRAMS = \
25 dom_build/dom_build \ 25 dom_build/dom_build \
26 dom_parse_entities/dom_parse_entities \ 26 dom_parse_entities/dom_parse_entities \
27@@ -36,6 +38,23 @@ check_PROGRAMS = \ 27@@ -37,6 +39,23 @@ check_PROGRAMS = \
28 schemavalidation/schemavalidation \ 28 schemavalidation/schemavalidation \
29 textreader/textreader 29 textreader/textreader
30 30
@@ -48,7 +48,7 @@ index d9541ca..c27e088 100644
48 # Shell scripts that call the example programs. 48 # Shell scripts that call the example programs.
49 check_SCRIPTS = \ 49 check_SCRIPTS = \
50 dom_build/make_check.sh \ 50 dom_build/make_check.sh \
51@@ -147,10 +166,10 @@ dist_noinst_DATA = \ 51@@ -154,10 +173,10 @@ dist_noinst_DATA = \
52 # file are located in different directories. 52 # file are located in different directories.
53 dom_read_write/make_check.sh: Makefile 53 dom_read_write/make_check.sh: Makefile
54 echo '# Generated and used by "make check"' >$@ 54 echo '# Generated and used by "make check"' >$@
@@ -61,7 +61,7 @@ index d9541ca..c27e088 100644
61 standard_scripts = $(filter-out dom_read_write/make_check.sh,$(check_SCRIPTS)) 61 standard_scripts = $(filter-out dom_read_write/make_check.sh,$(check_SCRIPTS))
62 62
63 # All other script files are generated like so: 63 # All other script files are generated like so:
64@@ -162,3 +181,18 @@ $(standard_scripts): Makefile 64@@ -169,3 +188,18 @@ $(standard_scripts): Makefile
65 CLEANFILES = \ 65 CLEANFILES = \
66 dom_read_write/example_output.xml \ 66 dom_read_write/example_output.xml \
67 $(check_SCRIPTS) 67 $(check_SCRIPTS)
@@ -77,6 +77,6 @@ index d9541ca..c27e088 100644
77+ cd $(srcdir) && cp --parents $(dist_noinst_DATA) $(DESTDIR)/examples 77+ cd $(srcdir) && cp --parents $(dist_noinst_DATA) $(DESTDIR)/examples
78+ cp Makefile $(DESTDIR)/examples 78+ cp Makefile $(DESTDIR)/examples
79+ $(MKDIR_P) $(DESTDIR)/macros 79+ $(MKDIR_P) $(DESTDIR)/macros
80+ cp $(srcdir)/../macros/test-driver $(DESTDIR)/macros 80+ cp $(top_srcdir)/build/test-driver $(DESTDIR)/macros
81+ sed -i -e 's|^Makefile:|_Makefile:|' $(DESTDIR)/examples/Makefile 81+ sed -i -e 's|^Makefile:|_Makefile:|' $(DESTDIR)/examples/Makefile
82+ 82+
diff --git a/meta-oe/recipes-core/libxml/libxml++_2.38.1.bb b/meta-oe/recipes-core/libxml/libxml++_2.40.1.bb
index 2cb954835..c001c184c 100644
--- a/meta-oe/recipes-core/libxml/libxml++_2.38.1.bb
+++ b/meta-oe/recipes-core/libxml/libxml++_2.40.1.bb
@@ -11,8 +11,8 @@ SRC_URI = "${GNOME_MIRROR}/${BPN}/${SHRT_VER}/${BP}.tar.xz \
11 file://libxml++_ptest.patch \ 11 file://libxml++_ptest.patch \
12 file://run-ptest \ 12 file://run-ptest \
13" 13"
14SRC_URI[md5sum] = "6b16aac575725a9bc0e9d96489e9251f" 14SRC_URI[md5sum] = "377a87bea899f2b4ff62df2418c3d8a6"
15SRC_URI[sha256sum] = "882529189b03db6c69925b3f579ab1941feb4f02b5fe2612504ee7e498a4a05f" 15SRC_URI[sha256sum] = "4ad4abdd3258874f61c2e2a41d08e9930677976d303653cd1670d3e9f35463e9"
16 16
17DEPENDS = "libxml2 glibmm" 17DEPENDS = "libxml2 glibmm"
18 18