summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-11-03 17:19:19 -0700
committerKhem Raj <raj.khem@gmail.com>2023-11-05 22:26:54 -0800
commit2e7666002780e8e4b75092f20a7216d5ef989e5f (patch)
treea6ce585afdc1afdf1c204e653e14711f8f163cc0 /meta-oe/recipes-core
parente849f51ea99a8441c89634339ce89114bd5df521 (diff)
downloadmeta-openembedded-2e7666002780e8e4b75092f20a7216d5ef989e5f.tar.gz
toybox: upgrade 0.8.8 -> 0.8.10
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/toybox/toybox/0001-portability-Fix-timer_settime_wrap-for-32bit-systems.patch37
-rw-r--r--meta-oe/recipes-core/toybox/toybox_0.8.10.bb (renamed from meta-oe/recipes-core/toybox/toybox_0.8.8.bb)6
2 files changed, 2 insertions, 41 deletions
diff --git a/meta-oe/recipes-core/toybox/toybox/0001-portability-Fix-timer_settime_wrap-for-32bit-systems.patch b/meta-oe/recipes-core/toybox/toybox/0001-portability-Fix-timer_settime_wrap-for-32bit-systems.patch
deleted file mode 100644
index 8976b3748..000000000
--- a/meta-oe/recipes-core/toybox/toybox/0001-portability-Fix-timer_settime_wrap-for-32bit-systems.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From 7284c7ae0df9aa5a9c8aa0a81a018e17289fe2c4 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 8 Sep 2022 07:22:26 -0700
4Subject: [PATCH] portability: Fix timer_settime_wrap for 32bit systems with
5 64bit time_t
6
7glibc does not define SYS_timer_settime if the 32bit syscall is not
8available, new architectures like riscv32 has defaulted to 64bit time_t
9from get go and avoided wiring 32bit syscall, therefore alias it to
1064bit version here
11
12Upstream-Status: Submitted [https://github.com/landley/toybox/pull/373]
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 lib/portability.c | 6 ++++++
16 1 file changed, 6 insertions(+)
17
18diff --git a/lib/portability.c b/lib/portability.c
19index d955d081..4baa9367 100644
20--- a/lib/portability.c
21+++ b/lib/portability.c
22@@ -711,6 +711,12 @@ int timer_create_wrap(clockid_t c, struct sigevent *se, timer_t *t)
23 return 0;
24 }
25
26+#if !defined(SYS_timer_settime) && defined(SYS_timer_settime64)
27+// glibc does not define defines SYS_timer_settime on 32-bit systems
28+// with 64-bit time_t defaults e.g. riscv32
29+#define SYS_timer_settime SYS_timer_settime64
30+#endif
31+
32 int timer_settime_wrap(timer_t t, int flags, struct itimerspec *val,
33 struct itimerspec *old)
34 {
35--
362.37.3
37
diff --git a/meta-oe/recipes-core/toybox/toybox_0.8.8.bb b/meta-oe/recipes-core/toybox/toybox_0.8.10.bb
index 6836b1468..d747ebf36 100644
--- a/meta-oe/recipes-core/toybox/toybox_0.8.8.bb
+++ b/meta-oe/recipes-core/toybox/toybox_0.8.10.bb
@@ -7,10 +7,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=78659a599b9325da368f2f1eb88f19c7"
7 7
8inherit cml1 update-alternatives 8inherit cml1 update-alternatives
9 9
10SRC_URI = "http://www.landley.net/toybox/downloads/${BPN}-${PV}.tar.gz \ 10SRC_URI = "http://www.landley.net/toybox/downloads/${BPN}-${PV}.tar.gz"
11 file://0001-portability-Fix-timer_settime_wrap-for-32bit-systems.patch \ 11SRC_URI[sha256sum] = "d3afee05ca90bf425ced73f527e418fecd626c5340b5f58711a14531f8d7d108"
12 "
13SRC_URI[sha256sum] = "dafd41978d40f02a61cf1be99a2b4a25812bbfb9c3157e679ee7611202d6ac58"
14 12
15SECTION = "base" 13SECTION = "base"
16 14