summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-08-18 18:53:48 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-22 15:56:28 +0200
commit289217bbc3c5c53f486ab5615a6d6196e3c12cf2 (patch)
treef9551306e700a0ba0218177f3ec417f76d1f5759 /meta-oe/recipes-core
parentf2bec07b87b3f1118aa1d1f194d230920f1afe01 (diff)
downloadmeta-openembedded-289217bbc3c5c53f486ab5615a6d6196e3c12cf2.tar.gz
meta-oe: fix indentation
* remove tabs which sneaked in since last cleanup * meta-oe layers are using consistent indentation with 4 spaces, see http://www.openembedded.org/wiki/Styleguide Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r--meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb31
-rw-r--r--meta-oe/recipes-core/usleep/usleep_1.0.bb14
2 files changed, 23 insertions, 22 deletions
diff --git a/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb b/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
index de23dcd5b..1c1a02d0b 100644
--- a/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
+++ b/meta-oe/recipes-core/plymouth/plymouth_0.9.2.bb
@@ -1,8 +1,9 @@
1SUMMARY = "Plymouth is a project from Fedora providing a flicker-free graphical boot process." 1SUMMARY = "Plymouth is a project from Fedora providing a flicker-free graphical boot process."
2 2
3DESCRIPTION = "Plymouth is an application that runs very early in the boot process \ 3DESCRIPTION = "Plymouth is an application that runs very early in the boot process \
4 (even before the root filesystem is mounted!) that provides a \ 4 (even before the root filesystem is mounted!) that provides a \
5 graphical boot animation while the boot process happens in the background." 5 graphical boot animation while the boot process happens in the background. \
6"
6 7
7HOMEPAGE = "http://www.freedesktop.org/wiki/Software/Plymouth" 8HOMEPAGE = "http://www.freedesktop.org/wiki/Software/Plymouth"
8SECTION = "base" 9SECTION = "base"
@@ -19,10 +20,10 @@ SRC_URI = "http://www.freedesktop.org/software/plymouth/releases/${BPN}-${PV}.ta
19SRC_URI[md5sum] = "ff420994deb7ea203df678df92e7ab7d" 20SRC_URI[md5sum] = "ff420994deb7ea203df678df92e7ab7d"
20SRC_URI[sha256sum] = "2f0ce82042cf9c7eadd2517a1f74c8a85fa8699781d9f294a06eade29fbed57f" 21SRC_URI[sha256sum] = "2f0ce82042cf9c7eadd2517a1f74c8a85fa8699781d9f294a06eade29fbed57f"
21 22
22EXTRA_OECONF += " --enable-shared --disable-static --disable-gtk --disable-documentation\ 23EXTRA_OECONF += " --enable-shared --disable-static --disable-gtk --disable-documentation \
23 --with-logo=${LOGO} \ 24 --with-logo=${LOGO} \
24 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-system-root-install', '', d)} \ 25 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-system-root-install', '', d)} \
25 " 26"
26 27
27PACKAGECONFIG ??= "pango initrd" 28PACKAGECONFIG ??= "pango initrd"
28PACKAGECONFIG_append_x86 = " drm" 29PACKAGECONFIG_append_x86 = " drm"
@@ -38,15 +39,15 @@ LOGO ??= "${datadir}/plymouth/bizcom.png"
38inherit autotools pkgconfig systemd 39inherit autotools pkgconfig systemd
39 40
40do_install_append() { 41do_install_append() {
41 install -d ${D}${systemd_unitdir}/system 42 install -d ${D}${systemd_unitdir}/system
42 install -m 644 ${B}/systemd-units/*.service ${D}${systemd_unitdir}/system 43 install -m 644 ${B}/systemd-units/*.service ${D}${systemd_unitdir}/system
43 install -m 644 ${B}/systemd-units/systemd-ask-password-plymouth.path ${D}${systemd_unitdir}/system 44 install -m 644 ${B}/systemd-units/systemd-ask-password-plymouth.path ${D}${systemd_unitdir}/system
44 # Remove /var/run from package as plymouth will populate it on startup 45 # Remove /var/run from package as plymouth will populate it on startup
45 rm -fr "${D}${localstatedir}/run" 46 rm -fr "${D}${localstatedir}/run"
46 47
47 if ! ${@bb.utils.contains('PACKAGECONFIG', 'initrd', 'true', 'false', d)}; then 48 if ! ${@bb.utils.contains('PACKAGECONFIG', 'initrd', 'true', 'false', d)}; then
48 rm -rf "${D}${libexecdir}" 49 rm -rf "${D}${libexecdir}"
49 fi 50 fi
50} 51}
51 52
52PACKAGES =. "${@bb.utils.contains('PACKAGECONFIG', 'initrd', '${PN}-initrd ', '', d)}" 53PACKAGES =. "${@bb.utils.contains('PACKAGECONFIG', 'initrd', '${PN}-initrd ', '', d)}"
diff --git a/meta-oe/recipes-core/usleep/usleep_1.0.bb b/meta-oe/recipes-core/usleep/usleep_1.0.bb
index 2ef4b7c02..403c6b7fe 100644
--- a/meta-oe/recipes-core/usleep/usleep_1.0.bb
+++ b/meta-oe/recipes-core/usleep/usleep_1.0.bb
@@ -9,18 +9,18 @@ S = "${WORKDIR}"
9DEPENDS = "popt" 9DEPENDS = "popt"
10 10
11SRC_URI = "file://usleep.c \ 11SRC_URI = "file://usleep.c \
12 file://usleep.1 \ 12 file://usleep.1 \
13 file://GPLv2.patch \ 13 file://GPLv2.patch \
14" 14"
15 15
16do_compile() { 16do_compile() {
17 ${CC} ${CFLAGS} ${LDFLAGS} usleep.c -o usleep -lpopt 17 ${CC} ${CFLAGS} ${LDFLAGS} usleep.c -o usleep -lpopt
18} 18}
19 19
20do_install() { 20do_install() {
21 install -d ${D}${base_bindir} 21 install -d ${D}${base_bindir}
22 install -d ${D}${mandir}/man1 22 install -d ${D}${mandir}/man1
23 23
24 install -m 0755 ${WORKDIR}/usleep ${D}${base_bindir} 24 install -m 0755 ${WORKDIR}/usleep ${D}${base_bindir}
25 install -m 0644 ${WORKDIR}/usleep.1 ${D}${mandir}/man1 25 install -m 0644 ${WORKDIR}/usleep.1 ${D}${mandir}/man1
26} 26}