diff options
author | Ross Burton <ross.burton@intel.com> | 2016-04-22 20:48:49 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-04-28 10:38:38 +0200 |
commit | 21f10c11f39020f9502d741c774a12d1aeb39499 (patch) | |
tree | fdc66c039950da89d82b6b7405ebfc50cbba693a /meta-oe/recipes-core | |
parent | 723b55f5c1f7df21dbcfa7cb2dcaecb10d886041 (diff) | |
download | meta-openembedded-21f10c11f39020f9502d741c774a12d1aeb39499.tar.gz |
meta-oe: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so
replace all instances with bb.utils.contains().
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r-- | meta-oe/recipes-core/packagegroups/packagegroup-basic.bb | 10 | ||||
-rw-r--r-- | meta-oe/recipes-core/packagegroups/packagegroup-boot.bb | 2 |
2 files changed, 6 insertions, 6 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb b/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb index 4f2992cb6f..21dd1deb65 100644 --- a/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb +++ b/meta-oe/recipes-core/packagegroups/packagegroup-basic.bb | |||
@@ -42,12 +42,12 @@ RDEPENDS_${PN} = "\ | |||
42 | # | 42 | # |
43 | RRECOMMENDS_${PN} = "\ | 43 | RRECOMMENDS_${PN} = "\ |
44 | ${MACHINE_EXTRA_RRECOMMENDS} \ | 44 | ${MACHINE_EXTRA_RRECOMMENDS} \ |
45 | ${@base_contains("MACHINE_FEATURES", "usbhost", "usbutils", "", d)} \ | 45 | ${@bb.utils.contains("MACHINE_FEATURES", "usbhost", "usbutils", "", d)} \ |
46 | ${@base_contains("MACHINE_FEATURES", "alsa", "alsa-utils-alsamixer", "", d)} \ | 46 | ${@bb.utils.contains("MACHINE_FEATURES", "alsa", "alsa-utils-alsamixer", "", d)} \ |
47 | ${@base_contains("MACHINE_FEATURES", "usbgadget", "kernel-module-g-ether kernel-module-g-serial kernel-module-g-mass-storage", "", d)} \ | 47 | ${@bb.utils.contains("MACHINE_FEATURES", "usbgadget", "kernel-module-g-ether kernel-module-g-serial kernel-module-g-mass-storage", "", d)} \ |
48 | \ | 48 | \ |
49 | ${@base_contains("DISTRO_FEATURES", "bluetooth", "${BLUEZ}", "", d)} \ | 49 | ${@bb.utils.contains("DISTRO_FEATURES", "bluetooth", "${BLUEZ}", "", d)} \ |
50 | ${@base_contains("DISTRO_FEATURES", "wifi", "iw wpa-supplicant", "", d)} \ | 50 | ${@bb.utils.contains("DISTRO_FEATURES", "wifi", "iw wpa-supplicant", "", d)} \ |
51 | \ | 51 | \ |
52 | tzdata \ | 52 | tzdata \ |
53 | \ | 53 | \ |
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb b/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb index f50443d812..a542ae4204 100644 --- a/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb +++ b/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb | |||
@@ -24,7 +24,7 @@ RDEPENDS_${PN} = "\ | |||
24 | base-passwd \ | 24 | base-passwd \ |
25 | busybox \ | 25 | busybox \ |
26 | netbase \ | 26 | netbase \ |
27 | ${@base_contains("MACHINE_FEATURES", "keyboard", "keymaps", "", d)} \ | 27 | ${@bb.utils.contains("MACHINE_FEATURES", "keyboard", "keymaps", "", d)} \ |
28 | ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \ | 28 | ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \ |
29 | " | 29 | " |
30 | 30 | ||