summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/tasks
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-09 13:13:32 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-09 19:34:05 +0200
commitf94e91dafcf3ebbbbdabbad1a89f7bf235b3aa81 (patch)
treea1553fb85f719877ebc0d4a66ba11be135aa2bb5 /meta-oe/recipes-core/tasks
parent7c335da35a4c83ad4280079ea9f983b15e1be969 (diff)
downloadmeta-openembedded-f94e91dafcf3ebbbbdabbad1a89f7bf235b3aa81.tar.gz
task-basic: initial add
This recipe is intended as a 'simpler' replacement for task-base. Please communicate your use cases and suggestions to the mailinglist(s) Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/tasks')
-rw-r--r--meta-oe/recipes-core/tasks/task-basic.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/tasks/task-basic.bb b/meta-oe/recipes-core/tasks/task-basic.bb
new file mode 100644
index 000000000..9e8ae979f
--- /dev/null
+++ b/meta-oe/recipes-core/tasks/task-basic.bb
@@ -0,0 +1,49 @@
1# This recipe is intended as a 'simpler' replacement for task-base.
2# Please communicate your use cases and suggestions to the mailinglist(s)
3
4DESCRIPTION = "Basic task to get a device online"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
7
8inherit task
9
10# packages which content depend on MACHINE_FEATURES need to be MACHINE_ARCH
11#
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14#
15# Select between dropbear and openssh
16# Set TASK_BASIC_SSHDAEMON = "openssh-sshd openssh-sftp" in your DISTRO config to get openssh(d)
17#
18TASK_BASIC_SSHDAEMON ?= "dropbear-systemd openssh-sftp"
19
20#
21# The section below is designed to match with task-boot, but doesn't depend on it to allow for more freedom
22# when writing image recipes.
23# It also avoids the choice between connman/networkmanager/ifupdown since that is an image feature, not a
24# distro feature.
25#
26RDEPENDS_${PN} = "\
27 ${TASK_BASIC_SSHDAEMON} \
28 avahi-daemon avahi-utils avahi-systemd \
29 systemd-compat-units \
30 "
31
32#
33# The following section is split in 3:
34# 1) Machine features: kernel modules and userspace helpers for those
35# 2) Distro features: packages associated with those
36# 3) Nice to have: packages that are nice to have, but aren't strictly needed
37#
38RRECOMMENDS_${PN} = "\
39 ${@base_contains("MACHINE_FEATURES", "usbhost", "usbutils", "", d)} \
40 ${@base_contains("MACHINE_FEATURES", "alsa", "alsa-utils-alsamixer", "", d)} \
41 ${@base_contains("MACHINE_FEATURES", "usbgadget", "kernel-module-g-ether kernel-module-g-serial kernel-module-g-mass-storage", "", d)} \
42 \
43 ${@base_contains("DISTRO_FEATURES", "bluetooth", "bluez4", "", d)} \
44 ${@base_contains("DISTRO_FEATURES", "wifi", "iw wpa-supplicant", "", d)} \
45 \
46 rsyslog \
47 cpufrequtils \
48 htop \
49 "