diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2011-10-21 13:55:51 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-10-21 16:13:46 +0200 |
commit | 8fee9e2af657f1233ceda5f0fd8dab76554d03be (patch) | |
tree | 06d5ddc7ca6787b2032639b2a4ceedc165682070 /meta-oe/recipes-core/systemd/systemd-serialgetty.bb | |
parent | 36423031ae2cc2157232f3bec8f5c9fa53ef215d (diff) | |
download | meta-openembedded-8fee9e2af657f1233ceda5f0fd8dab76554d03be.tar.gz |
systemd-serialgetty: don't require systemd_git.bb
Avoids the recompile of this package every time systemd is change.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/systemd/systemd-serialgetty.bb')
-rw-r--r-- | meta-oe/recipes-core/systemd/systemd-serialgetty.bb | 23 |
1 files changed, 8 insertions, 15 deletions
diff --git a/meta-oe/recipes-core/systemd/systemd-serialgetty.bb b/meta-oe/recipes-core/systemd/systemd-serialgetty.bb index d7e857162..86d833e64 100644 --- a/meta-oe/recipes-core/systemd/systemd-serialgetty.bb +++ b/meta-oe/recipes-core/systemd/systemd-serialgetty.bb | |||
@@ -1,19 +1,11 @@ | |||
1 | require systemd_git.bb | ||
2 | |||
3 | SRC_URI = "git://anongit.freedesktop.org/systemd;protocol=git \ | ||
4 | file://serial-getty@.service \ | ||
5 | " | ||
6 | |||
7 | DESCRIPTION = "Systemd serial config" | 1 | DESCRIPTION = "Systemd serial config" |
8 | SERIAL_CONSOLE ?= "115200 /dev/ttyS0" | 2 | LICENSE = "GPLv2+" |
3 | LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=751419260aa954499f7abaabaa882bbe" | ||
9 | 4 | ||
10 | do_configure() { | 5 | SERIAL_CONSOLE ?= "115200 /dev/ttyS0" |
11 | : | ||
12 | } | ||
13 | 6 | ||
14 | do_compile() { | 7 | SRC_URI = "file://LICENSE \ |
15 | : | 8 | file://serial-getty@.service" |
16 | } | ||
17 | 9 | ||
18 | def get_baudrate(bb, d): | 10 | def get_baudrate(bb, d): |
19 | return bb.data.getVar('SERIAL_CONSOLE', d, 1).split()[0] | 11 | return bb.data.getVar('SERIAL_CONSOLE', d, 1).split()[0] |
@@ -27,9 +19,11 @@ do_install() { | |||
27 | install -d ${D}${base_libdir}/systemd/system/ | 19 | install -d ${D}${base_libdir}/systemd/system/ |
28 | install -d ${D}${sysconfdir}/systemd/system/getty.target.wants/ | 20 | install -d ${D}${sysconfdir}/systemd/system/getty.target.wants/ |
29 | install ${WORKDIR}/serial-getty@.service ${D}${base_libdir}/systemd/system/ | 21 | install ${WORKDIR}/serial-getty@.service ${D}${base_libdir}/systemd/system/ |
22 | |||
23 | # enable the service | ||
30 | ln -sf ${base_libdir}/systemd/system/serial-getty@.service \ | 24 | ln -sf ${base_libdir}/systemd/system/serial-getty@.service \ |
31 | ${D}${sysconfdir}/systemd/system/getty.target.wants/serial-getty@${@get_console(bb, d)}.service | 25 | ${D}${sysconfdir}/systemd/system/getty.target.wants/serial-getty@${@get_console(bb, d)}.service |
32 | fi | 26 | fi |
33 | } | 27 | } |
34 | 28 | ||
35 | PACKAGES = "${PN} ${PN}-dbg ${PN}-dev ${PN}-doc" | 29 | PACKAGES = "${PN} ${PN}-dbg ${PN}-dev ${PN}-doc" |
@@ -40,4 +34,3 @@ RDEPENDS_${PN} = "systemd" | |||
40 | # This is a machine specific file | 34 | # This is a machine specific file |
41 | FILES_${PN} = "${base_libdir}/systemd/system/serial-getty@.service ${sysconfdir}" | 35 | FILES_${PN} = "${base_libdir}/systemd/system/serial-getty@.service ${sysconfdir}" |
42 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 36 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
43 | |||