summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/libxml
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-core/libxml
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-core/libxml')
-rw-r--r--meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch82
-rw-r--r--meta-oe/recipes-core/libxml/libxml++-2.37.1/run-ptest3
-rw-r--r--meta-oe/recipes-core/libxml/libxml++_2.37.1.bb28
3 files changed, 113 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch b/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch
new file mode 100644
index 000000000..82960f112
--- /dev/null
+++ b/meta-oe/recipes-core/libxml/libxml++-2.37.1/libxml++_ptest.patch
@@ -0,0 +1,82 @@
1diff --git a/Makefile.am b/Makefile.am
2index d4aadb1..0e36756 100644
3--- a/Makefile.am
4+++ b/Makefile.am
5@@ -253,5 +253,8 @@ post-html: docs/index.html
6 rsync $(rsync_args) -r docs/index.html $$USER,libxmlplusplus@web.sourceforge.net:$(web_path_project)
7 rsync $(rsync_args) -r examples $$USER,libxmlplusplus@web.sourceforge.net:$(web_path_project)
8
9+install-ptest:
10+ make -C examples install-ptest
11+
12 # Optional: auto-generate the ChangeLog file from the git log on make dist
13 include $(top_srcdir)/macros/dist-changelog.am
14diff --git a/examples/Makefile.am b/examples/Makefile.am
15index d9541ca..c27e088 100644
16--- a/examples/Makefile.am
17+++ b/examples/Makefile.am
18@@ -19,6 +19,8 @@ AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir) -I. $(LIBXMLXX_CFLAGS)
19 AM_CXXFLAGS = $(LIBXMLXX_WXXFLAGS)
20 LDADD = $(top_builddir)/libxml++/libxml++-$(LIBXMLXX_API_VERSION).la $(LIBXMLXX_LIBS)
21
22+LOG_DRIVER = $(SHELL) ../macros/test-driver
23+
24 check_PROGRAMS = \
25 dom_build/dom_build \
26 dom_parse_entities/dom_parse_entities \
27@@ -36,6 +38,23 @@ check_PROGRAMS = \
28 schemavalidation/schemavalidation \
29 textreader/textreader
30
31+check_DOTLIBS = \
32+ dom_build/.libs/dom_build \
33+ dom_parse_entities/.libs/dom_parse_entities \
34+ dom_parser/.libs/dom_parser \
35+ dom_parser_raw/.libs/dom_parser_raw \
36+ dom_read_write/.libs/dom_read_write \
37+ dom_xinclude/.libs/dom_xinclude \
38+ dom_xpath/.libs/dom_xpath \
39+ dtdvalidation/.libs/dtdvalidation \
40+ import_node/.libs/import_node \
41+ sax_exception/.libs/sax_exception \
42+ sax_parser/.libs/sax_parser \
43+ sax_parser_build_dom/.libs/sax_parser_build_dom \
44+ sax_parser_entities/.libs/sax_parser_entities \
45+ schemavalidation/.libs/schemavalidation \
46+ textreader/.libs/textreader
47+
48 # Shell scripts that call the example programs.
49 check_SCRIPTS = \
50 dom_build/make_check.sh \
51@@ -147,10 +166,10 @@ dist_noinst_DATA = \
52 # file are located in different directories.
53 dom_read_write/make_check.sh: Makefile
54 echo '# Generated and used by "make check"' >$@
55- echo 'dom_read_write/dom_read_write "$(srcdir)/dom_read_write/example.xml" dom_read_write/example_output.xml >/dev/null' >>$@
56+ echo 'cd dom_read_write && .libs/dom_read_write "example.xml" example_output.xml >/dev/null' >>$@
57 chmod +x $@
58
59-script_template = cd "$(srcdir)/<!progname!>" && "$(abs_builddir)/<!progname!>/<!progname!>" >/dev/null
60+script_template = cd "<!progname!>" && ".libs/<!progname!>" >/dev/null
61 standard_scripts = $(filter-out dom_read_write/make_check.sh,$(check_SCRIPTS))
62
63 # All other script files are generated like so:
64@@ -162,3 +181,18 @@ $(standard_scripts): Makefile
65 CLEANFILES = \
66 dom_read_write/example_output.xml \
67 $(check_SCRIPTS)
68+
69+buildtest: all
70+ $(MAKE) $(AM_MAKEFLAGS) $(check_PROGRAMS) $(check_SCRIPTS)
71+ $(MAKE) $(AM_MAKEFLAGS) buildtest-TESTS
72+
73+install-ptest:
74+ $(MKDIR_P) $(DESTDIR)/examples
75+ cp --parents $(check_DOTLIBS) $(DESTDIR)/examples
76+ cp --parents $(check_SCRIPTS) $(DESTDIR)/examples
77+ cd $(srcdir) && cp --parents $(dist_noinst_DATA) $(DESTDIR)/examples
78+ cp Makefile $(DESTDIR)/examples
79+ $(MKDIR_P) $(DESTDIR)/macros
80+ cp $(srcdir)/../macros/test-driver $(DESTDIR)/macros
81+ sed -i -e 's|^Makefile:|_Makefile:|' $(DESTDIR)/examples/Makefile
82+
diff --git a/meta-oe/recipes-core/libxml/libxml++-2.37.1/run-ptest b/meta-oe/recipes-core/libxml/libxml++-2.37.1/run-ptest
new file mode 100644
index 000000000..236f66753
--- /dev/null
+++ b/meta-oe/recipes-core/libxml/libxml++-2.37.1/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2cd examples
3make -k check-TESTS
diff --git a/meta-oe/recipes-core/libxml/libxml++_2.37.1.bb b/meta-oe/recipes-core/libxml/libxml++_2.37.1.bb
new file mode 100644
index 000000000..0ed8ee399
--- /dev/null
+++ b/meta-oe/recipes-core/libxml/libxml++_2.37.1.bb
@@ -0,0 +1,28 @@
1SUMMARY = "C++ wrapper for libxml library"
2DESCRIPTION = "C++ wrapper for libxml library"
3HOMEPAGE = "http://libxmlplusplus.sourceforge.net"
4BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml%2B%2B"
5SECTION = "libs"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34 "
8
9SHRT_VER = "${@d.getVar('PV',True).split('.')[0]}.${@d.getVar('PV',True).split('.')[1]}"
10SRC_URI = "${GNOME_MIRROR}/${BPN}/${SHRT_VER}/${BP}.tar.xz \
11 file://libxml++_ptest.patch \
12 file://run-ptest \
13"
14SRC_URI[md5sum] = "2f9372a6eba6e40206c11f558a8fbc32"
15SRC_URI[sha256sum] = "f3b183600532a92af355719210223f858857092b8b1531c7907155c59a6db39f"
16
17DEPENDS = "libxml2 glibmm"
18
19inherit autotools pkgconfig ptest
20
21do_compile_ptest() {
22 oe_runmake -C examples buildtest
23}
24
25FILES_${PN}-doc += "${datadir}/devhelp"
26FILES_${PN}-dev += "${libdir}/libxml++-2.6/include/libxml++config.h"
27
28RDEPENDS_${PN}-ptest += "make"