summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/glib-2.0
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2011-09-29 16:30:36 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-12 13:02:55 +0200
commit7d0a12d091b0f802a31c8769b8b28fc25c1cc870 (patch)
tree162a99d5ffe36aeb728ee3f7b00f00f52999c475 /meta-oe/recipes-core/glib-2.0
parent5e49da18dd6e355d70f3872ed22699551d120212 (diff)
downloadmeta-openembedded-7d0a12d091b0f802a31c8769b8b28fc25c1cc870.tar.gz
glib-2.0: drop 2.29.3+git from meta-oe, there should be 2.30.0 in oe-core
* see http://lists.linuxtogo.org/pipermail/openembedded-core/2011-September/010447.html Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core/glib-2.0')
-rw-r--r--meta-oe/recipes-core/glib-2.0/glib-2.0.inc6
-rw-r--r--meta-oe/recipes-core/glib-2.0/glib-2.0/0003-gatomic-proper-pointer-get-cast.patch.patch28
-rw-r--r--meta-oe/recipes-core/glib-2.0/glib-2.0/0005-glib-mkenums-interpreter.patch.patch25
-rw-r--r--meta-oe/recipes-core/glib-2.0/glib-2.0/60_wait-longer-for-threads-to-die.patch33
-rw-r--r--meta-oe/recipes-core/glib-2.0/glib-2.0/configure-libtool.patch38
-rw-r--r--meta-oe/recipes-core/glib-2.0/glib-2.0/g_once_init_enter.patch24
-rw-r--r--meta-oe/recipes-core/glib-2.0/glib-2.0/glib-gettextize-dir.patch24
-rw-r--r--meta-oe/recipes-core/glib-2.0/glib-2.0/no-iconv.patch104
-rw-r--r--meta-oe/recipes-core/glib-2.0/glib-2.0/remove.test.for.qsort_r.patch54
-rw-r--r--meta-oe/recipes-core/glib-2.0/glib-2.0_git.bb32
-rw-r--r--meta-oe/recipes-core/glib-2.0/glib.inc38
11 files changed, 0 insertions, 406 deletions
diff --git a/meta-oe/recipes-core/glib-2.0/glib-2.0.inc b/meta-oe/recipes-core/glib-2.0/glib-2.0.inc
deleted file mode 100644
index ccbbd2b35..000000000
--- a/meta-oe/recipes-core/glib-2.0/glib-2.0.inc
+++ /dev/null
@@ -1,6 +0,0 @@
1
2python () {
3 import bb
4 if bb.data.getVar("USE_NLS", d, 1) == "no":
5 raise bb.parse.SkipPackage("${PN} requires native language support.")
6}
diff --git a/meta-oe/recipes-core/glib-2.0/glib-2.0/0003-gatomic-proper-pointer-get-cast.patch.patch b/meta-oe/recipes-core/glib-2.0/glib-2.0/0003-gatomic-proper-pointer-get-cast.patch.patch
deleted file mode 100644
index ad1ca12b8..000000000
--- a/meta-oe/recipes-core/glib-2.0/glib-2.0/0003-gatomic-proper-pointer-get-cast.patch.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 3d371334d5668bcd02a38ff99884bd343c244d68 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Sat, 18 Jun 2011 23:51:35 +0200
4Subject: [PATCH 3/7] gatomic-proper-pointer-get-cast.patch
5
6Upstream-Status: Unknown
7
8Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
9---
10 glib/gatomic.h | 2 +-
11 1 files changed, 1 insertions(+), 1 deletions(-)
12
13diff --git a/glib/gatomic.h b/glib/gatomic.h
14index ddd39b8..b758142 100644
15--- a/glib/gatomic.h
16+++ b/glib/gatomic.h
17@@ -70,7 +70,7 @@ void g_atomic_pointer_set (volatile gpointer G_GNUC_MAY_ALI
18 (g_atomic_int_set) ((volatile gint G_GNUC_MAY_ALIAS *) (volatile void *) (atomic), (newval)))
19 # define g_atomic_pointer_get(atomic) \
20 ((void) sizeof (gchar [sizeof (*(atomic)) == sizeof (gpointer) ? 1 : -1]), \
21- (g_atomic_pointer_get) ((volatile gpointer G_GNUC_MAY_ALIAS *) (volatile void *) (atomic)))
22+ (g_atomic_pointer_get) ((volatile gpointer G_GNUC_MAY_ALIAS *) (volatile void G_GNUC_MAY_ALIAS *) (atomic)))
23 # define g_atomic_pointer_set(atomic, newval) \
24 ((void) sizeof (gchar [sizeof (*(atomic)) == sizeof (gpointer) ? 1 : -1]), \
25 (g_atomic_pointer_set) ((volatile gpointer G_GNUC_MAY_ALIAS *) (volatile void *) (atomic), (newval)))
26--
271.6.6.1
28
diff --git a/meta-oe/recipes-core/glib-2.0/glib-2.0/0005-glib-mkenums-interpreter.patch.patch b/meta-oe/recipes-core/glib-2.0/glib-2.0/0005-glib-mkenums-interpreter.patch.patch
deleted file mode 100644
index 678033039..000000000
--- a/meta-oe/recipes-core/glib-2.0/glib-2.0/0005-glib-mkenums-interpreter.patch.patch
+++ /dev/null
@@ -1,25 +0,0 @@
1From a8e5c4a808e7f8572bd5023645a6cb4386b9aff8 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Sat, 18 Jun 2011 23:52:17 +0200
4Subject: [PATCH 5/7] don't leak buildpaths into perl hashbang
5
6Upstream-Status: Unknown
7
8Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
9---
10 gobject/glib-mkenums.in | 2 +-
11 1 files changed, 1 insertions(+), 1 deletions(-)
12
13diff --git a/gobject/glib-mkenums.in b/gobject/glib-mkenums.in
14index 6372245..b486fe9 100755
15--- a/gobject/glib-mkenums.in
16+++ b/gobject/glib-mkenums.in
17@@ -1,4 +1,4 @@
18-#! @PERL_PATH@
19+#! /usr/bin/env perl
20
21 use warnings;
22 use File::Basename;
23--
241.6.6.1
25
diff --git a/meta-oe/recipes-core/glib-2.0/glib-2.0/60_wait-longer-for-threads-to-die.patch b/meta-oe/recipes-core/glib-2.0/glib-2.0/60_wait-longer-for-threads-to-die.patch
deleted file mode 100644
index b65a47462..000000000
--- a/meta-oe/recipes-core/glib-2.0/glib-2.0/60_wait-longer-for-threads-to-die.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1copy from OE, said to borrow from Ubuntu. Not in glib-2.0 upstream yet. Add for sanity.
2Added to poky by Kevin Tian <kevin.tian@intel.com>, 06/25/2010
3Rebased for glib-2.27.3 by Dongxiao Xu <dongxiao.xu@intel.com>, 11/16/2010
4
5Upstream-Status: Inappropriate [patches for test code]
6
7diff -ruN glib-2.27.3-orig/tests/threadpool-test.c glib-2.27.3/tests/threadpool-test.c
8--- glib-2.27.3-orig/tests/threadpool-test.c 2009-04-01 07:04:21.000000000 +0800
9+++ glib-2.27.3/tests/threadpool-test.c 2010-11-16 12:28:09.002172678 +0800
10@@ -5,8 +5,8 @@
11
12 #include <glib.h>
13
14-#define DEBUG_MSG(x)
15-/* #define DEBUG_MSG(args) g_printerr args ; g_printerr ("\n"); */
16+/* #define DEBUG_MSG(x) */
17+#define DEBUG_MSG(args) g_printerr args ; g_printerr ("\n");
18
19 #define WAIT 5 /* seconds */
20 #define MAX_THREADS 10
21@@ -124,10 +124,10 @@
22 DEBUG_MSG (("[unused] stopping unused threads"));
23 g_thread_pool_stop_unused_threads ();
24
25- DEBUG_MSG (("[unused] waiting ONE second for threads to die"));
26+ DEBUG_MSG (("[unused] waiting FIVE second for threads to die"));
27
28 /* Some time for threads to die. */
29- g_usleep (G_USEC_PER_SEC);
30+ g_usleep (5 * G_USEC_PER_SEC);
31
32 DEBUG_MSG (("[unused] stopped idle threads, %d remain, %d threads still exist",
33 g_thread_pool_get_num_unused_threads (),
diff --git a/meta-oe/recipes-core/glib-2.0/glib-2.0/configure-libtool.patch b/meta-oe/recipes-core/glib-2.0/glib-2.0/configure-libtool.patch
deleted file mode 100644
index c21e37849..000000000
--- a/meta-oe/recipes-core/glib-2.0/glib-2.0/configure-libtool.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1# Poky renames libtool to $host_alias-libtool.
2# ./$host_alias-libtool isn't created until after configure runs with libtool >= 2.2.2
3# so we can't call # it at this point. We can safely assume a version is available
4# from PATH though
5# Rebased to glib-2.27.3 by Dongxiao Xu <dongxiao.xu@intel.com>
6
7Upstream-Status: Inappropriate [configuration]
8
9diff -ruN glib-2.27.3-orig/configure.ac glib-2.27.3/configure.ac
10--- glib-2.27.3-orig/configure.ac 2010-11-03 11:02:05.000000000 +0800
11+++ glib-2.27.3/configure.ac 2010-11-16 12:38:12.610485990 +0800
12@@ -1385,7 +1385,7 @@
13 G_MODULE_LDFLAGS=
14 else
15 export SED
16- G_MODULE_LDFLAGS=`(./libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
17+ G_MODULE_LDFLAGS=`(./$host_alias-libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`
18 fi
19 dnl G_MODULE_IMPL= don't reset, so cmd-line can override
20 G_MODULE_NEED_USCORE=0
21@@ -1450,7 +1450,7 @@
22 LDFLAGS="$LDFLAGS $G_MODULE_LDFLAGS"
23 dnl *** check for OSF1/5.0 RTLD_GLOBAL brokenness
24 echo "void glib_plugin_test(void) { }" > plugin.c
25- ${SHELL} ./libtool --mode=compile ${CC} -shared \
26+ ${SHELL} ./$host_alias-libtool --mode=compile ${CC} -shared \
27 -export-dynamic -o plugin.o plugin.c 2>&1 >/dev/null
28 AC_CACHE_CHECK([for RTLD_GLOBAL brokenness],
29 glib_cv_rtldglobal_broken,[
30@@ -1524,7 +1524,7 @@
31
32 AC_MSG_CHECKING(for the suffix of module shared libraries)
33 export SED
34-shrext_cmds=`./libtool --config | grep '^shrext_cmds='`
35+shrext_cmds=`./$host_alias-libtool --config | grep '^shrext_cmds='`
36 eval $shrext_cmds
37 module=yes eval std_shrext=$shrext_cmds
38 # chop the initial dot
diff --git a/meta-oe/recipes-core/glib-2.0/glib-2.0/g_once_init_enter.patch b/meta-oe/recipes-core/glib-2.0/glib-2.0/g_once_init_enter.patch
deleted file mode 100644
index 2eaa19b60..000000000
--- a/meta-oe/recipes-core/glib-2.0/glib-2.0/g_once_init_enter.patch
+++ /dev/null
@@ -1,24 +0,0 @@
1fix g_once_init_enter compile failure
2
3Kernelshark trips over a compile bug in glib-2.0 addressed by Open Embedded
4back in the 2.22 timeframe. It appears to still be present in 2.27.
5
6http://www.mail-archive.com/openembedded-devel@lists.openembedded.org/msg005
7
8Signed-off-by: Darren Hart <dvhart@linux.intel.com>
9
10Upstream-Status: Pending
11
12Index: glib-2.27.5/glib/gthread.h
13===================================================================
14--- glib-2.27.5.orig/glib/gthread.h
15+++ glib-2.27.5/glib/gthread.h
16@@ -344,7 +344,7 @@ void g_once_init_leav
17 G_INLINE_FUNC gboolean
18 g_once_init_enter (volatile gsize *value_location)
19 {
20- if G_LIKELY ((gpointer) g_atomic_pointer_get (value_location) != NULL)
21+ if G_LIKELY ((gpointer) g_atomic_pointer_get ((volatile gpointer *)value_location) != NULL)
22 return FALSE;
23 else
24 return g_once_init_enter_impl (value_location);
diff --git a/meta-oe/recipes-core/glib-2.0/glib-2.0/glib-gettextize-dir.patch b/meta-oe/recipes-core/glib-2.0/glib-2.0/glib-gettextize-dir.patch
deleted file mode 100644
index ee435111f..000000000
--- a/meta-oe/recipes-core/glib-2.0/glib-2.0/glib-gettextize-dir.patch
+++ /dev/null
@@ -1,24 +0,0 @@
1# an very old patch cherry-picked in every glib-2.0 patch directory. The earliest container
2# for it is 2.6.5 in OE. The earliest commit for it is c8e5702127e507e82e6f68a4b8c546803accea9d
3# in OE side which ports from previous bitkeeper SCM. In OE side it's only used til 2.12.4.
4#
5# keep it since it's always cleaner to not hardcode destination path. Use @datadir@ is more
6# portable here. mark for upstream
7#
8# by Kevin Tian <kevin.tian@intel.com>, 06/25/2010
9# Rebased by Dongxiao Xu <dongxiao.xu@intel.com>, 11/16/2010
10
11Upstream-Status: Inappropriate [configuration]
12
13diff -ruN glib-2.27.3-orig/glib-gettextize.in glib-2.27.3/glib-gettextize.in
14--- glib-2.27.3-orig/glib-gettextize.in 2009-04-01 07:04:20.000000000 +0800
15+++ glib-2.27.3/glib-gettextize.in 2010-11-16 12:55:06.874605916 +0800
16@@ -52,7 +52,7 @@
17 datadir=@datadir@
18 datarootdir=@datarootdir@
19
20-gettext_dir=$prefix/share/glib-2.0/gettext
21+gettext_dir=@datadir@/glib-2.0/gettext
22
23 while test $# -gt 0; do
24 case "$1" in
diff --git a/meta-oe/recipes-core/glib-2.0/glib-2.0/no-iconv.patch b/meta-oe/recipes-core/glib-2.0/glib-2.0/no-iconv.patch
deleted file mode 100644
index cca57d4f7..000000000
--- a/meta-oe/recipes-core/glib-2.0/glib-2.0/no-iconv.patch
+++ /dev/null
@@ -1,104 +0,0 @@
1We provide dummy implementation of iconv functionality if it does not find
2iconv which will be case with uclibc. We remove the check for iconv in configure
3
4This is needed when libintl and libiconv is not available. It wont have any
5impact on case when they are available.
6
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8
9
10Index: glib-2.26.1/glib/gconvert.c
11===================================================================
12--- glib-2.26.1.orig/glib/gconvert.c
13+++ glib-2.26.1/glib/gconvert.c
14@@ -23,7 +23,7 @@
15 #include "config.h"
16 #include "glibconfig.h"
17
18-#ifndef G_OS_WIN32
19+#if !defined G_OS_WIN32 && defined HAVE_ICONV_H
20 #include <iconv.h>
21 #endif
22 #include <errno.h>
23@@ -65,6 +65,28 @@
24 #error GNU libiconv not in use but included iconv.h is from libiconv
25 #endif
26
27+#ifndef HAVE_ICONV_H
28+typedef void *iconv_t;
29+
30+iconv_t iconv_open(const char *tocode, const char *fromcode)
31+{
32+ return (iconv_t)(-1);
33+}
34+
35+int iconv_close(iconv_t cd)
36+{
37+ free(cd);
38+
39+ return 0;
40+}
41+size_t iconv (iconv_t __cd, char **__inbuf,
42+ size_t *__inbytesleft,
43+ char **__outbuf,
44+ size_t *__outbytesleft)
45+{
46+ return 0;
47+}
48+#endif
49
50 /**
51 * SECTION:conversions
52Index: glib-2.26.1/configure.ac
53===================================================================
54--- glib-2.26.1.orig/configure.ac
55+++ glib-2.26.1/configure.ac
56@@ -373,46 +373,8 @@ dnl *** Tests for iconv ***
57 dnl ***********************
58 dnl
59 dnl We do this before the gettext checks, to avoid distortion
60-
61-dnl On Windows we use a native implementation
62-
63-if test x"$glib_native_win32" = xyes; then
64- with_libiconv=native
65-else
66- AC_ARG_WITH(libiconv,
67- [AC_HELP_STRING([--with-libiconv=@<:@no/gnu/native@:>@],
68- [use the libiconv library])],,
69- [with_libiconv=maybe])
70-
71- found_iconv=no
72- case $with_libiconv in
73- maybe)
74- # Check in the C library first
75- AC_CHECK_FUNC(iconv_open, [with_libiconv=no; found_iconv=yes])
76- # Check if we have GNU libiconv
77- if test $found_iconv = "no"; then
78- AC_CHECK_LIB(iconv, libiconv_open, [with_libiconv=gnu; found_iconv=yes])
79- fi
80- # Check if we have a iconv in -liconv, possibly from vendor
81- if test $found_iconv = "no"; then
82- AC_CHECK_LIB(iconv, iconv_open, [with_libiconv=native; found_iconv=yes])
83- fi
84- ;;
85- no)
86- AC_CHECK_FUNC(iconv_open, [with_libiconv=no; found_iconv=yes])
87- ;;
88- gnu|yes)
89- AC_CHECK_LIB(iconv, libiconv_open, [with_libiconv=gnu; found_iconv=yes])
90- ;;
91- native)
92- AC_CHECK_LIB(iconv, iconv_open, [with_libiconv=native; found_iconv=yes])
93- ;;
94- esac
95-
96- if test "x$found_iconv" = "xno" ; then
97- AC_MSG_ERROR([*** No iconv() implementation found in C library or libiconv])
98- fi
99-fi
100+found_iconv=yes
101+with_libiconv=no
102
103 gl_GLIBC21
104 AC_ARG_ENABLE(iconv-cache,
diff --git a/meta-oe/recipes-core/glib-2.0/glib-2.0/remove.test.for.qsort_r.patch b/meta-oe/recipes-core/glib-2.0/glib-2.0/remove.test.for.qsort_r.patch
deleted file mode 100644
index 3300eb024..000000000
--- a/meta-oe/recipes-core/glib-2.0/glib-2.0/remove.test.for.qsort_r.patch
+++ /dev/null
@@ -1,54 +0,0 @@
1while cross compiling we cannot execute run tests
2
3diff --git a/configure.ac b/configure.ac
4index 378b082..3f2a8d3 100644
5--- a/configure.ac
6+++ b/configure.ac
7@@ -580,46 +580,7 @@ AC_FUNC_VPRINTF
8 AC_FUNC_ALLOCA
9 AC_CHECK_FUNCS(mmap posix_memalign memalign valloc fsync pipe2)
10 AC_CHECK_FUNCS(atexit on_exit timegm gmtime_r)
11-# BSD has a qsort_r with wrong argument order
12-AC_CACHE_CHECK([for qsort_r], glib_cv_have_qsort_r, [
13-AC_RUN_IFELSE([AC_LANG_SOURCE([[
14-#define _GNU_SOURCE
15-#include <stdlib.h>
16-
17-static int
18-cmp (const void *a, const void *b, void *c)
19-{
20- const int *ia = a;
21- const int *ib = b;
22-
23- if (*ia < *ib)
24- return -1;
25- else if (*ia > *ib)
26- return 1;
27- else
28- return 0;
29-}
30-
31-int
32-main (int argc, char **argv)
33-{
34- int arr[3] = { 1, 2, 0 };
35- int d = 3;
36-
37- qsort_r (arr, 3, sizeof (int), cmp, &d);
38-
39- if (arr[0] == 0 && arr[1] == 1 && arr[2] == 2)
40- return 0;
41- else
42- return 1;
43-}]])],[glib_cv_have_qsort_r=yes],[glib_cv_have_qsort_r=no])])
44-
45-if test $glib_cv_have_qsort_r = yes ; then
46- AC_MSG_RESULT([yes])
47- AC_DEFINE(HAVE_QSORT_R, 1, [Define to 1 if you have the 'qsort_r' function])
48-else
49- AC_MSG_RESULT([no])
50-fi
51+AC_DEFINE(HAVE_QSORT_R, 1, [Define to 1 if you have the 'qsort_r' function])
52
53 AC_CHECK_SIZEOF(char)
54 AC_CHECK_SIZEOF(short)
diff --git a/meta-oe/recipes-core/glib-2.0/glib-2.0_git.bb b/meta-oe/recipes-core/glib-2.0/glib-2.0_git.bb
deleted file mode 100644
index 34fcaf6e7..000000000
--- a/meta-oe/recipes-core/glib-2.0/glib-2.0_git.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1require glib.inc
2
3PE = "1"
4PR = "r1"
5
6DEFAULT_PREFERENCE = "-1"
7
8DEPENDS += "libffi python-argparse-native"
9DEPENDS_virtclass-native += "libffi-native python-argparse-native"
10
11SRC_URI = "git://git.gnome.org/glib;protocol=git;branch=master \
12 file://configure-libtool.patch \
13 file://60_wait-longer-for-threads-to-die.patch \
14 file://g_once_init_enter.patch \
15 file://remove.test.for.qsort_r.patch \
16 "
17SRCREV = "d97cbc6731deab137770bc0fe9c69b06f689f5b4"
18PV = "2.29.3+gitr${SRCPV}"
19S = "${WORKDIR}/git"
20
21# Only apply this patch for target recipe on uclibc
22SRC_URI_append_libc-uclibc = " ${@['', 'file://no-iconv.patch']['${PN}' == '${BPN}']}"
23
24SRC_URI_append_virtclass-native = " file://glib-gettextize-dir.patch"
25BBCLASSEXTEND = "native"
26
27do_configure_prepend() {
28 # missing ${topdir}/gtk-doc.make and --disable-gtk-doc* is not enough, because it calls gtkdocize (not provided by gtk-doc-native)
29 sed -i '/^docs/d' ${S}/configure.ac
30 sed -i 's/SUBDIRS = . m4macros glib gmodule gthread gobject gio tests po docs/SUBDIRS = . m4macros glib gmodule gthread gobject gio tests po/g' ${S}/Makefile.am
31 sed -i -e "s:TEST_PROGS += gdbus-serialization::g" ${S}/gio/tests/Makefile.am
32}
diff --git a/meta-oe/recipes-core/glib-2.0/glib.inc b/meta-oe/recipes-core/glib-2.0/glib.inc
deleted file mode 100644
index 0800c85c4..000000000
--- a/meta-oe/recipes-core/glib-2.0/glib.inc
+++ /dev/null
@@ -1,38 +0,0 @@
1SUMMARY = "A general-purpose utility library"
2DESCRIPTION = "GLib is a general-purpose utility library, which provides many useful data types, macros, type conversions, string utilities, file utilities, a main loop abstraction, and so on."
3# pcre is under BSD;
4# docs/reference/COPYING is with a 'public domai'-like license!
5LICENSE = "LGPLv2+ & BSD & PD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
7 file://glib/glib.h;startline=4;endline=17;md5=a4332fe58b076f29d07c9c066d2967b6 \
8 file://gmodule/COPYING;md5=3bf50002aefd002f49e7bb854063f7e7 \
9 file://gmodule/gmodule.h;startline=4;endline=17;md5=76ab161b37202cd004073c42fac276ed \
10 file://glib/pcre/COPYING;md5=266ebc3ff74ee9ce6fad65577667c0f4 \
11 file://glib/pcre/pcre.h;startline=11;endline=35;md5=ce867cf87ebbd2bb55e980d90328390d \
12 file://docs/reference/COPYING;md5=f51a5100c17af6bae00735cd791e1fcc"
13BUGTRACKER = "http://bugzilla.gnome.org"
14SECTION = "libs"
15
16require glib-2.0.inc
17
18DEPENDS = "glib-2.0-native gtk-doc-native zip dbus"
19DEPENDS_virtclass-native = "gtk-doc-native pkgconfig-native gettext-native dbus-native"
20DEPENDS_virtclass-nativesdk = "libtool-nativesdk"
21PACKAGES =+ "${PN}-utils "
22
23LEAD_SONAME = "libglib-2.0.*"
24FILES_${PN}-utils = "${bindir}/*"
25
26inherit autotools pkgconfig gettext
27
28S = "${WORKDIR}/glib-${PV}"
29
30EXTRA_OECONF = "--disable-debug --enable-included-printf=no"
31EXTRA_OECONF_virtclass-native = ""
32EXTRA_OECONF_linuxstdbase = "--enable-included-printf=no"
33
34FILES_${PN} = "${libdir}/lib*${SOLIBS} ${sysconfdir}/bash_completion.d ${datadir}/glib-2.0/schemas"
35FILES_${PN}-dev += "${libdir}/glib-2.0/include"
36FILES_${PN}-dbg += "${datadir}/glib-2.0/gdb ${datadir}/gdb"
37
38ARM_INSTRUCTION_SET = "arm"