summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/dbus
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-06-28 07:33:52 -0700
committerKhem Raj <raj.khem@gmail.com>2018-06-28 08:09:32 -0700
commit3e2d529c34ebe02babb5daf95e31e587fdcb3d6f (patch)
tree2f9b09754b83eb330aa21db6b96b018f5938de74 /meta-oe/recipes-core/dbus
parentb6c0c92f6c2d8ccf4878722bc00ad535dc9bff31 (diff)
downloadmeta-openembedded-3e2d529c34ebe02babb5daf95e31e587fdcb3d6f.tar.gz
dbus-broker: Upgrade to latest and fix build on musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core/dbus')
-rw-r--r--meta-oe/recipes-core/dbus/dbus-broker/0001-Comment-rst2man-related-stuff.patch34
-rw-r--r--meta-oe/recipes-core/dbus/dbus-broker/0001-Include-sys-wait.h-for-WEXITED-definition.patch37
-rw-r--r--meta-oe/recipes-core/dbus/dbus-broker/0002-Correct-including-directory-for-conf.patch25
-rw-r--r--meta-oe/recipes-core/dbus/dbus-broker/0002-Use-getenv-instead-of-secure_getenv-on-musl.patch29
-rw-r--r--meta-oe/recipes-core/dbus/dbus-broker_git.bb13
5 files changed, 74 insertions, 64 deletions
diff --git a/meta-oe/recipes-core/dbus/dbus-broker/0001-Comment-rst2man-related-stuff.patch b/meta-oe/recipes-core/dbus/dbus-broker/0001-Comment-rst2man-related-stuff.patch
deleted file mode 100644
index f10c49e7c..000000000
--- a/meta-oe/recipes-core/dbus/dbus-broker/0001-Comment-rst2man-related-stuff.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From a92fd7da3a262e21c0970a3908eb0b4502819a01 Mon Sep 17 00:00:00 2001
2From: Yang Lyu <yangl@axis.com>
3Date: Fri, 23 Feb 2018 16:31:49 +0100
4Subject: [PATCH] Comment rst2man related stuff
5
6---
7 meson.build | 4 ++--
8 1 file changed, 2 insertions(+), 2 deletions(-)
9
10diff --git a/meson.build b/meson.build
11index 56d38e4..3c3b109 100644
12--- a/meson.build
13+++ b/meson.build
14@@ -15,7 +15,7 @@ add_project_arguments('-DBINDIR="' + join_paths(get_option('prefix'), get_option
15 cc = meson.get_compiler('c')
16 conf = configuration_data()
17 mod_pkgconfig = import('pkgconfig')
18-prog_rst2man = find_program('rst2man', 'rst2man.py')
19+#prog_rst2man = find_program('rst2man', 'rst2man.py')
20
21 sub_cdvar = subproject('c-dvar', version: '>=1')
22 sub_clist = subproject('c-list', version: '>=3')
23@@ -56,7 +56,7 @@ endif
24
25 conf.set('bindir', join_paths(get_option('prefix'), get_option('bindir')))
26
27-subdir('docs')
28+#subdir('docs')
29 subdir('src')
30
31 if use_launcher
32--
332.1.4
34
diff --git a/meta-oe/recipes-core/dbus/dbus-broker/0001-Include-sys-wait.h-for-WEXITED-definition.patch b/meta-oe/recipes-core/dbus/dbus-broker/0001-Include-sys-wait.h-for-WEXITED-definition.patch
new file mode 100644
index 000000000..8b8be074f
--- /dev/null
+++ b/meta-oe/recipes-core/dbus/dbus-broker/0001-Include-sys-wait.h-for-WEXITED-definition.patch
@@ -0,0 +1,37 @@
1From 99657fcbba288a843dc9e411bdfd3934b2074db5 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 28 Jun 2018 07:11:58 -0700
4Subject: [PATCH] Include sys/wait.h for WEXITED definition
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7---
8Upstream-Status: Submitted
9
10 src/launch/main.c | 1 +
11 test/dbus/util-broker.c | 1 +
12 2 files changed, 2 insertions(+)
13
14diff --git a/src/launch/main.c b/src/launch/main.c
15index f335d6b..6475ae6 100644
16--- a/src/launch/main.c
17+++ b/src/launch/main.c
18@@ -16,6 +16,7 @@
19 #include <sys/socket.h>
20 #include <sys/types.h>
21 #include <sys/un.h>
22+#include <sys/wait.h>
23 #include <systemd/sd-bus.h>
24 #include <systemd/sd-daemon.h>
25 #include <systemd/sd-event.h>
26diff --git a/test/dbus/util-broker.c b/test/dbus/util-broker.c
27index d9367ae..3bd021b 100644
28--- a/test/dbus/util-broker.c
29+++ b/test/dbus/util-broker.c
30@@ -11,6 +11,7 @@
31 #include <sys/socket.h>
32 #include <sys/types.h>
33 #include <sys/un.h>
34+#include <sys/wait.h>
35 #include <systemd/sd-bus.h>
36 #include <systemd/sd-event.h>
37 #include "dbus/protocol.h"
diff --git a/meta-oe/recipes-core/dbus/dbus-broker/0002-Correct-including-directory-for-conf.patch b/meta-oe/recipes-core/dbus/dbus-broker/0002-Correct-including-directory-for-conf.patch
deleted file mode 100644
index 4909dea12..000000000
--- a/meta-oe/recipes-core/dbus/dbus-broker/0002-Correct-including-directory-for-conf.patch
+++ /dev/null
@@ -1,25 +0,0 @@
1From 4b79f603b948709906c108796087de7b5643f61a Mon Sep 17 00:00:00 2001
2From: Yang Lyu <yangl@axis.com>
3Date: Mon, 26 Feb 2018 12:48:34 +0100
4Subject: [PATCH] Correct including directory for conf
5
6---
7 src/launch/config.c | 2 +-
8 1 file changed, 1 insertion(+), 1 deletion(-)
9
10diff --git a/src/launch/config.c b/src/launch/config.c
11index 6a68699..579471b 100644
12--- a/src/launch/config.c
13+++ b/src/launch/config.c
14@@ -1022,7 +1022,7 @@ static void config_parser_end_fn(void *userdata, const XML_Char *name) {
15 state->file,
16 state->current->include.selinux_root_relative ?
17 bus_selinux_policy_root() :
18- state->file->path,
19+ NULL,
20 state->current->cdata);
21 if (r) {
22 state->error = error_trace(r);
23--
242.1.4
25
diff --git a/meta-oe/recipes-core/dbus/dbus-broker/0002-Use-getenv-instead-of-secure_getenv-on-musl.patch b/meta-oe/recipes-core/dbus/dbus-broker/0002-Use-getenv-instead-of-secure_getenv-on-musl.patch
new file mode 100644
index 000000000..bebd2145f
--- /dev/null
+++ b/meta-oe/recipes-core/dbus/dbus-broker/0002-Use-getenv-instead-of-secure_getenv-on-musl.patch
@@ -0,0 +1,29 @@
1From 95a5541f8b75f7896ee6e5e71edd61838cab3c8b Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 28 Jun 2018 07:16:34 -0700
4Subject: [PATCH] Use getenv instead of secure_getenv on musl
5
6musl doesnt implement secure version
7
8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9---
10Upstream-Status: Pending
11
12 src/launch/main.c | 4 ++++
13 1 file changed, 4 insertions(+)
14
15diff --git a/src/launch/main.c b/src/launch/main.c
16index 6475ae6..6468d84 100644
17--- a/src/launch/main.c
18+++ b/src/launch/main.c
19@@ -30,6 +30,10 @@
20 #include "util/log.h"
21 #include "util/misc.h"
22
23+#ifndef __GLIBC__
24+#define secure_getenv getenv
25+#endif
26+
27 typedef struct Manager Manager;
28 typedef struct Service Service;
29
diff --git a/meta-oe/recipes-core/dbus/dbus-broker_git.bb b/meta-oe/recipes-core/dbus/dbus-broker_git.bb
index b62bccf2c..4a025cfeb 100644
--- a/meta-oe/recipes-core/dbus/dbus-broker_git.bb
+++ b/meta-oe/recipes-core/dbus/dbus-broker_git.bb
@@ -8,17 +8,20 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=7b486c2338d225a1405d979ed2c15ce8"
8 8
9DEPENDS = "dbus glib-2.0 expat" 9DEPENDS = "dbus glib-2.0 expat"
10 10
11PV = "9+git${SRCPV}" 11PV = "13+git${SRCPV}"
12SRCREV = "ccd06b284892182af569e69046262331150e3536" 12SRCREV = "1165025e26c3b46160402841dadf08d3d42f5cbb"
13 13
14SRC_URI = "git://github.com/bus1/dbus-broker;protocol=git" 14SRC_URI = "git://github.com/bus1/dbus-broker;protocol=git \
15SRC_URI += "file://0001-Comment-rst2man-related-stuff.patch" 15 file://0001-Include-sys-wait.h-for-WEXITED-definition.patch \
16SRC_URI += "file://0002-Correct-including-directory-for-conf.patch" 16 file://0002-Use-getenv-instead-of-secure_getenv-on-musl.patch \
17 "
17 18
18S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
19 20
20inherit meson pkgconfig systemd distro_features_check 21inherit meson pkgconfig systemd distro_features_check
21 22
23EXTRA_OEMESON += "-Ddocs=false"
24
22REQUIRED_DISTRO_FEATURES = "systemd" 25REQUIRED_DISTRO_FEATURES = "systemd"
23 26
24SYSTEMD_SERVICE_${PN} = "${BPN}.service" 27SYSTEMD_SERVICE_${PN} = "${BPN}.service"