summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/dbus
diff options
context:
space:
mode:
authorBernhard Guillon <Bernhard.Guillon@hale.at>2011-08-30 20:21:53 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-09-04 09:20:12 +0200
commit08513a79f6a54201b38a0c5ee6c086a7cff15dde (patch)
tree939d47acdb26b07e4c4c3b7b6652bfea54fbbdee /meta-oe/recipes-core/dbus
parent9a9bc6e47dbbab9f405299e4331f1f04f72a5697 (diff)
downloadmeta-openembedded-08513a79f6a54201b38a0c5ee6c086a7cff15dde.tar.gz
dbus-c++: use openembedded-core versions
Remove non working recipes because openembedded-core provides better ones. Signed-off-by: Bernhard Guillon <Bernhard.Guillon@hale.at> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-core/dbus')
-rw-r--r--meta-oe/recipes-core/dbus/dbus-c++-native_git.bb17
-rw-r--r--meta-oe/recipes-core/dbus/dbus-c++/fix-linking.patch13
-rw-r--r--meta-oe/recipes-core/dbus/dbus-c++_git.bb23
3 files changed, 0 insertions, 53 deletions
diff --git a/meta-oe/recipes-core/dbus/dbus-c++-native_git.bb b/meta-oe/recipes-core/dbus/dbus-c++-native_git.bb
deleted file mode 100644
index eba80b2e9..000000000
--- a/meta-oe/recipes-core/dbus/dbus-c++-native_git.bb
+++ /dev/null
@@ -1,17 +0,0 @@
1require dbus-c++_git.bb
2inherit native
3
4FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-c++"
5# actually dbus-native and expat-native, but even the bearest build machine should have that nowadays...
6DEPENDS = ""
7
8do_compile() {
9 oe_runmake -C src libdbus-c++-1.la
10 oe_runmake -C tools dbusxx-xml2cpp
11 install -m 0755 tools/dbusxx-xml2cpp ${STAGING_BINDIR_NATIVE}
12}
13
14do_install() {
15 :
16}
17
diff --git a/meta-oe/recipes-core/dbus/dbus-c++/fix-linking.patch b/meta-oe/recipes-core/dbus/dbus-c++/fix-linking.patch
deleted file mode 100644
index 822216916..000000000
--- a/meta-oe/recipes-core/dbus/dbus-c++/fix-linking.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1Index: dbus/tools/Makefile.am
2===================================================================
3--- dbus.orig/tools/Makefile.am
4+++ dbus/tools/Makefile.am
5@@ -16,7 +16,7 @@ endif
6 bin_PROGRAMS = dbusxx-xml2cpp dbusxx-introspect
7
8 dbusxx_xml2cpp_SOURCES = xml.h xml.cpp xml2cpp.h xml2cpp.cpp
9-dbusxx_xml2cpp_LDADD = $(libdbus_cxx_la)
10+dbusxx_xml2cpp_LDADD = $(libdbus_cxx_la) -lexpat
11
12 dbusxx_introspect_SOURCES = introspect.h introspect.cpp
13 dbusxx_introspect_LDADD = $(libdbus_cxx_la)
diff --git a/meta-oe/recipes-core/dbus/dbus-c++_git.bb b/meta-oe/recipes-core/dbus/dbus-c++_git.bb
deleted file mode 100644
index 64598238d..000000000
--- a/meta-oe/recipes-core/dbus/dbus-c++_git.bb
+++ /dev/null
@@ -1,23 +0,0 @@
1DESCRIPTION = "C++ bindings for dbus"
2LICENSE = "LGPLv2.1+"
3SECTION = "libs"
4DEPENDS = "dbus dbus-c++-native expat"
5SRCREV = "530a887913d3b0dd7091eabb8eef8e3c279e3bb8"
6
7PE = "1"
8PV = "0.5.0+gitr${SRCPV}"
9
10SRC_URI = "git://gitorious.org/dbus-cplusplus/mainline.git;protocol=git"
11# file://fix-linking.patch"
12S = "${WORKDIR}/git"
13
14inherit autotools pkgconfig
15
16do_compile_prepend() {
17 find . -name "Makefile.am" |xargs sed -i -e 's,$(top_builddir)/tools/dbusxx-xml2cpp,dbusxx-xml2cpp,'
18}
19
20FILES_${PN}-dbg += "${bindir}/dbusxx-xml2cpp ${bindir}/dbusxx-introspect"
21FILES_${PN}-dev += "${bindir}/.dev"
22FILES_${PN} = "${libdir}/*.so.*"
23