summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/dbus/dbus-broker_git.bb
diff options
context:
space:
mode:
authorYang Lyu <yang.lyu@axis.com>2018-03-21 12:40:54 +0100
committerArmin Kuster <akuster808@gmail.com>2018-04-13 12:40:56 -0700
commited70b4f91f5fd6776f120cd5c9f915a8b999adfd (patch)
tree3329907a23ec3d062b8743ca30215228339b1f2b /meta-oe/recipes-core/dbus/dbus-broker_git.bb
parentfa1913215275899b09c49c0bb5531f26909c5790 (diff)
downloadmeta-openembedded-ed70b4f91f5fd6776f120cd5c9f915a8b999adfd.tar.gz
dbus-broker: Add recipe
DBus-broker is a drop-in replacement for dbus-daemon. It is an implementation of a message bus as defined by the D-Bus specification. Its aim is to provide high performance and reliability, while keeping compatibility to the D-Bus reference implementation. 0001-Comment-rst2man-related-stuff.patch avoids using rst2man. 0002-Correct-including-directory-for-conf.patch fixs path computation for <include> node. The patch should be dropped when a newer version of dbus-broker that includes commit: https://github.com/bus1/dbus-broker/commit/9af79016f0f6b1ee60779bc6dc4acd7b4b9e6c70 is available. Signed-off-by: Yang Lyu <yang.lyu@axis.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-core/dbus/dbus-broker_git.bb')
-rw-r--r--meta-oe/recipes-core/dbus/dbus-broker_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/dbus/dbus-broker_git.bb b/meta-oe/recipes-core/dbus/dbus-broker_git.bb
new file mode 100644
index 000000000..51dfe8c0a
--- /dev/null
+++ b/meta-oe/recipes-core/dbus/dbus-broker_git.bb
@@ -0,0 +1,29 @@
1SUMMARY = "dbus broker"
2DESCRIPTION = "Drop-in replacement for dbus-daemon."
3
4SECTION = "base"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=7b486c2338d225a1405d979ed2c15ce8"
8
9DEPENDS = "dbus glib-2.0 expat systemd"
10
11PV = "9+git${SRCPV}"
12SRCREV = "ccd06b284892182af569e69046262331150e3536"
13
14SRC_URI = "git://github.com/bus1/dbus-broker;protocol=git"
15SRC_URI += "file://0001-Comment-rst2man-related-stuff.patch"
16SRC_URI += "file://0002-Correct-including-directory-for-conf.patch"
17
18S = "${WORKDIR}/git"
19
20inherit meson pkgconfig systemd
21
22SYSTEMD_SERVICE_${PN} = "${BPN}.service"
23
24FILES_${PN} += "${systemd_system_unitdir}"
25FILES_${PN} += "${systemd_user_unitdir}"
26
27RDEPENDS_${PN} = "dbus systemd"
28
29BBCLASSEXTEND = "native"