summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-11-22 14:19:55 +0800
committerKhem Raj <raj.khem@gmail.com>2023-11-21 22:35:50 -0800
commitbc1674784b4a957bd47cca32ecd63129c330c123 (patch)
tree66eb261d4c896903651fe30992592d793846c350 /meta-oe/recipes-connectivity
parentfdb279bc33c1dff36678bc822da22666a4c9ab18 (diff)
downloadmeta-openembedded-bc1674784b4a957bd47cca32ecd63129c330c123.tar.gz
libwebsockets: upgrade 4.3.2 -> 4.3.3
0001-Fix-Werror-enum-int-mismatch-in-lws_tls_server_abort.patch removed since it's included in 4.3.3 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/libwebsockets/libwebsockets/0001-Fix-Werror-enum-int-mismatch-in-lws_tls_server_abort.patch32
-rw-r--r--meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.3.bb (renamed from meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.2.bb)5
2 files changed, 2 insertions, 35 deletions
diff --git a/meta-oe/recipes-connectivity/libwebsockets/libwebsockets/0001-Fix-Werror-enum-int-mismatch-in-lws_tls_server_abort.patch b/meta-oe/recipes-connectivity/libwebsockets/libwebsockets/0001-Fix-Werror-enum-int-mismatch-in-lws_tls_server_abort.patch
deleted file mode 100644
index 41d004d9f..000000000
--- a/meta-oe/recipes-connectivity/libwebsockets/libwebsockets/0001-Fix-Werror-enum-int-mismatch-in-lws_tls_server_abort.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From 722e44cb5b74cae206f47a6dc0d985eba8ed1b2e Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 26 Jan 2023 17:17:49 -0800
4Subject: [PATCH] Fix -Werror=enum-int-mismatch in
5 lws_tls_server_abort_connection()
6
7GCC 13 is findinf this function signature mismatch.
8
9../git/lib/tls/openssl/openssl-server.c:713:1: error: conflicting types for 'lws_tls_server_abort_connection' due to enum/integer mismatch; have 'int(struct lws *)' [-Werror=enum-int-mismatch]
10
11Upstream-Status: Submitted [https://github.com/warmcat/libwebsockets/pull/2824]
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 lib/tls/openssl/openssl-server.c | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/lib/tls/openssl/openssl-server.c b/lib/tls/openssl/openssl-server.c
18index f2e77324f..43d65e030 100644
19--- a/lib/tls/openssl/openssl-server.c
20+++ b/lib/tls/openssl/openssl-server.c
21@@ -699,7 +699,7 @@ lws_tls_server_new_nonblocking(struct lws *wsi, lws_sockfd_type accept_fd)
22 return 0;
23 }
24
25-int
26+enum lws_ssl_capable_status
27 lws_tls_server_abort_connection(struct lws *wsi)
28 {
29 if (wsi->tls.use_ssl)
30--
312.39.1
32
diff --git a/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.2.bb b/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.3.bb
index 95c2854fa..4518e2faa 100644
--- a/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.2.bb
+++ b/meta-oe/recipes-connectivity/libwebsockets/libwebsockets_4.3.3.bb
@@ -7,9 +7,8 @@ DEPENDS = "zlib"
7DEPENDS:append:class-native = " libcap-native" 7DEPENDS:append:class-native = " libcap-native"
8 8
9S = "${WORKDIR}/git" 9S = "${WORKDIR}/git"
10SRCREV = "b0a749c8e7a8294b68581ce4feac0e55045eb00b" 10SRCREV = "4415e84c095857629863804e941b9e1c2e9347ef"
11SRC_URI = "git://github.com/warmcat/libwebsockets.git;protocol=https;branch=v4.3-stable \ 11SRC_URI = "git://github.com/warmcat/libwebsockets.git;protocol=https;branch=v4.3-stable"
12 file://0001-Fix-Werror-enum-int-mismatch-in-lws_tls_server_abort.patch"
13 12
14UPSTREAM_CHECK_URI = "https://github.com/warmcat/${BPN}/releases" 13UPSTREAM_CHECK_URI = "https://github.com/warmcat/${BPN}/releases"
15UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" 14UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"