summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-11-07 14:33:49 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-07 17:22:19 +0100
commit9292db41f1e1707e0c6864cedf95ce4d7b366e83 (patch)
treea3aa6a0dc9cb32e369bd4b95fc956e2a280c71b0 /meta-oe/recipes-connectivity
parenta94753610158a368216407a1a21039fe0c21bcc6 (diff)
downloadmeta-openembedded-9292db41f1e1707e0c6864cedf95ce4d7b366e83.tar.gz
dhcp: add system support to dhcp-server
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/dhcp/dhcp_4.2.0.bbappend19
-rw-r--r--meta-oe/recipes-connectivity/dhcp/files/dhcpd.service12
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/dhcp/dhcp_4.2.0.bbappend b/meta-oe/recipes-connectivity/dhcp/dhcp_4.2.0.bbappend
new file mode 100644
index 000000000..d47f1ce57
--- /dev/null
+++ b/meta-oe/recipes-connectivity/dhcp/dhcp_4.2.0.bbappend
@@ -0,0 +1,19 @@
1# look for files in the layer first
2FILESEXTRAPATHS := "${THISDIR}/files"
3
4inherit systemd
5
6SYSTEMD_PACKAGES = "dhcp-server-systemd"
7SYSTEMD_SERVICE_dhcp-server-systemd = "dhcpd.service"
8
9SRC_URI += "file://dhcpd.service"
10
11do_install_append() {
12 install -d ${D}${base_libdir}/systemd/system
13 install -m 644 ${WORKDIR}/dhcpd.service ${D}${base_libdir}/systemd/system
14}
15
16PACKAGES =+ "dhcp-server-systemd"
17
18FILES_dhcp-server-systemd += "${base_libdir}/systemd"
19RDEPENDS_dhcp-server-systemd += "dhcp-server"
diff --git a/meta-oe/recipes-connectivity/dhcp/files/dhcpd.service b/meta-oe/recipes-connectivity/dhcp/files/dhcpd.service
new file mode 100644
index 000000000..70beee92e
--- /dev/null
+++ b/meta-oe/recipes-connectivity/dhcp/files/dhcpd.service
@@ -0,0 +1,12 @@
1[Unit]
2Description=Dynamic Host Configuration Protocol (DHCP)
3After=syslog.target network.target
4
5[Service]
6Type=forking
7PIDFile=/var/run/dhcpd.pid
8EnvironmentFile=-/etc/default/dhcp-server
9ExecStart=/usr/sbin/dhcpd -cf /etc/dhcp/dhcpd.conf -q $INTERFACES
10
11[Install]
12WantedBy=multi-user.target