summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2017-09-05 14:46:48 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-13 11:08:46 +0200
commit836766e5cf5b0af2a63415d18449a0966816aedb (patch)
tree55bae14c217b28ddd9f4a3198f14555907b0f396 /meta-oe/recipes-connectivity
parent5e406e208cfbdc5818387378afbb3c612709b258 (diff)
downloadmeta-openembedded-836766e5cf5b0af2a63415d18449a0966816aedb.tar.gz
telepathy-python: Move to meta-python, requires python-dbus
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/parallel_make.patch43
-rw-r--r--meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/remove_duplicate_install.patch26
-rw-r--r--meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/telepathy-python_fix_for_automake_1.12.patch26
-rw-r--r--meta-oe/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb32
4 files changed, 0 insertions, 127 deletions
diff --git a/meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/parallel_make.patch b/meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/parallel_make.patch
deleted file mode 100644
index 248824606..000000000
--- a/meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/parallel_make.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1Add dependency of __init__.py
2
3Tasks must be done after exec of __init__, which creates the
4src/_generated directory that tasks are based on.
5
6Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
7
8Upstream-Status: Submitted
9(However it seems that this project is out of maintanence.)
10
11diff -ruN telepathy-python-0.15.19-orig/src/Makefile.am telepathy-python-0.15.19/src/Makefile.am
12--- telepathy-python-0.15.19-orig/src/Makefile.am 2011-03-10 08:51:49.000000000 +0800
13+++ telepathy-python-0.15.19/src/Makefile.am 2011-03-10 08:54:45.000000000 +0800
14@@ -39,17 +39,17 @@
15 XSLTPROC_OPTS = --nonet --novalid --xinclude
16 tools_dir = $(top_srcdir)/tools
17
18-_generated/interfaces.py: $(tools_dir)/python-interfaces-generator.xsl $(wildcard $(spec_dir)/*.xml)
19+_generated/interfaces.py: _generated/__init__.py $(tools_dir)/python-interfaces-generator.xsl $(wildcard $(spec_dir)/*.xml)
20 $(AM_V_GEN)$(XSLTPROC) $(XSLTPROC_OPTS) -o $@ \
21 $(tools_dir)/python-interfaces-generator.xsl \
22 $(spec_dir)/all.xml
23
24-_generated/constants.py: $(tools_dir)/python-constants-generator.xsl $(wildcard $(spec_dir)/*.xml)
25+_generated/constants.py: _generated/__init__.py $(tools_dir)/python-constants-generator.xsl $(wildcard $(spec_dir)/*.xml)
26 $(AM_V_GEN)$(XSLTPROC) $(XSLTPROC_OPTS) -o $@ \
27 $(tools_dir)/python-constants-generator.xsl \
28 $(spec_dir)/all.xml
29
30-_generated/errors.py: $(tools_dir)/python-errors-generator.xsl $(wildcard $(spec_dir)/*.xml)
31+_generated/errors.py: _generated/__init__.py $(tools_dir)/python-errors-generator.xsl $(wildcard $(spec_dir)/*.xml)
32 $(AM_V_GEN)$(XSLTPROC) $(XSLTPROC_OPTS) -o $@ \
33 $(tools_dir)/python-errors-generator.xsl \
34 $(spec_dir)/all.xml
35@@ -58,7 +58,7 @@
36 $(AM_V_GEN)$(mkdir_p) $(dir $@)
37 @echo "# Placeholder for package" > $@
38
39-_generated/%.py: $(tools_dir)/spec-to-python.xsl $(spec_dir)/%.xml
40+_generated/%.py: _generated/__init__.py $(tools_dir)/spec-to-python.xsl $(spec_dir)/%.xml
41 $(AM_V_GEN)$(XSLTPROC) $(XSLTPROC_OPTS) -o $@ \
42 $(tools_dir)/spec-to-python.xsl \
43 $(spec_dir)/$*.xml
diff --git a/meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/remove_duplicate_install.patch b/meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/remove_duplicate_install.patch
deleted file mode 100644
index df95a4c13..000000000
--- a/meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/remove_duplicate_install.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1commit f6c67662145de889055a86a6b3b12c70a45fc8d5
2Author: Dongxiao Xu <dongxiao.xu@intel.com>
3Date: Wed Sep 7 16:02:20 2011 +0800
4
5 Avoid duplicated installation of errors.py
6
7 newer version of autotools don't seem to like listing files to install
8 twice. Remove one errors.py from the installation list.
9
10 Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
11
12 Upstream-Status: Inappropirate [upstream inactive]
13
14diff --git a/src/Makefile.am b/src/Makefile.am
15index 5c27dfe..7536e43 100644
16--- a/src/Makefile.am
17+++ b/src/Makefile.am
18@@ -11,7 +11,7 @@ telepathy_PYTHON = \
19
20 # telepathy._generated.* auto-generated modules
21 spec_dir = $(top_srcdir)/spec
22-spec_files := $(patsubst $(spec_dir)%.xml,_generated%.py,$(wildcard $(spec_dir)/*.xml))
23+spec_files := $(filter-out _generated/errors.py, $(patsubst $(spec_dir)%.xml,_generated%.py,$(wildcard $(spec_dir)/*.xml)))
24
25 BUILT_SOURCES = \
26 _generated/interfaces.py \
diff --git a/meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/telepathy-python_fix_for_automake_1.12.patch b/meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/telepathy-python_fix_for_automake_1.12.patch
deleted file mode 100644
index f613fdce4..000000000
--- a/meta-oe/recipes-connectivity/telepathy/telepathy-python-0.15.19/telepathy-python_fix_for_automake_1.12.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1Upstream-Status: Pending
2
3automake 1.12 has deprecated use of mkdir_p, and it recommends
4use of MKDIR_P instead. Changed the code to avoid these kind
5of warning-errors.
6
7| make[1]: _generated/: Command not found
8| make[1]: *** [_generated/__init__.py] Error 127
9| make[1]: Leaving directory `/srv/home/nitin/builds2/build0/tmp/work/i586-poky-linux/telepathy-python-0.15.19-r4/telepathy-python-0.15.19/src'
10| make: *** [all-recursive] Error 1
11
12Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
132012/07/10
14Index: telepathy-python-0.15.19/src/Makefile.am
15===================================================================
16--- telepathy-python-0.15.19.orig/src/Makefile.am
17+++ telepathy-python-0.15.19/src/Makefile.am
18@@ -55,7 +55,7 @@ _generated/errors.py: _generated/__init_
19 $(spec_dir)/all.xml
20
21 _generated/__init__.py:
22- $(AM_V_GEN)$(mkdir_p) $(dir $@)
23+ $(AM_V_GEN)$(MKDIR_P) $(dir $@)
24 @echo "# Placeholder for package" > $@
25
26 _generated/%.py: _generated/__init__.py $(tools_dir)/spec-to-python.xsl $(spec_dir)/%.xml
diff --git a/meta-oe/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb b/meta-oe/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb
deleted file mode 100644
index b7aea24a7..000000000
--- a/meta-oe/recipes-connectivity/telepathy/telepathy-python_0.15.19.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1SUMMARY = "Telepathy IM framework - Python package"
2HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
3LICENSE = "LGPLv2.1+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1 \
5 file://src/utils.py;beginline=1;endline=17;md5=9a07d1a9791a7429a14e7b25c6c86822"
6
7DEPENDS = "libxslt-native"
8RDEPENDS_${PN} += "python-dbus"
9
10SRC_URI = "http://telepathy.freedesktop.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
11 file://parallel_make.patch \
12 file://remove_duplicate_install.patch \
13 file://telepathy-python_fix_for_automake_1.12.patch"
14
15PR = "r6"
16
17inherit autotools pythonnative
18
19SRC_URI[md5sum] = "f7ca25ab3c88874015b7e9728f7f3017"
20SRC_URI[sha256sum] = "244c0e1bf4bbd78ae298ea659fe10bf3a73738db550156767cc2477aedf72376"
21
22FILES_${PN} += "\
23 ${libdir}/python*/site-packages/telepathy/*.py \
24 ${libdir}/python*/site-packages/telepathy/*/*.py \
25"
26
27do_install_append () {
28 rm -f ${D}${libdir}/python*/site-packages/telepathy/*.pyc
29 rm -f ${D}${libdir}/python*/site-packages/telepathy/*.pyo
30 rm -f ${D}${libdir}/python*/site-packages/telepathy/*/*.pyc
31 rm -f ${D}${libdir}/python*/site-packages/telepathy/*/*.pyo
32}