summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity
diff options
context:
space:
mode:
authorBian Naimeng <biannm@cn.fujitsu.com>2015-06-25 13:12:56 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-07-16 21:09:11 +0200
commit7169f1631af6b9b3302e5f3906688cec63bae93d (patch)
treed03947308a0082c826739e7b70d0fe724b9a1683 /meta-oe/recipes-connectivity
parentb9a8410d15eb55aebe9be9ae2e89ded4d3771b51 (diff)
downloadmeta-openembedded-7169f1631af6b9b3302e5f3906688cec63bae93d.tar.gz
zabbix: add new recipe
zabbix is an open-source monitoring solution for your IT infrastructure. Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r--meta-oe/recipes-connectivity/zabbix/zabbix/0001-Fix-configure.ac.patch23
-rw-r--r--meta-oe/recipes-connectivity/zabbix/zabbix/zabbix-agent.service12
-rw-r--r--meta-oe/recipes-connectivity/zabbix/zabbix_2.4.5.bb70
3 files changed, 105 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/zabbix/zabbix/0001-Fix-configure.ac.patch b/meta-oe/recipes-connectivity/zabbix/zabbix/0001-Fix-configure.ac.patch
new file mode 100644
index 000000000..af14a1a56
--- /dev/null
+++ b/meta-oe/recipes-connectivity/zabbix/zabbix/0001-Fix-configure.ac.patch
@@ -0,0 +1,23 @@
1uname can not get version of kernel correctly while cross compile
2
3Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com>
4---
5 configure.ac | 2 +-
6 1 file changed, 1 insertion(+), 1 deletion(-)
7
8diff --git a/configure.ac b/configure.ac
9index 523899b..4e6ae0d 100644
10--- a/configure.ac
11+++ b/configure.ac
12@@ -924,7 +924,7 @@ AC_MSG_RESULT([$ARCH ($host_os)])
13 if test "x$ARCH" = "xlinux"; then
14 AC_MSG_CHECKING([for the linux kernel version])
15
16- kernel=`uname -r`
17+ kernel="${KERNEL_VERSION}"
18
19 case "${kernel}" in
20 2.6.*)
21--
221.8.3.1
23
diff --git a/meta-oe/recipes-connectivity/zabbix/zabbix/zabbix-agent.service b/meta-oe/recipes-connectivity/zabbix/zabbix/zabbix-agent.service
new file mode 100644
index 000000000..b18a96f8b
--- /dev/null
+++ b/meta-oe/recipes-connectivity/zabbix/zabbix/zabbix-agent.service
@@ -0,0 +1,12 @@
1[Unit]
2Description=Zabbix Monitor Agent
3After=syslog.target network.target
4
5[Service]
6Type=oneshot
7ExecStart=@SBINDIR@/zabbix_agentd
8RemainAfterExit=yes
9User=zabbix
10
11[Install]
12WantedBy=multi-user.target
diff --git a/meta-oe/recipes-connectivity/zabbix/zabbix_2.4.5.bb b/meta-oe/recipes-connectivity/zabbix/zabbix_2.4.5.bb
new file mode 100644
index 000000000..35c7d64a0
--- /dev/null
+++ b/meta-oe/recipes-connectivity/zabbix/zabbix_2.4.5.bb
@@ -0,0 +1,70 @@
1SUMMARY = "Open-source monitoring solution for your IT infrastructure"
2DESCRIPTION = "\
3ZABBIX is software that monitors numerous parameters of a network and the \
4health and integrity of servers. ZABBIX uses a flexible notification \
5mechanism that allows users to configure e-mail based alerts for virtually \
6any event. This allows a fast reaction to server problems. ZABBIX offers \
7excellent reporting and data visualisation features based on the stored \
8data. This makes ZABBIX ideal for capacity planning. \
9\
10ZABBIX supports both polling and trapping. All ZABBIX reports and \
11statistics, as well as configuration parameters are accessed through a \
12web-based front end. A web-based front end ensures that the status of \
13your network and the health of your servers can be assessed from any \
14location. Properly configured, ZABBIX can play an important role in \
15monitoring IT infrastructure. This is equally true for small \
16organisations with a few servers and for large companies with a \
17multitude of servers."
18HOMEPAGE = "http://www.zabbix.com/"
19SECTION = "Applications/Internet"
20LICENSE = "GPLv2+"
21LIC_FILES_CHKSUM = "file://COPYING;md5=300e938ad303147fede2294ed78fe02e"
22DEPENDS = "openldap virtual/libiconv"
23
24SRC_URI = "http://jaist.dl.sourceforge.net/project/zabbix/ZABBIX%20Latest%20Stable/${PV}/${BPN}-${PV}.tar.gz \
25 file://0001-Fix-configure.ac.patch \
26 file://zabbix-agent.service"
27
28SRC_URI[md5sum] = "a82eb0d55d3ca947e10a4a55238f4388"
29SRC_URI[sha256sum] = "4e2cf1e4893a45d83379a05e2debabddf16beab324c93e84adc0bb57716fb957"
30
31inherit autotools-brokensep linux-kernel-base pkgconfig systemd useradd
32
33SYSTEMD_PACKAGES = "${PN}"
34SYSTEMD_SERVICE_${PN} = "zabbix-agent.service"
35SYSTEMD_AUTO_ENABLE = "enable"
36
37USERADD_PACKAGES = "${PN}"
38GROUPADD_PARAM_${PN} = "-r zabbix"
39USERADD_PARAM_${PN} = "-r -g zabbix -d /var/lib/zabbix \
40 -s /sbin/nologin -c \"Zabbix Monitoring System\" zabbix"
41
42KERNEL_VERSION = "${@get_kernelversion_headers('${STAGING_KERNEL_DIR}')}"
43
44EXTRA_OECONF = '--enable-dependency-tracking \
45 --enable-agent \
46 --enable-ipv6 \
47 --with-net-snmp \
48 --with-ldap=${STAGING_EXECPREFIXDIR} \
49 --with-jabber \
50 --with-unixodbc \
51 --with-ssh2 \
52 --with-sqlite3 \
53 '
54CFLAGS_append += "-lldap -llber"
55
56do_configure_prepend() {
57 export KERNEL_VERSION="${KERNEL_VERSION}"
58}
59
60do_install_append() {
61 if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then
62 install -d ${D}${systemd_unitdir}/system
63 install -m 0644 ${WORKDIR}/zabbix-agent.service ${D}${systemd_unitdir}/system/
64 sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/zabbix-agent.service
65 fi
66}
67
68FILES_${PN} += "${libdir}"
69
70RDEPENDS_${PN} = "logrotate"