diff options
author | Pascal Bach <pascal.bach@siemens.com> | 2017-04-27 14:30:41 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-05-04 09:18:33 +0200 |
commit | 17f6775a14fa1b6831c79708bed51991e9c13b0d (patch) | |
tree | fa7a7c58d69256af5afdc252647f795aa5ee338a /meta-oe/recipes-connectivity | |
parent | 3927abca048ef8e7d6979b5b359968d78ccbecb1 (diff) | |
download | meta-openembedded-17f6775a14fa1b6831c79708bed51991e9c13b0d.tar.gz |
thrift: refactor recipe
- use release tarball instead of git
- move libevent, python and glib into PACKAGECONFIG
- add NOTICE file to copyright check
- split into multiple packages
- libthrift for libaries
- thrift-compiler for compiler
- thrift pulls in everything as before
Signed-off-by: Pascal Bach <pascal.bach@siemens.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity')
-rw-r--r-- | meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb | 47 |
1 files changed, 40 insertions, 7 deletions
diff --git a/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb b/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb index 905e5618d5..9baeed1692 100644 --- a/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb +++ b/meta-oe/recipes-connectivity/thrift/thrift_0.9.3.bb | |||
@@ -3,18 +3,19 @@ DESCRIPTION = "A software framework, for scalable cross-language services devel | |||
3 | HOMEPAGE = "https://thrift.apache.org/" | 3 | HOMEPAGE = "https://thrift.apache.org/" |
4 | 4 | ||
5 | LICENSE = "Apache-2.0" | 5 | LICENSE = "Apache-2.0" |
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e4ed21f679b2aafef26eac82ab0c2cbf" | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e4ed21f679b2aafef26eac82ab0c2cbf \ |
7 | file://NOTICE;md5=115f49498b66b494b0472658f2bfe80b" | ||
7 | 8 | ||
8 | DEPENDS = "thrift-native boost python libevent flex-native bison-native \ | 9 | DEPENDS = "thrift-native boost flex-native bison-native openssl" |
9 | glib-2.0 openssl" | ||
10 | 10 | ||
11 | SRC_URI = "git://git-wip-us.apache.org/repos/asf/thrift.git;protocol=https \ | 11 | SRC_URI = "http://mirror.switch.ch/mirror/apache/dist/thrift/${PV}/${BPN}-${PV}.tar.gz \ |
12 | file://0001-Forcibly-disable-check-for-Qt5.patch \ | 12 | file://0001-Forcibly-disable-check-for-Qt5.patch \ |
13 | file://0001-THRIFT-3828-In-cmake-avoid-use-of-both-quoted-paths-.patch \ | 13 | file://0001-THRIFT-3828-In-cmake-avoid-use-of-both-quoted-paths-.patch \ |
14 | file://0002-THRIFT-3831-in-test-cpp-explicitly-use-signed-char.patch \ | 14 | file://0002-THRIFT-3831-in-test-cpp-explicitly-use-signed-char.patch \ |
15 | " | 15 | " |
16 | SRCREV = "61b8a29b0704ccd81b520f2300f5d1bb261fea3e" | 16 | |
17 | S = "${WORKDIR}/git" | 17 | SRC_URI[md5sum] = "88d667a8ae870d5adeca8cb7d6795442" |
18 | SRC_URI[sha256sum] = "b0740a070ac09adde04d43e852ce4c320564a292f26521c46b78e0641564969e" | ||
18 | 19 | ||
19 | BBCLASSEXTEND = "native nativesdk" | 20 | BBCLASSEXTEND = "native nativesdk" |
20 | 21 | ||
@@ -25,12 +26,44 @@ export STAGING_LIBDIR | |||
25 | export BUILD_SYS | 26 | export BUILD_SYS |
26 | export HOST_SYS | 27 | export HOST_SYS |
27 | 28 | ||
28 | EXTRA_OECMAKE = "-DWITH_QT4=OFF -DWITH_QT5=OFF -DBUILD_JAVA=OFF" | 29 | EXTRA_OECMAKE = " \ |
30 | -DBUILD_LIBRARIES=ON \ | ||
31 | -DBUILD_COMPILER=ON \ | ||
32 | -DBUILD_TESTING=OFF \ | ||
33 | -DBUILD_EXAMPLES=OFF \ | ||
34 | -DBUILD_TUTORIALS=OFF \ | ||
35 | -DWITH_CPP=ON \ | ||
36 | -DWITH_JAVA=OFF \ | ||
37 | -DWITH_STATIC_LIB=ON \ | ||
38 | -DWITH_SHARED_LIB=ON \ | ||
39 | -DWITH_OPENSSL=ON \ | ||
40 | -DWITH_QT4=OFF \ | ||
41 | -DWITH_QT5=OFF \ | ||
42 | " | ||
43 | |||
29 | EXTRA_OECMAKE_append_class-native = "\ | 44 | EXTRA_OECMAKE_append_class-native = "\ |
30 | -DBUILD_TESTING=OFF -DBUILD_EXAMPLES=OFF -DWITH_CPP=OFF" | 45 | -DBUILD_TESTING=OFF -DBUILD_EXAMPLES=OFF -DWITH_CPP=OFF" |
31 | EXTRA_OECMAKE_append_class-nativesdk = "\ | 46 | EXTRA_OECMAKE_append_class-nativesdk = "\ |
32 | -DBUILD_TESTING=OFF -DBUILD_EXAMPLES=OFF -DWITH_PYTHON=OFF" | 47 | -DBUILD_TESTING=OFF -DBUILD_EXAMPLES=OFF -DWITH_PYTHON=OFF" |
33 | 48 | ||
49 | PACKAGECONFIG ??= "libevent glib python" | ||
50 | PACKAGECONFIG[libevent] = "-DWITH_LIBEVENT=ON,-DWITH_LIBEVENT=OFF,libevent," | ||
51 | PACKAGECONFIG[python] = "-DWITH_PYTHON=ON,-DWITH_PYTHON=OFF,python," | ||
52 | PACKAGECONFIG[glib] = "-DWITH_C_GLIB=ON,-DWITH_C_GLIB=OFF,glib-2.0 ," | ||
53 | |||
34 | do_install_append () { | 54 | do_install_append () { |
35 | ln -sf thrift ${D}/${bindir}/thrift-compiler | 55 | ln -sf thrift ${D}/${bindir}/thrift-compiler |
36 | } | 56 | } |
57 | |||
58 | LEAD_SONAME = "libthrift.so.${PV}" | ||
59 | |||
60 | # thrift packages | ||
61 | PACKAGE_BEFORE_PN = "${PN}-compiler lib${BPN}" | ||
62 | FILES_lib${BPN} = "${libdir}/*.so.*" | ||
63 | FILES_${PN}-compiler = "${bindir}/*" | ||
64 | |||
65 | # The thrift packages just pulls in some default dependencies but is otherwise empty | ||
66 | RRECOMMENDS_${PN} = "${PN}-compiler lib${BPN}" | ||
67 | ALLOW_EMPTY_${PN} = "1" | ||
68 | RRECOMMENDS_${PN}_class-native = "" | ||
69 | RRECOMMENDS_${PN}_class-nativesdk = "" | ||