summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/zabbix/zabbix_4.4.5.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-02-11 09:21:33 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-11 16:46:31 -0800
commitc13246e4631288966ddffc02eae49e66d5eccb31 (patch)
tree5145cb5bfb8be1473d2163832ac9be0ad54f4755 /meta-oe/recipes-connectivity/zabbix/zabbix_4.4.5.bb
parentd671941f3fbecc8d07e9ab66ea12802a80f81b8c (diff)
downloadmeta-openembedded-c13246e4631288966ddffc02eae49e66d5eccb31.tar.gz
zabbix: upgrade 4.4.1 -> 4.4.5
Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/zabbix/zabbix_4.4.5.bb')
-rw-r--r--meta-oe/recipes-connectivity/zabbix/zabbix_4.4.5.bb78
1 files changed, 78 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/zabbix/zabbix_4.4.5.bb b/meta-oe/recipes-connectivity/zabbix/zabbix_4.4.5.bb
new file mode 100644
index 000000000..108813f1e
--- /dev/null
+++ b/meta-oe/recipes-connectivity/zabbix/zabbix_4.4.5.bb
@@ -0,0 +1,78 @@
1SUMMARY = "Open-source monitoring solution for your IT infrastructure"
2DESCRIPTION = "\
3ZABBIX is software that monitors numerous parameters of a network and the \
4health and integrity of servers. ZABBIX uses a flexible notification \
5mechanism that allows users to configure e-mail based alerts for virtually \
6any event. This allows a fast reaction to server problems. ZABBIX offers \
7excellent reporting and data visualisation features based on the stored \
8data. This makes ZABBIX ideal for capacity planning. \
9\
10ZABBIX supports both polling and trapping. All ZABBIX reports and \
11statistics, as well as configuration parameters are accessed through a \
12web-based front end. A web-based front end ensures that the status of \
13your network and the health of your servers can be assessed from any \
14location. Properly configured, ZABBIX can play an important role in \
15monitoring IT infrastructure. This is equally true for small \
16organisations with a few servers and for large companies with a \
17multitude of servers."
18HOMEPAGE = "http://www.zabbix.com/"
19SECTION = "Applications/Internet"
20LICENSE = "GPLv2+"
21LIC_FILES_CHKSUM = "file://COPYING;md5=300e938ad303147fede2294ed78fe02e"
22DEPENDS = "libevent libpcre openldap virtual/libiconv zlib"
23
24PACKAGE_ARCH = "${MACHINE_ARCH}"
25
26SRC_URI = "http://jaist.dl.sourceforge.net/project/zabbix/ZABBIX%20Latest%20Stable/${PV}/${BPN}-${PV}.tar.gz \
27 file://0001-Fix-configure.ac.patch \
28 file://zabbix-agent.service \
29"
30
31SRC_URI[md5sum] = "69ab0c1bbf9d1f8979664498d36cc9a6"
32SRC_URI[sha256sum] = "94a897825b062e17b34767c0864305cee6a87476dda8bee88dcf845b24bed0ea"
33
34inherit autotools-brokensep linux-kernel-base pkgconfig systemd useradd
35
36SYSTEMD_PACKAGES = "${PN}"
37SYSTEMD_SERVICE_${PN} = "zabbix-agent.service"
38SYSTEMD_AUTO_ENABLE = "enable"
39
40USERADD_PACKAGES = "${PN}"
41GROUPADD_PARAM_${PN} = "-r zabbix"
42USERADD_PARAM_${PN} = "-r -g zabbix -d /var/lib/zabbix \
43 -s /sbin/nologin -c \"Zabbix Monitoring System\" zabbix \
44"
45
46KERNEL_VERSION = "${@get_kernelversion_headers('${STAGING_KERNEL_DIR}')}"
47
48EXTRA_OECONF = " \
49 --enable-dependency-tracking \
50 --enable-agent \
51 --enable-ipv6 \
52 --with-net-snmp \
53 --with-ldap=${STAGING_EXECPREFIXDIR} \
54 --with-unixodbc \
55 --with-ssh2 \
56 --with-sqlite3 \
57 --with-zlib \
58 --with-libpthread \
59 --with-libevent \
60 --with-libpcre \
61"
62CFLAGS_append = " -lldap -llber -pthread"
63
64do_configure_prepend() {
65 export KERNEL_VERSION="${KERNEL_VERSION}"
66}
67
68do_install_append() {
69 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
70 install -d ${D}${systemd_unitdir}/system
71 install -m 0644 ${WORKDIR}/zabbix-agent.service ${D}${systemd_unitdir}/system/
72 sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/zabbix-agent.service
73 fi
74}
75
76FILES_${PN} += "${libdir}"
77
78RDEPENDS_${PN} = "logrotate"