diff options
author | Gianfranco Costamagna <gianfranco.costamagna@abinsula.com> | 2017-05-11 14:28:11 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-05-23 15:49:33 +0200 |
commit | 85810933a8b1e88a8ae8652387885abc0522b419 (patch) | |
tree | 0bf2f0f37a8280516aafef420641fc32d21c4ad8 /meta-oe/recipes-connectivity/wvdial | |
parent | 37acbb5d0fc76684ce172e3925ccd1d9252c7ffb (diff) | |
download | meta-openembedded-85810933a8b1e88a8ae8652387885abc0522b419.tar.gz |
wxstreams: fix build with gcc-6 (patch from Debian). Remove blacklists for wvstreams and wvdial
Signed-off-by: Gianfranco Costamagna <gianfranco.costamagna@abinsula.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/wvdial')
-rw-r--r-- | meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/wvdial/wvstreams/gcc-6.patch | 42 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb | 4 |
3 files changed, 43 insertions, 5 deletions
diff --git a/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb b/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb index 80e72bd8b3..f7adf4c9f4 100644 --- a/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb +++ b/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb | |||
@@ -28,5 +28,3 @@ do_configure() { | |||
28 | do_install() { | 28 | do_install() { |
29 | oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install | 29 | oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install |
30 | } | 30 | } |
31 | |||
32 | PNBLACKLIST[wvdial] ?= "Depends on broken wvstreams - the recipe will be removed on 2017-09-01 unless the issue is fixed" | ||
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams/gcc-6.patch b/meta-oe/recipes-connectivity/wvdial/wvstreams/gcc-6.patch new file mode 100644 index 0000000000..b084887ba7 --- /dev/null +++ b/meta-oe/recipes-connectivity/wvdial/wvstreams/gcc-6.patch | |||
@@ -0,0 +1,42 @@ | |||
1 | Description: Fix compilation with gcc-6 | ||
2 | Author: Gert Wollny <gw.fossdev@gmail.com> | ||
3 | Last-Updated: 2016-07-26 | ||
4 | Forwarded: No | ||
5 | Bug-Debian: https://bugs.debian.org/811659 | ||
6 | Bug-Debian: https://bugs.debian.org/831146 | ||
7 | |||
8 | --- a/streams/wvstream.cc | ||
9 | +++ b/streams/wvstream.cc | ||
10 | @@ -907,9 +907,9 @@ | ||
11 | |||
12 | if (forceable) | ||
13 | { | ||
14 | - si.wants.readable = readcb; | ||
15 | - si.wants.writable = writecb; | ||
16 | - si.wants.isexception = exceptcb; | ||
17 | + si.wants.readable = static_cast<bool>(readcb); | ||
18 | + si.wants.writable = static_cast<bool>(writecb); | ||
19 | + si.wants.isexception = static_cast<bool>(exceptcb); | ||
20 | } | ||
21 | else | ||
22 | { | ||
23 | @@ -1019,7 +1019,8 @@ | ||
24 | |||
25 | IWvStream::SelectRequest WvStream::get_select_request() | ||
26 | { | ||
27 | - return IWvStream::SelectRequest(readcb, writecb, exceptcb); | ||
28 | + return IWvStream::SelectRequest(static_cast<bool>(readcb), static_cast<bool>(writecb), | ||
29 | + static_cast<bool>(exceptcb)); | ||
30 | } | ||
31 | |||
32 | |||
33 | @@ -1107,7 +1108,8 @@ | ||
34 | // inefficient, because if the alarm was expired then pre_select() | ||
35 | // returned true anyway and short-circuited the previous select(). | ||
36 | TRACE("hello-%p\n", this); | ||
37 | - return !alarm_was_ticking || select(0, readcb, writecb, exceptcb); | ||
38 | + return !alarm_was_ticking || select(0, static_cast<bool>(readcb), | ||
39 | + static_cast<bool>(writecb), static_cast<bool>(exceptcb)); | ||
40 | } | ||
41 | |||
42 | |||
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb b/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb index fe79dc1ad2..607a6178f6 100644 --- a/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb +++ b/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb | |||
@@ -11,6 +11,7 @@ SRC_URI = "http://${BPN}.googlecode.com/files/${BP}.tar.gz \ | |||
11 | file://05_gcc.diff \ | 11 | file://05_gcc.diff \ |
12 | file://06_gcc-4.7.diff \ | 12 | file://06_gcc-4.7.diff \ |
13 | file://07_buildflags.diff \ | 13 | file://07_buildflags.diff \ |
14 | file://gcc-6.patch \ | ||
14 | " | 15 | " |
15 | 16 | ||
16 | SRC_URI[md5sum] = "2760dac31a43d452a19a3147bfde571c" | 17 | SRC_URI[md5sum] = "2760dac31a43d452a19a3147bfde571c" |
@@ -46,6 +47,3 @@ FILES_libwvstreams-extras-dbg = "${libdir}/.debug/libwvbase.so.* ${libdir}/.debu | |||
46 | 47 | ||
47 | FILES_${PN}-valgrind = "${libdir}/valgrind/wvstreams.supp" | 48 | FILES_${PN}-valgrind = "${libdir}/valgrind/wvstreams.supp" |
48 | RDEPENDS_${PN} += "perl" | 49 | RDEPENDS_${PN} += "perl" |
49 | |||
50 | # http://errors.yoctoproject.org/Errors/Details/68614/ | ||
51 | PNBLACKLIST[wvstreams] ?= "BROKEN: fails to build with gcc-6 - the recipe will be removed on 2017-09-01 unless the issue is fixed" | ||