summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/wvdial
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-connectivity/wvdial
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/wvdial')
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvdial/typo_pon.wvdial.1.patch20
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb30
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams/04_signed_request.diff13
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams/05_gcc.diff41
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams/06_gcc-4.7.diff18
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams/07_buildflags.diff32
-rw-r--r--meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb45
7 files changed, 199 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/wvdial/wvdial/typo_pon.wvdial.1.patch b/meta-oe/recipes-connectivity/wvdial/wvdial/typo_pon.wvdial.1.patch
new file mode 100644
index 000000000..eec5a5d64
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvdial/typo_pon.wvdial.1.patch
@@ -0,0 +1,20 @@
1Remove warnings found by lintian
2Last-Update: 2011-01-09
3Index: wvdial-1.61/pon.wvdial.1
4===================================================================
5--- wvdial-1.61.orig/pon.wvdial.1 2011-01-09 21:33:03.000000000 +0300
6+++ wvdial-1.61/pon.wvdial.1 2011-01-09 21:33:15.000000000 +0300
7@@ -8,13 +8,11 @@
8 .SH DESCRIPTION
9 .B pon.wvdial
10 .br
11-.TR
12 .B poff.wvdial
13 .br
14 .RS
15 Replacement scripts for pon and poff.
16 .RE
17-\."
18 .SH SEE ALSO
19 .BR wvdial (1),
20 .BR pon (1),
diff --git a/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb b/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb
new file mode 100644
index 000000000..f7adf4c9f
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvdial_1.61.bb
@@ -0,0 +1,30 @@
1HOMEPAGE = "http://www.alumnit.ca/wiki/?WvDial"
2DESCRIPTION = "WvDial is a program that makes it easy to connect your Linux workstation to the Internet."
3
4LICENSE = "LGPLv2"
5LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605"
6
7DEPENDS = "wvstreams"
8RDEPENDS_${PN} = "ppp"
9
10SRC_URI = "http://${BPN}.googlecode.com/files/${BP}.tar.bz2 \
11 file://typo_pon.wvdial.1.patch \
12 "
13
14SRC_URI[md5sum] = "37e9a2d664effe4efd44c0e1a20136de"
15SRC_URI[sha256sum] = "99906d9560cbdbc97e1855e7b0a7169f1e11983be3ac539140423f09debced82"
16
17EXTRA_OEMAKE = ""
18export WVLINK="${LD}"
19
20PARALLEL_MAKE = ""
21
22BUILD_CPPFLAGS += "-I${STAGING_INCDIR}/wvstreams"
23
24do_configure() {
25 sed -i 's/LDFLAGS+=-luniconf/LIBS+=-luniconf/' ${S}/Makefile
26}
27
28do_install() {
29 oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install
30}
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams/04_signed_request.diff b/meta-oe/recipes-connectivity/wvdial/wvstreams/04_signed_request.diff
new file mode 100644
index 000000000..5ab633bc3
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams/04_signed_request.diff
@@ -0,0 +1,13 @@
1Index: wvstreams-4.6/crypto/wvx509.cc
2===================================================================
3--- wvstreams-4.6.orig/crypto/wvx509.cc 2009-07-29 11:58:16.000000000 -0400
4+++ wvstreams-4.6/crypto/wvx509.cc 2009-07-29 11:58:43.000000000 -0400
5@@ -325,7 +325,7 @@
6 }
7
8 int verify_result = X509_REQ_verify(certreq, pk);
9- if (verify_result == 0)
10+ if (verify_result == 0 || verify_result == -1)
11 {
12 debug(WvLog::Warning, "Self signed request failed");
13 X509_REQ_free(certreq);
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams/05_gcc.diff b/meta-oe/recipes-connectivity/wvdial/wvstreams/05_gcc.diff
new file mode 100644
index 000000000..8e4fd0329
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams/05_gcc.diff
@@ -0,0 +1,41 @@
1Index: wvstreams-4.6.1/crypto/wvx509.cc
2===================================================================
3--- wvstreams-4.6.1.orig/crypto/wvx509.cc 2011-05-20 00:02:38.119136584 +0200
4+++ wvstreams-4.6.1/crypto/wvx509.cc 2011-05-20 00:02:26.035136589 +0200
5@@ -1157,7 +1157,7 @@
6
7 if (ext)
8 {
9- X509V3_EXT_METHOD *method = X509V3_EXT_get(ext);
10+ X509V3_EXT_METHOD *method = (X509V3_EXT_METHOD *)X509V3_EXT_get(ext);
11 if (!method)
12 {
13 WvDynBuf buf;
14Index: wvstreams-4.6.1/ipstreams/wvunixdgsocket.cc
15===================================================================
16--- wvstreams-4.6.1.orig/ipstreams/wvunixdgsocket.cc 2011-05-20 00:02:38.391136584 +0200
17+++ wvstreams-4.6.1/ipstreams/wvunixdgsocket.cc 2011-05-20 00:02:35.283136585 +0200
18@@ -1,8 +1,6 @@
19 #include "wvunixdgsocket.h"
20-#ifdef MACOS
21 #include <sys/types.h>
22 #include <sys/stat.h>
23-#endif
24
25 WvUnixDGSocket::WvUnixDGSocket(WvStringParm filename, bool _server, int perms)
26 : socketfile(filename)
27Index: wvstreams-4.6.1/streams/wvatomicfile.cc
28===================================================================
29--- wvstreams-4.6.1.orig/streams/wvatomicfile.cc 2011-05-20 00:02:38.223136584 +0200
30+++ wvstreams-4.6.1/streams/wvatomicfile.cc 2011-05-20 00:02:31.619136587 +0200
31@@ -10,10 +10,7 @@
32 #include "wvatomicfile.h"
33 #include "wvfileutils.h"
34 #include "wvstrutils.h"
35-
36-#ifdef MACOS
37 #include <sys/stat.h>
38-#endif
39
40 WvAtomicFile::WvAtomicFile(WvStringParm filename, int flags, mode_t create_mode)
41 : tmp_file(WvString::null)
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams/06_gcc-4.7.diff b/meta-oe/recipes-connectivity/wvdial/wvstreams/06_gcc-4.7.diff
new file mode 100644
index 000000000..a75067a10
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams/06_gcc-4.7.diff
@@ -0,0 +1,18 @@
1Description: Fix FTBFS with gcc-4.7
2 Small header include change. This is borderlinde cosmetic, but still needed
3 to prevent the FTBFS.
4Author: Paul Tagliamonte <paultag@ubuntu.com>
5Origin: vendor
6Bug-Debian: http://bugs.debian.org/667418
7Last-Update: 2012-04-13
8
9--- wvstreams-4.6.1.orig/utils/wvuid.cc
10+++ wvstreams-4.6.1/utils/wvuid.cc
11@@ -33,6 +33,7 @@ wvuid_t wvgetuid()
12
13 #else // not WIN32
14
15+#include <unistd.h>
16
17 WvString wv_username_from_uid(wvuid_t uid)
18 {
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams/07_buildflags.diff b/meta-oe/recipes-connectivity/wvdial/wvstreams/07_buildflags.diff
new file mode 100644
index 000000000..ec99dcd36
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams/07_buildflags.diff
@@ -0,0 +1,32 @@
1Index: b/gen-cc
2===================================================================
3--- a/gen-cc
4+++ b/gen-cc
5@@ -15,6 +15,11 @@
6 shift
7 shift
8
9+ echo $CC \$MODE -o \$BASE.o \$BASE.$EXT \\
10+ -MMD -MF \$DEPFILE -MP -MQ \$BASE.o \\
11+ $CPPFLAGS \\
12+ $CFLAGS \\
13+ "\$@"
14 $CC \$MODE -o \$BASE.o \$BASE.$EXT \\
15 -MMD -MF \$DEPFILE -MP -MQ \$BASE.o \\
16 $CPPFLAGS \\
17Index: b/wvrules-posix.mk
18===================================================================
19--- a/wvrules-posix.mk
20+++ b/wvrules-posix.mk
21@@ -35,11 +35,6 @@
22 # Default compiler we use for linking
23 WVLINK_CC = $(CXX)
24
25-ifneq ("$(enable_optimization)", "no")
26- CXXFLAGS+=-O2
27- CFLAGS+=-O2
28-endif
29-
30 ifneq ("$(enable_warnings)", "no")
31 CXXFLAGS+=-Wall -Woverloaded-virtual
32 CFLAGS+=-Wall
diff --git a/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb b/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb
new file mode 100644
index 000000000..8a77b5bec
--- /dev/null
+++ b/meta-oe/recipes-connectivity/wvdial/wvstreams_4.6.1.bb
@@ -0,0 +1,45 @@
1HOMEPAGE = "http://alumnit.ca/wiki/index.php?page=WvStreams"
2SUMMARY = "WvStreams is a network programming library in C++"
3
4LICENSE = "LGPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
6
7DEPENDS = "zlib openssl (>= 0.9.8) dbus readline"
8
9SRC_URI = "http://${BPN}.googlecode.com/files/${BP}.tar.gz \
10 file://04_signed_request.diff \
11 file://05_gcc.diff \
12 file://06_gcc-4.7.diff \
13 file://07_buildflags.diff \
14 "
15
16SRC_URI[md5sum] = "2760dac31a43d452a19a3147bfde571c"
17SRC_URI[sha256sum] = "8403f5fbf83aa9ac0c6ce15d97fd85607488152aa84e007b7d0621b8ebc07633"
18
19inherit autotools-brokensep pkgconfig
20
21PARALLEL_MAKE = ""
22
23LDFLAGS_append = " -Wl,-rpath-link,${CROSS_DIR}/${TARGET_SYS}/lib"
24
25EXTRA_OECONF = " --without-tcl --without-qt --without-pam --without-valgrind"
26
27PACKAGES_prepend = "libuniconf libuniconf-dbg "
28PACKAGES_prepend = "uniconfd uniconfd-dbg "
29PACKAGES_prepend = "libwvstreams-base libwvstreams-base-dbg "
30PACKAGES_prepend = "libwvstreams-extras libwvstreams-extras-dbg "
31PACKAGES_prepend = "${PN}-valgrind "
32
33FILES_libuniconf = "${libdir}/libuniconf.so.*"
34FILES_libuniconf-dbg = "${libdir}/.debug/libuniconf.so.*"
35
36FILES_uniconfd = "${sbindir}/uniconfd ${sysconfdir}/uniconf.conf ${localstatedir}/uniconf"
37FILES_uniconfd-dbg = "${sbindir}/.debug/uniconfd"
38
39FILES_libwvstreams-base = "${libdir}/libwvutils.so.*"
40FILES_libwvstreams-base-dbg = "${libdir}/.debug/libwvutils.so.*"
41
42FILES_libwvstreams-extras = "${libdir}/libwvbase.so.* ${libdir}/libwvstreams.so.*"
43FILES_libwvstreams-extras-dbg = "${libdir}/.debug/libwvbase.so.* ${libdir}/.debug/libwvstreams.so.*"
44
45FILES_${PN}-valgrind = "${libdir}/valgrind/wvstreams.supp"