summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/usbmuxd
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-connectivity/usbmuxd
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/usbmuxd')
-rw-r--r--meta-oe/recipes-connectivity/usbmuxd/usbmuxd_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/usbmuxd/usbmuxd_git.bb b/meta-oe/recipes-connectivity/usbmuxd/usbmuxd_git.bb
new file mode 100644
index 000000000..52bf811e3
--- /dev/null
+++ b/meta-oe/recipes-connectivity/usbmuxd/usbmuxd_git.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "This daemon is in charge of multiplexing connections over USB to an iPhone or iPod touch."
2LICENSE = "GPLv3 & GPLv2 & LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING.GPLv2;md5=ebb5c50ab7cab4baeffba14977030c07 \
4 file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \
5 file://COPYING.LGPLv2.1;md5=6ab17b41640564434dda85c06b7124f7"
6
7DEPENDS = "udev libusb1"
8
9inherit cmake pkgconfig gitpkgv
10
11PKGV = "${GITPKGVTAG}"
12
13SRCREV = "919587580c5e77f3936f3432115d2e10c7bac7c5"
14SRC_URI = "git://git.sukimashita.com/usbmuxd.git;protocol=http"
15
16S = "${WORKDIR}/git"
17
18FILES_${PN} += "${base_libdir}/udev/rules.d/"
19
20# fix usbmuxd installing files to /usr/lib64 on 64bit hosts:
21EXTRA_OECMAKE = "-DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')}"
22
23PACKAGECONFIG ??= ""
24PACKAGECONFIG[plist] = "-DWANT_PLIST=1,-DWANT_PLIST=0,libplist"