diff options
author | Ann Thornton <ann.thornton@nxp.com> | 2016-05-04 17:03:41 -0500 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-05-10 20:18:55 +0200 |
commit | 5397ae5d576b53f6e4be25219f719bcafc8b9357 (patch) | |
tree | c047d10a5dceee95dde64eae15804cfa9b35870d /meta-oe/recipes-connectivity/packagegroups | |
parent | 4adec181e7303c0afd7fca08fec6ddc5532237a1 (diff) | |
download | meta-openembedded-5397ae5d576b53f6e4be25219f719bcafc8b9357.tar.gz |
packagegroup-tools-bluetooth: Selects the tools appropriate for the version of bluez being used.
Signed-off-by: Ann Thornton <ann.thornton@nxp.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/packagegroups')
-rw-r--r-- | meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb | 43 |
1 files changed, 20 insertions, 23 deletions
diff --git a/meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb b/meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb index bdab389bcf..dde4599ac4 100644 --- a/meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb +++ b/meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb | |||
@@ -5,36 +5,33 @@ LICENSE = "MIT" | |||
5 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \ | 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \ |
6 | file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" | 6 | file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
7 | 7 | ||
8 | SUMMARY = "Set of Bluetooh related tools for inclusion on images" | 8 | SUMMARY = "Set of Bluetooth related tools for inclusion in images" |
9 | DESCRIPTION = "Add bluetooth tools based on the version of BlueZ in use.\ | 9 | DESCRIPTION = "Includes bluetooth specific tools for this version of BlueZ.\ |
10 | The tools that have been tested and work the best are pulled in \ | 10 | These tools are used at runtime. \ |
11 | automatically. The same packagegroup can be used in a recipe without \ | ||
12 | the need to know which version of BlueZ is in use. \ | ||
13 | Supports BlueZ4 and BlueZ5." | 11 | Supports BlueZ4 and BlueZ5." |
14 | 12 | ||
15 | inherit packagegroup | 13 | inherit packagegroup |
14 | inherit bluetooth | ||
16 | 15 | ||
17 | BLUEZ4_INSTALL = " \ | 16 | RDEPENDS_bluez4 = " \ |
18 | obexftp \ | 17 | obexftp \ |
19 | " | 18 | " |
20 | 19 | ||
21 | BLUEZ5_INSTALL = " \ | 20 | RDEPENDS_bluez5 = " \ |
22 | bluez5-noinst-tools \ | 21 | bluez5-noinst-tools \ |
23 | bluez5-obex \ | 22 | bluez5-obex \ |
24 | bluez5-testtools \ | 23 | bluez5-testtools \ |
25 | libasound-module-bluez \ | 24 | libasound-module-bluez \ |
26 | ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', "pulseaudio-module-bluetooth-discover \ | 25 | ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', \ |
27 | pulseaudio-module-bluetooth-policy \ | 26 | 'pulseaudio-module-bluetooth-discover \ |
28 | pulseaudio-module-bluez5-discover \ | 27 | pulseaudio-module-bluetooth-policy \ |
29 | pulseaudio-module-bluez5-device \ | 28 | pulseaudio-module-bluez5-discover \ |
30 | pulseaudio-module-switch-on-connect \ | 29 | pulseaudio-module-bluez5-device \ |
31 | pulseaudio-module-loopback", \ | 30 | pulseaudio-module-switch-on-connect \ |
32 | '', d)} \ | 31 | pulseaudio-module-loopback', \ |
32 | '', d)} \ | ||
33 | " | 33 | " |
34 | 34 | ||
35 | # Install either bluez4 or bluez5 if they are in distro. | 35 | # Install bluez4 tools or bluez5 tools depending on what is specified in the distro. |
36 | # Otherwise install nothing. | 36 | # Otherwise install nothing. |
37 | RDEPENDS_${PN} = " \ | 37 | RDEPENDS_${PN} = "${RDEPENDS_${BLUEZ}}" |
38 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluez5', '${BLUEZ5_INSTALL}', "", d)} \ | ||
39 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluez4', '${BLUEZ4_INSTALL}', "", d)} \ | ||
40 | " | ||