summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/obexftp
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-connectivity/obexftp
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/obexftp')
-rw-r--r--meta-oe/recipes-connectivity/obexftp/obexftp/Remove_some_printf_in_obexftpd.patch34
-rw-r--r--meta-oe/recipes-connectivity/obexftp/obexftp_0.23.bb16
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/obexftp/obexftp/Remove_some_printf_in_obexftpd.patch b/meta-oe/recipes-connectivity/obexftp/obexftp/Remove_some_printf_in_obexftpd.patch
new file mode 100644
index 000000000..8b73af32e
--- /dev/null
+++ b/meta-oe/recipes-connectivity/obexftp/obexftp/Remove_some_printf_in_obexftpd.patch
@@ -0,0 +1,34 @@
1Signed-off-by: Jun Zhu <R01007@freescale.com>
2
3Upstream-Status: Not applicable
4
5diff -Nru obexftp-0.23/apps.orig/obexftpd.c obexftp-0.23/apps/obexftpd.c
6--- obexftp-0.23/apps.orig/obexftpd.c 2013-11-08 10:42:20.816631583 +0800
7+++ obexftp-0.23/apps/obexftpd.c 2013-11-08 10:44:18.628634893 +0800
8@@ -639,7 +639,7 @@
9 struct stat statbuf;
10 //char *namebuf = NULL;
11
12- fprintf(stderr, "put_done>>>\n");
13+ //fprintf(stderr, "put_done>>>\n");
14 while(OBEX_ObjectGetNextHeader(handle, object, &hi, &hv, &hlen)) {
15 switch(hi) {
16 case OBEX_HDR_BODY:
17@@ -671,7 +671,7 @@
18 }
19 }
20 if(!body) {
21- printf("Got a PUT without a body\n");
22+ //printf("Got a PUT without a body\n");
23 OBEX_ObjectSetRsp(object, OBEX_RSP_CONTINUE, OBEX_RSP_SUCCESS);
24 }
25 if(!name) {
26@@ -807,7 +807,7 @@
27
28 switch(obex_cmd) {
29 case OBEX_CMD_PUT:
30- fprintf(stderr, "obex_ev_progress: obex_cmd_put\n");
31+ //fprintf(stderr, "obex_ev_progress: obex_cmd_put\n");
32 put_done(handle, obj, 0);
33 break;
34 default:
diff --git a/meta-oe/recipes-connectivity/obexftp/obexftp_0.23.bb b/meta-oe/recipes-connectivity/obexftp/obexftp_0.23.bb
new file mode 100644
index 000000000..b6bdfb7e4
--- /dev/null
+++ b/meta-oe/recipes-connectivity/obexftp/obexftp_0.23.bb
@@ -0,0 +1,16 @@
1DESCRIPTION = "A tool for transfer files to/from any OBEX enabled device"
2LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
4
5DEPENDS += "openobex"
6
7SRC_URI = "http://sourceforge.net/projects/openobex/files/obexftp/${PV}/obexftp-${PV}.tar.bz2 \
8 file://Remove_some_printf_in_obexftpd.patch "
9
10SRC_URI[md5sum] = "f20762061b68bc921e80be4aebc349eb"
11SRC_URI[sha256sum] = "44a74ff288d38c0f75354d6bc2efe7d6dec10112eaff2e7b10e292b0d2105b36"
12
13inherit autotools pkgconfig
14
15EXTRA_OECONF += "--disable-tcl --disable-perl --disable-python --disable-ruby"
16