diff options
author | Khem Raj <raj.khem@gmail.com> | 2018-12-07 23:11:24 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-12-07 23:11:24 -0800 |
commit | 03cc27a6093b88308fb15bbf0f525c4c4511aa69 (patch) | |
tree | 0374978d50f790e41efbb820242c052a32321be9 /meta-oe/recipes-connectivity/modemmanager | |
parent | ff6bead1624a1e261408516b3d064a04aab5f592 (diff) | |
download | meta-openembedded-03cc27a6093b88308fb15bbf0f525c4c4511aa69.tar.gz |
modemmanager: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/modemmanager')
-rw-r--r-- | meta-oe/recipes-connectivity/modemmanager/modemmanager/0001-Do-not-set-Wno-unused-but-set-variable.patch | 30 | ||||
-rw-r--r-- | meta-oe/recipes-connectivity/modemmanager/modemmanager_1.8.2.bb | 2 |
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/modemmanager/modemmanager/0001-Do-not-set-Wno-unused-but-set-variable.patch b/meta-oe/recipes-connectivity/modemmanager/modemmanager/0001-Do-not-set-Wno-unused-but-set-variable.patch new file mode 100644 index 0000000000..dcbe01d5ed --- /dev/null +++ b/meta-oe/recipes-connectivity/modemmanager/modemmanager/0001-Do-not-set-Wno-unused-but-set-variable.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From d4f73b037d11d20f080e74c05df28853fb833075 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 7 Dec 2018 22:59:47 -0800 | ||
4 | Subject: [PATCH] Do not set Wno-unused-but-set-variable | ||
5 | |||
6 | This is gcc specific warning, not implemented by pretending to be gcc | ||
7 | like compilers e.g. clang. | ||
8 | |||
9 | We will pass this option from recipe | ||
10 | |||
11 | Upstream-Status: Inappropriate [OE-Specific] | ||
12 | |||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | m4/compiler_warnings.m4 | 2 +- | ||
16 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
17 | |||
18 | diff --git a/m4/compiler_warnings.m4 b/m4/compiler_warnings.m4 | ||
19 | index f498a28..e65e97f 100644 | ||
20 | --- a/m4/compiler_warnings.m4 | ||
21 | +++ b/m4/compiler_warnings.m4 | ||
22 | @@ -11,7 +11,7 @@ if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then | ||
23 | -Wdeclaration-after-statement -Wstrict-prototypes \ | ||
24 | -Wno-unused-parameter -Wno-sign-compare \ | ||
25 | -Wno-deprecated-declarations \ | ||
26 | - -Wno-unused-but-set-variable -Wformat-security; do | ||
27 | + -Wno-unused -Wformat-security; do | ||
28 | SAVE_CFLAGS="$CFLAGS" | ||
29 | CFLAGS="$CFLAGS $option" | ||
30 | AC_MSG_CHECKING([whether gcc understands $option]) | ||
diff --git a/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.8.2.bb b/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.8.2.bb index 50114dd399..e198bd588e 100644 --- a/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.8.2.bb +++ b/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.8.2.bb | |||
@@ -12,6 +12,7 @@ inherit gnomebase gettext systemd vala gobject-introspection bash-completion | |||
12 | DEPENDS = "glib-2.0 libgudev dbus-glib intltool-native" | 12 | DEPENDS = "glib-2.0 libgudev dbus-glib intltool-native" |
13 | 13 | ||
14 | SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz \ | 14 | SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz \ |
15 | file://0001-Do-not-set-Wno-unused-but-set-variable.patch \ | ||
15 | " | 16 | " |
16 | 17 | ||
17 | SRC_URI[md5sum] = "a49c9f73e46c7b89e5efedda250d22c0" | 18 | SRC_URI[md5sum] = "a49c9f73e46c7b89e5efedda250d22c0" |
@@ -33,6 +34,7 @@ PACKAGECONFIG[qmi] = "--with-qmi,--without-qmi,libqmi" | |||
33 | EXTRA_OECONF = " \ | 34 | EXTRA_OECONF = " \ |
34 | --with-udev-base-dir=${nonarch_base_libdir}/udev \ | 35 | --with-udev-base-dir=${nonarch_base_libdir}/udev \ |
35 | " | 36 | " |
37 | CFLAGS_append_toolchain-gcc = " -Wno-unused-but-set-variable" | ||
36 | 38 | ||
37 | FILES_${PN} += " \ | 39 | FILES_${PN} += " \ |
38 | ${datadir}/icons \ | 40 | ${datadir}/icons \ |