summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-19 22:31:39 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-31 13:25:56 +0200
commitf67e201820e15c542a05bf67ec49a80ba36ab875 (patch)
treea69c6219151494eb42a443d48459e06e08c4c99f /meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb
parent0d48a392d56d6ec9ef0de267f7ee802b3daae8b0 (diff)
downloadmeta-openembedded-f67e201820e15c542a05bf67ec49a80ba36ab875.tar.gz
libtorrent, rtorrent: Update to latest
libtorrent -> 0.13.6+git rtorrent -> 0.9.6+git Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb')
-rw-r--r--meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb b/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb
new file mode 100644
index 000000000..aaebc5f1b
--- /dev/null
+++ b/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "libTorrent is a BitTorrent library written in C++ for *nix, \
2with a focus on high performance and good code."
3HOMEPAGE = "http://libtorrent.rakshasa.no/"
4LICENSE = "GPL-2.0"
5LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
6
7DEPENDS = "zlib libsigc++-2.0 openssl cppunit"
8
9SRC_URI = "git://github.com/rakshasa/libtorrent \
10 file://don-t-run-code-while-configuring-package.patch \
11"
12SRCREV = "c167c5a9e0bcf0df23ae5efd91396aae0e37eb87"
13
14PV = "0.13.6+git${SRCPV}"
15
16S = "${WORKDIR}/git"
17
18inherit autotools pkgconfig
19
20EXTRA_OECONF = "--with-zlib=${STAGING_EXECPREFIXDIR}"
21
22do_configure_prepend() {
23 (cd ${S}; ./autogen.sh; cd -)
24}