summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/iwd
diff options
context:
space:
mode:
authorPierre-Jean Texier <pjtexier@koncepto.io>2020-03-13 19:57:50 +0100
committerKhem Raj <raj.khem@gmail.com>2020-03-13 12:49:40 -0700
commit93d67b30793ef5d22647d9f80656ba3449083ea5 (patch)
treeceae22f6e00b3ebe577efd42217c46c6cb30d1c8 /meta-oe/recipes-connectivity/iwd
parentf5fdeea3564cdf0705d898350cf35d4612b672cc (diff)
downloadmeta-openembedded-93d67b30793ef5d22647d9f80656ba3449083ea5.tar.gz
iwd: upgrade 1.4 -> 1.5
Remove patch already in version Fixes: ver 1.5: Fix issue with handling missing NEW_WIPHY events. Fix issue with interface creation and NEW_WIPHY events. Fix issue with handling LastConnectedTime property change. Fix issue with PEAPv0 interoperability with Windows. Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/iwd')
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd/0001-build-Support-missing-rawmemchr.patch62
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd_1.5.bb (renamed from meta-oe/recipes-connectivity/iwd/iwd_1.4.bb)10
2 files changed, 4 insertions, 68 deletions
diff --git a/meta-oe/recipes-connectivity/iwd/iwd/0001-build-Support-missing-rawmemchr.patch b/meta-oe/recipes-connectivity/iwd/iwd/0001-build-Support-missing-rawmemchr.patch
deleted file mode 100644
index 733f5fea1..000000000
--- a/meta-oe/recipes-connectivity/iwd/iwd/0001-build-Support-missing-rawmemchr.patch
+++ /dev/null
@@ -1,62 +0,0 @@
1From fcdddf2b726439e049992878f90da607414a1a47 Mon Sep 17 00:00:00 2001
2From: Denis Kenzior <denkenz@gmail.com>
3Date: Mon, 3 Feb 2020 11:54:28 -0600
4Subject: [PATCH] build: Support missing rawmemchr
5
6rawmemchr is a GNU extension in glibc that does not exist in musl.
7
8Upstream-status: Backport of https://git.kernel.org/pub/scm/network/wireless/iwd.git/commit/?id=fcdddf2b726439e049992878f90da607414a1a47
9
10Signed-off-by: Robert Joslyn <robert.joslyn@redrectangle.org>
11
12---
13 configure.ac | 1 +
14 src/missing.h | 10 ++++++++++
15 src/wiphy.c | 1 +
16 3 files changed, 12 insertions(+)
17
18diff --git a/configure.ac b/configure.ac
19index 5ae1401cae17..2d373a47ba68 100644
20--- a/configure.ac
21+++ b/configure.ac
22@@ -128,6 +128,7 @@ AC_DEFINE_UNQUOTED(WIRED_STORAGEDIR, "${wired_storagedir}",
23 [Directory for Ethernet daemon storage files])
24
25 AC_CHECK_FUNCS(explicit_bzero)
26+AC_CHECK_FUNCS(rawmemchr)
27
28 AC_CHECK_HEADERS(linux/types.h linux/if_alg.h)
29
30diff --git a/src/missing.h b/src/missing.h
31index 2bb210ae3c81..2cc80aee5d38 100644
32--- a/src/missing.h
33+++ b/src/missing.h
34@@ -27,3 +27,13 @@ static inline void explicit_bzero(void *s, size_t n)
35 __asm__ __volatile__ ("" : : "r"(s) : "memory");
36 }
37 #endif
38+
39+#ifndef HAVE_RAWMEMCHR
40+static inline void *rawmemchr(const void *s, int c)
41+{
42+_Pragma("GCC diagnostic push")
43+_Pragma("GCC diagnostic ignored \"-Wstringop-overflow=\"")
44+ return memchr(s, c, (size_t) -1);
45+_Pragma("GCC diagnostic pop")
46+}
47+#endif
48diff --git a/src/wiphy.c b/src/wiphy.c
49index 1da479db2dab..511bb27f52b8 100644
50--- a/src/wiphy.c
51+++ b/src/wiphy.c
52@@ -37,6 +37,7 @@
53
54 #include "linux/nl80211.h"
55
56+#include "src/missing.h"
57 #include "src/iwd.h"
58 #include "src/module.h"
59 #include "src/ie.h"
60--
612.21.0
62
diff --git a/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb b/meta-oe/recipes-connectivity/iwd/iwd_1.5.bb
index f758781e3..4d4c69906 100644
--- a/meta-oe/recipes-connectivity/iwd/iwd_1.4.bb
+++ b/meta-oe/recipes-connectivity/iwd/iwd_1.5.bb
@@ -5,12 +5,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
5 5
6DEPENDS = "ell" 6DEPENDS = "ell"
7 7
8SRC_URI = " \ 8SRC_URI = "git://git.kernel.org/pub/scm/network/wireless/iwd.git \
9 git://git.kernel.org/pub/scm/network/wireless/iwd.git \ 9 file://0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch \
10 file://0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch \ 10 "
11 file://0001-build-Support-missing-rawmemchr.patch \ 11SRCREV = "1ee7b985aaa294447d073bfe1242744784278a8e"
12"
13SRCREV = "860fa4697f349da7791ecf22ca76f9ac0e5de261"
14S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
15 13
16inherit autotools manpages pkgconfig python3native systemd 14inherit autotools manpages pkgconfig python3native systemd