summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/iwd/iwd
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-04 16:43:51 -0800
committerKhem Raj <raj.khem@gmail.com>2019-11-06 06:32:14 -0800
commita9ebc44571dcfaaddc6255b07ed0141ba40f6b69 (patch)
tree020f4f8056c0f0951e9e3f1fbe67f31a2e341a32 /meta-oe/recipes-connectivity/iwd/iwd
parent3fc72e6efd71b414a833d4e7f4fb2c5e0b4f8189 (diff)
downloadmeta-openembedded-a9ebc44571dcfaaddc6255b07ed0141ba40f6b69.tar.gz
iwd: Fix build race during documentation build
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/iwd/iwd')
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd/0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/iwd/iwd/0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch b/meta-oe/recipes-connectivity/iwd/iwd/0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch
new file mode 100644
index 000000000..93ef007f8
--- /dev/null
+++ b/meta-oe/recipes-connectivity/iwd/iwd/0001-Makefile.am-Avoid-redirection-of-input-and-output-fi.patch
@@ -0,0 +1,40 @@
1From f2a2b9f445ab1e31fbb27a74744e9a2ededfce17 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 4 Nov 2019 16:38:04 -0800
4Subject: [PATCH] Makefile.am: Avoid redirection of input and output files
5
6Ensure that directory is created before its written to
7
8This can cause a build race in a highly parallelised build where a directory is not yet created but
9output file is being written using redirection e.g.
10
11rst2man.py --strict --no-raw --no-generator --no-datestamp < ../git/monitor/iwmon.rst > monitor/iwmon.1
12/bin/sh: monitor/iwmon.1: No such file or directory
13make[1]: *** [Makefile:3544: monitor/iwmon.1] Error 1
14
15Upstream-Status: Pending
16
17Signed-off-by: Khem Raj <raj.khem@gmail.com>
18---
19 Makefile.am | 5 +++--
20 1 file changed, 3 insertions(+), 2 deletions(-)
21
22diff --git a/Makefile.am b/Makefile.am
23index 823b7d02..1bd0005c 100644
24--- a/Makefile.am
25+++ b/Makefile.am
26@@ -626,8 +626,9 @@ SED_PROCESS = $(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(SED) \
27 < $< > $@
28
29 if RUN_RST2MAN
30-RST2MAN_PROCESS = $(AM_V_GEN)$(RST2MAN) --strict --no-raw --no-generator \
31- --no-datestamp < $< > $@
32+RST2MAN_PROCESS = $(AM_V_GEN)$(MKDIR_P) $(dir $@) && \
33+ $(AM_V_GEN)$(RST2MAN) --strict --no-raw \
34+ --no-generator --no-datestamp $< $@
35 else
36 RST2MAN_PROCESS = $(AM_V_GEN)test -f $@ || \
37 { echo "Generated manual page $@ does not exist"; false; }
38--
392.24.0
40