summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/iwd/iwd
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-04-04 20:04:51 -0700
committerKhem Raj <raj.khem@gmail.com>2021-04-18 11:59:09 -0700
commit9f34b0f0e80bd13a858d3e4d392b219055d5e07f (patch)
tree40b9609957a6ff5bb734114e049713ac5a6cb949 /meta-oe/recipes-connectivity/iwd/iwd
parent4784c7c62f6549577228f6830aebb33baa1ee931 (diff)
downloadmeta-openembedded-9f34b0f0e80bd13a858d3e4d392b219055d5e07f.tar.gz
iwd: Upgade to 1.13
Fix out of tree builds Switch to tarball fetch Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/iwd/iwd')
-rw-r--r--meta-oe/recipes-connectivity/iwd/iwd/0001-build-Use-abs_top_srcdir-instead-of-abs_srcdir-for-e.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/iwd/iwd/0001-build-Use-abs_top_srcdir-instead-of-abs_srcdir-for-e.patch b/meta-oe/recipes-connectivity/iwd/iwd/0001-build-Use-abs_top_srcdir-instead-of-abs_srcdir-for-e.patch
new file mode 100644
index 000000000..63d617f3e
--- /dev/null
+++ b/meta-oe/recipes-connectivity/iwd/iwd/0001-build-Use-abs_top_srcdir-instead-of-abs_srcdir-for-e.patch
@@ -0,0 +1,35 @@
1From 0532cddcec9c3abff1f3bc22d2fa50df03d55d17 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 5 Apr 2021 14:11:40 -0700
4Subject: [PATCH] build: Use abs_top_srcdir instead of abs_srcdir for ell sources
5
6this makes it build when build dir is outside of sources dir
7
8Upstream-Status: Submitted [https://lists.01.org/hyperkitty/list/iwd@lists.01.org/message/SYX6Z7SUQHU7UWM6ECZTTJ6SPODIS6KB/]
9---
10 Makefile.am | 4 ++--
11 1 file changed, 2 insertions(+), 2 deletions(-)
12
13--- a/Makefile.am
14+++ b/Makefile.am
15@@ -625,9 +625,10 @@ unit/tls-settings.8021x: unit/cert-ca.pe
16 BUILT_SOURCES = $(ell_built_sources) src/builtin.h
17
18 ell/shared: Makefile
19+ $(AM_V_at)$(MKDIR_P) ell
20 $(AM_V_GEN)for f in $(ell_shared) ; do \
21 if [ ! -f $$f ] ; then \
22- $(LN_S) -t ell -f $(abs_srcdir)/../ell/$$f ; \
23+ $(LN_S) -t ell -f $(abs_top_srcdir)/ell/$$f ; \
24 fi \
25 done > $@
26
27@@ -635,7 +636,7 @@ ell/internal: Makefile
28 $(AM_V_at)$(MKDIR_P) ell
29 $(AM_V_GEN)for f in $(ell_headers) $(ell_sources) ; do \
30 if [ ! -f $$f ] ; then \
31- $(LN_S) -t ell -f $(abs_srcdir)/../ell/$$f ; \
32+ $(LN_S) -t ell -f $(abs_top_srcdir)/ell/$$f ; \
33 fi \
34 done > $@
35