summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/iw
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-08 22:51:41 +0200
commit1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e (patch)
treea21a5fc103bb3bd65ecd85ed22be5228fc54e447 /meta-oe/recipes-connectivity/iw
downloadmeta-openembedded-1219bf8a90a7bf8cd3a5363551ef635d51e8fc8e.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta-oe/recipes-connectivity/iw')
-rw-r--r--meta-oe/recipes-connectivity/iw/iw/0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch43
-rw-r--r--meta-oe/recipes-connectivity/iw/iw_3.15.bb23
2 files changed, 66 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/iw/iw/0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch b/meta-oe/recipes-connectivity/iw/iw/0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch
new file mode 100644
index 000000000..e64dd0ad9
--- /dev/null
+++ b/meta-oe/recipes-connectivity/iw/iw/0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch
@@ -0,0 +1,43 @@
1From 5310abba864cfe3a8b65af130729447604190b29 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Tue, 29 Nov 2011 17:03:27 +0100
4Subject: [PATCH] iw: version.sh: don't use git describe for versioning
5
6It will detect top-level git repositories like the Angstrom setup-scripts and break.
7
8Upstream-Status: Unknown
9
10Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
11---
12 version.sh | 16 +---------------
13 1 file changed, 1 insertion(+), 15 deletions(-)
14
15diff --git a/version.sh b/version.sh
16index 11d124b..5d423c4 100755
17--- a/version.sh
18+++ b/version.sh
19@@ -3,21 +3,7 @@
20 VERSION="3.15"
21 OUT="$1"
22
23-if [ -d .git ] && head=`git rev-parse --verify HEAD 2>/dev/null`; then
24- git update-index --refresh --unmerged > /dev/null
25- descr=$(git describe)
26-
27- # on git builds check that the version number above
28- # is correct...
29- [ "${descr%%-*}" = "v$VERSION" ] || exit 2
30-
31- v="${descr#v}"
32- if git diff-index --name-only HEAD | read dummy ; then
33- v="$v"-dirty
34- fi
35-else
36- v="$VERSION"
37-fi
38+v="$VERSION"
39
40 echo '#include "iw.h"' > "$OUT"
41 echo "const char iw_version[] = \"$v\";" >> "$OUT"
42--
431.7.7.3
diff --git a/meta-oe/recipes-connectivity/iw/iw_3.15.bb b/meta-oe/recipes-connectivity/iw/iw_3.15.bb
new file mode 100644
index 000000000..7800e905e
--- /dev/null
+++ b/meta-oe/recipes-connectivity/iw/iw_3.15.bb
@@ -0,0 +1,23 @@
1SUMMARY = "nl80211 based CLI configuration utility for wireless devices"
2DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \
3wireless devices. It supports almost all new drivers that have been added \
4to the kernel recently. "
5HOMEPAGE = "http://wireless.kernel.org/en/users/Documentation/iw"
6SECTION = "base"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774"
9
10DEPENDS = "libnl pkgconfig"
11
12SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.gz \
13 file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \
14"
15
16SRC_URI[md5sum] = "ebb16e6c29b075e3a58b99552583fd79"
17SRC_URI[sha256sum] = "1223ebab68dc337f16ed80c45af37b78f112ea091e919eafe96a4cbd63942081"
18
19EXTRA_OEMAKE = ""
20
21do_install() {
22 oe_runmake DESTDIR=${D} install
23}